3.12.6
This commit is contained in:
parent
bf2cb338cf
commit
90fce7b6d2
1
.gitignore
vendored
1
.gitignore
vendored
@ -46,3 +46,4 @@ hplip-3.10.6.tar.gz
|
||||
/hplip-3.11.12.tar.gz
|
||||
/hplip-3.12.2.tar.gz
|
||||
/hplip-3.12.4.tar.gz
|
||||
/hplip-3.12.6.tar.gz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk+D8jEACgkQc9dwzaWQR7lIrgCgyhirUKUz1u/lF5bkkxBj6spG
|
||||
yAEAoMK7jiMHuSt9tuQ45Hmi2USWAS6r
|
||||
=Mj+M
|
||||
-----END PGP SIGNATURE-----
|
7
hplip-3.12.6.tar.gz.asc
Normal file
7
hplip-3.12.6.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.11 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk/fBzsACgkQc9dwzaWQR7n/hgCeLWOa+DwaRaS7AOKrxyPbLxJ8
|
||||
7ZsAoNhcYLg6Sx3u360POOnKw1tiN0qh
|
||||
=YfNt
|
||||
-----END PGP SIGNATURE-----
|
@ -1,17 +1,17 @@
|
||||
diff -up hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.clear-old-state-reasons hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.clear-old-state-reasons 2011-12-19 12:12:38.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp 2011-12-19 12:16:06.524701093 +0100
|
||||
@@ -502,6 +502,13 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
|
||||
signal(SIGTERM, HPCancelJob);
|
||||
|
||||
+/*
|
||||
diff -up hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp.clear-old-state-reasons hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp.clear-old-state-reasons 2012-06-19 11:00:06.000000000 +0200
|
||||
+++ hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp 2012-06-19 11:00:57.822093043 +0200
|
||||
@@ -510,6 +510,13 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
|
||||
signal(SIGTERM, HPCancelJob);
|
||||
|
||||
+/*
|
||||
+ * Prior to the re-write of hpcups, this filter managed the
|
||||
+ * marker-supply-low-warning printer state reason. Make sure to
|
||||
+ * clear that state reason so that upgrades work correctly.
|
||||
+ */
|
||||
+ fputs ("STATE: -marker-supply-low-warning\n", stderr);
|
||||
+
|
||||
cups_raster = cupsRasterOpen(fd, CUPS_RASTER_READ);
|
||||
|
||||
if (cups_raster == NULL) {
|
||||
+ */
|
||||
+ fputs ("STATE: -marker-supply-low-warning\n", stderr);
|
||||
+
|
||||
cups_raster = cupsRasterOpen(fd, CUPS_RASTER_READ);
|
||||
|
||||
if (cups_raster == NULL) {
|
||||
|
@ -1,34 +1,34 @@
|
||||
diff -up hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline 2011-12-19 12:16:37.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp 2011-12-19 12:22:02.957245073 +0100
|
||||
@@ -432,7 +432,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
m_DBusComm.sendEvent(EVENT_PRINT_FAILED_MISSING_PLUGIN, "Plugin missing", m_JA.job_id, m_JA.user_name);
|
||||
|
||||
}
|
||||
- dbglog ("m_Job initialization failed with error = %d", err);
|
||||
+ dbglog ("m_Job initialization failed with error = %d\n", err);
|
||||
ppdClose(m_ppd);
|
||||
m_ppd = NULL;
|
||||
return err;
|
||||
@@ -525,7 +525,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
- dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()", err);
|
||||
+ dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()\n", err);
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 1;
|
||||
@@ -535,7 +535,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
- dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()");
|
||||
+ dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()\n");
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 0;
|
||||
@@ -670,7 +670,7 @@ int HPCupsFilter::processRasterData(cups
|
||||
diff -up hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline 2012-06-19 11:01:38.000000000 +0200
|
||||
+++ hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp 2012-06-19 11:02:52.150529477 +0200
|
||||
@@ -440,7 +440,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
m_DBusComm.sendEvent(EVENT_PRINT_FAILED_MISSING_PLUGIN, "Plugin missing", m_JA.job_id, m_JA.user_name);
|
||||
|
||||
}
|
||||
- dbglog ("m_Job initialization failed with error = %d", err);
|
||||
+ dbglog ("m_Job initialization failed with error = %d\n", err);
|
||||
ppdClose(m_ppd);
|
||||
m_ppd = NULL;
|
||||
return err;
|
||||
@@ -533,7 +533,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
- dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()", err);
|
||||
+ dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()\n", err);
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 1;
|
||||
@@ -543,7 +543,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
- dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()");
|
||||
+ dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()\n");
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 0;
|
||||
@@ -678,7 +678,7 @@ int HPCupsFilter::processRasterData(cups
|
||||
//Need to revisit to crosscheck if it is a firmware issue.
|
||||
|
||||
*m_pPrinterBuffer = 0x01;
|
||||
@ -36,10 +36,10 @@ diff -up hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.11.12
|
||||
+ dbglog("First raster data plane..\n" );
|
||||
}
|
||||
|
||||
if (this->isBlankRaster((BYTE *) m_pPrinterBuffer, &cups_header)) {
|
||||
diff -up hplip-3.11.12/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.11.12/prnt/hpcups/Lidil.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/Lidil.cpp.dbglog-newline 2011-12-09 12:17:50.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/Lidil.cpp 2011-12-19 12:16:39.063294307 +0100
|
||||
if (this->isBlankRaster((BYTE *) m_pPrinterBuffer, &cups_header)) {
|
||||
diff -up hplip-3.12.6/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.12.6/prnt/hpcups/Lidil.cpp
|
||||
--- hplip-3.12.6/prnt/hpcups/Lidil.cpp.dbglog-newline 2012-06-18 12:40:17.000000000 +0200
|
||||
+++ hplip-3.12.6/prnt/hpcups/Lidil.cpp 2012-06-19 11:01:39.598521705 +0200
|
||||
@@ -103,7 +103,7 @@ DRIVER_ERROR Lidil::Configure(Pipeline *
|
||||
if (m_pPM->BaseResX != m_pQA->horizontal_resolution ||
|
||||
m_pPM->BaseResY != m_pQA->vertical_resolution)
|
||||
@ -94,9 +94,9 @@ diff -up hplip-3.11.12/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.11.12/prnt/h
|
||||
return false;
|
||||
}
|
||||
|
||||
diff -up hplip-3.11.12/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.11.12/prnt/hpcups/Pcl3.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/Pcl3.cpp.dbglog-newline 2011-12-09 12:17:50.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/Pcl3.cpp 2011-12-19 12:16:39.107293756 +0100
|
||||
diff -up hplip-3.12.6/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.12.6/prnt/hpcups/Pcl3.cpp
|
||||
--- hplip-3.12.6/prnt/hpcups/Pcl3.cpp.dbglog-newline 2012-06-18 12:40:17.000000000 +0200
|
||||
+++ hplip-3.12.6/prnt/hpcups/Pcl3.cpp 2012-06-19 11:01:39.599521691 +0200
|
||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3::Configure(Pipeline **
|
||||
|
||||
if (!selectPrintMode())
|
||||
@ -140,9 +140,9 @@ diff -up hplip-3.11.12/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.11.12/prnt/hp
|
||||
return false;
|
||||
}
|
||||
|
||||
diff -up hplip-3.11.12/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline hplip-3.11.12/prnt/hpcups/Pcl3Gui.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline 2011-12-09 12:17:50.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/Pcl3Gui.cpp 2011-12-19 12:16:39.156293143 +0100
|
||||
diff -up hplip-3.12.6/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline hplip-3.12.6/prnt/hpcups/Pcl3Gui.cpp
|
||||
--- hplip-3.12.6/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline 2012-06-18 12:40:17.000000000 +0200
|
||||
+++ hplip-3.12.6/prnt/hpcups/Pcl3Gui.cpp 2012-06-19 11:01:39.599521691 +0200
|
||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3Gui::Configure(Pipeline
|
||||
|
||||
if (!selectPrintMode())
|
||||
|
@ -1,30 +1,30 @@
|
||||
diff -up hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.mucks-with-spooldir hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.mucks-with-spooldir 2011-12-09 12:17:50.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp 2011-12-19 12:02:03.581239338 +0100
|
||||
@@ -466,26 +466,6 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
|
||||
getLogLevel();
|
||||
m_JA.job_id = atoi(argv[1]);
|
||||
- FILE *fp;
|
||||
- char dFileName[32];
|
||||
- memset(dFileName, 0, sizeof(dFileName));
|
||||
- m_JA.job_id = atoi(argv[1]);
|
||||
- snprintf (dFileName, sizeof(dFileName), "/var/spool/cups/d%05d-001", m_JA.job_id);
|
||||
- if ((fp = fopen (dFileName, "r")))
|
||||
- {
|
||||
- char line[258];
|
||||
- for (int i = 0; i < 10; i++)
|
||||
- {
|
||||
- fgets (line, 256, fp);
|
||||
- if (!strncmp (line, "%%Pages:", 8))
|
||||
- {
|
||||
- sscanf (line+9, "%d", &m_JA.total_pages);
|
||||
- break;
|
||||
- }
|
||||
- }
|
||||
- fclose (fp);
|
||||
- }
|
||||
-
|
||||
m_ppd = ppdOpenFile(getenv("PPD"));
|
||||
if (m_ppd == NULL) {
|
||||
dbglog("DEBUG: ppdOpenFile failed for %s\n", getenv("PPD"));
|
||||
diff -up hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp.mucks-with-spooldir hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp.mucks-with-spooldir 2012-06-18 12:40:17.000000000 +0200
|
||||
+++ hplip-3.12.6/prnt/hpcups/HPCupsFilter.cpp 2012-06-19 10:55:05.325913806 +0200
|
||||
@@ -474,26 +474,6 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
|
||||
getLogLevel();
|
||||
m_JA.job_id = atoi(argv[1]);
|
||||
- FILE *fp;
|
||||
- char dFileName[32];
|
||||
- memset(dFileName, 0, sizeof(dFileName));
|
||||
- m_JA.job_id = atoi(argv[1]);
|
||||
- snprintf (dFileName, sizeof(dFileName), "/var/spool/cups/d%05d-001", m_JA.job_id);
|
||||
- if ((fp = fopen (dFileName, "r")))
|
||||
- {
|
||||
- char line[258];
|
||||
- for (int i = 0; i < 10; i++)
|
||||
- {
|
||||
- fgets (line, 256, fp);
|
||||
- if (!strncmp (line, "%%Pages:", 8))
|
||||
- {
|
||||
- sscanf (line+9, "%d", &m_JA.total_pages);
|
||||
- break;
|
||||
- }
|
||||
- }
|
||||
- fclose (fp);
|
||||
- }
|
||||
-
|
||||
m_ppd = ppdOpenFile(getenv("PPD"));
|
||||
if (m_ppd == NULL) {
|
||||
dbglog("DEBUG: ppdOpenFile failed for %s\n", getenv("PPD"));
|
||||
|
@ -1,16 +1,7 @@
|
||||
diff -up hplip-3.10.6/prnt/drv/hpcups.drv.in.snmp-quirks hplip-3.10.6/prnt/drv/hpcups.drv.in
|
||||
--- hplip-3.10.6/prnt/drv/hpcups.drv.in.snmp-quirks 2010-08-20 18:03:46.026041759 +0100
|
||||
+++ hplip-3.10.6/prnt/drv/hpcups.drv.in 2010-08-20 18:04:26.210041811 +0100
|
||||
@@ -5318,6 +5318,8 @@ Manufacturer "HP"
|
||||
Attribute "NickName" "" "HP Officejet Pro 8500 a909g, $Version"
|
||||
Attribute "ShortNickName" "" "HP Officejet Pro 8500 a909g"
|
||||
Attribute "1284DeviceID" "" "MFG:HP;MDL:officejet pro 8500 a909g;DES:officejet pro 8500 a909g;"
|
||||
+ // This device lies about its supplies capacity.
|
||||
+ Attribute "cupsSNMPQuirks" "" "capacity"
|
||||
PCFileName "hp-officejet_pro_8500_a909g.ppd"
|
||||
Attribute "Product" "" "(HP Officejet Pro 8500 Wireless All-in-one Printer - a909g)"
|
||||
}
|
||||
@@ -5326,6 +5328,8 @@ Manufacturer "HP"
|
||||
diff -up hplip-3.12.6/prnt/drv/hpcups.drv.in.snmp-quirks hplip-3.12.6/prnt/drv/hpcups.drv.in
|
||||
--- hplip-3.12.6/prnt/drv/hpcups.drv.in.snmp-quirks 2012-06-19 10:58:26.121167716 +0200
|
||||
+++ hplip-3.12.6/prnt/drv/hpcups.drv.in 2012-06-19 10:59:16.880473528 +0200
|
||||
@@ -6653,6 +6653,8 @@ Manufacturer "HP"
|
||||
Attribute "NickName" "" "HP Officejet Pro 8500 a909a, $Version"
|
||||
Attribute "ShortNickName" "" "HP Officejet Pro 8500 a909a"
|
||||
Attribute "1284DeviceID" "" "MFG:HP;MDL:officejet pro 8500 a909a;DES:officejet pro 8500 a909a;"
|
||||
@ -19,3 +10,12 @@ diff -up hplip-3.10.6/prnt/drv/hpcups.drv.in.snmp-quirks hplip-3.10.6/prnt/drv/h
|
||||
PCFileName "hp-officejet_pro_8500_a909a.ppd"
|
||||
Attribute "Product" "" "(HP Officejet Pro 8500 All-in-one Printer - a909a)"
|
||||
}
|
||||
@@ -6669,6 +6671,8 @@ Manufacturer "HP"
|
||||
Attribute "NickName" "" "HP Officejet Pro 8500 a909g, $Version"
|
||||
Attribute "ShortNickName" "" "HP Officejet Pro 8500 a909g"
|
||||
Attribute "1284DeviceID" "" "MFG:HP;MDL:officejet pro 8500 a909g;DES:officejet pro 8500 a909g;"
|
||||
+ // This device lies about its supplies capacity.
|
||||
+ Attribute "cupsSNMPQuirks" "" "capacity"
|
||||
PCFileName "hp-officejet_pro_8500_a909g.ppd"
|
||||
Attribute "Product" "" "(HP Officejet Pro 8500 Wireless All-in-one Printer - a909g)"
|
||||
}
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up hplip-3.12.4/data/rules/56-hpmud_support.rules.udev-rules hplip-3.12.4/data/rules/56-hpmud_support.rules
|
||||
--- hplip-3.12.4/data/rules/56-hpmud_support.rules.udev-rules 2012-04-10 10:34:19.000000000 +0200
|
||||
+++ hplip-3.12.4/data/rules/56-hpmud_support.rules 2012-04-12 12:31:05.120241342 +0200
|
||||
diff -up hplip-3.12.6/data/rules/56-hpmud_support.rules.udev-rules hplip-3.12.6/data/rules/56-hpmud_support.rules
|
||||
--- hplip-3.12.6/data/rules/56-hpmud_support.rules.udev-rules 2012-06-18 12:43:22.000000000 +0200
|
||||
+++ hplip-3.12.6/data/rules/56-hpmud_support.rules 2012-06-19 10:56:21.451872702 +0200
|
||||
@@ -6,6 +6,7 @@ SUBSYSTEM!="usb_device", GOTO="hpmud_rul
|
||||
|
||||
LABEL="pid_test"
|
||||
@ -9,15 +9,15 @@ diff -up hplip-3.12.4/data/rules/56-hpmud_support.rules.udev-rules hplip-3.12.4/
|
||||
# Check for LaserJet products (0x03f0xx17).
|
||||
ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??17", ENV{hp_model}="$attrs{product}", ENV{hp_test}="yes"
|
||||
# Check for LaserJet products (0x03f0xx2a).
|
||||
diff -up hplip-3.12.4/Makefile.in.udev-rules hplip-3.12.4/Makefile.in
|
||||
--- hplip-3.12.4/Makefile.in.udev-rules 2012-04-10 10:38:51.000000000 +0200
|
||||
+++ hplip-3.12.4/Makefile.in 2012-04-12 12:36:40.806539034 +0200
|
||||
@@ -4119,7 +4119,7 @@ cups_drv = prnt/drv/hpcups.drv
|
||||
diff -up hplip-3.12.6/Makefile.in.udev-rules hplip-3.12.6/Makefile.in
|
||||
--- hplip-3.12.6/Makefile.in.udev-rules 2012-06-18 12:44:46.000000000 +0200
|
||||
+++ hplip-3.12.6/Makefile.in 2012-06-19 10:57:37.812828378 +0200
|
||||
@@ -4274,7 +4274,7 @@ cups_drv = prnt/drv/hpcups.drv
|
||||
@HPLIP_BUILD_TRUE@hp_mkuri_CFLAGS = -DCONFDIR=\"$(hplip_confdir)\"
|
||||
|
||||
# hpmud.rules
|
||||
-@HPLIP_BUILD_TRUE@rulesdir = /etc/udev/rules.d
|
||||
+@HPLIP_BUILD_TRUE@rulesdir = /lib/udev/rules.d
|
||||
@HPLIP_BUILD_TRUE@dist_rules_DATA = data/rules/56-hpmud_support.rules \
|
||||
@HPLIP_BUILD_TRUE@ data/rules/86-hpmud_plugin.rules \
|
||||
@HPLIP_BUILD_TRUE@ data/rules/56-hpmud_add_printer.rules \
|
||||
+@HPLIP_BUILD_TRUE@rulesdir = /usr/lib/udev/rules.d
|
||||
@HPLIP_BUILD_TRUE@@UDEV_SYSFS_RULES_FALSE@dist_rules_DATA = data/rules/56-hpmud_support.rules \
|
||||
@HPLIP_BUILD_TRUE@@UDEV_SYSFS_RULES_FALSE@ data/rules/86-hpmud_plugin.rules \
|
||||
@HPLIP_BUILD_TRUE@@UDEV_SYSFS_RULES_FALSE@ data/rules/56-hpmud_add_printer.rules \
|
||||
|
11
hplip.spec
11
hplip.spec
@ -1,6 +1,6 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.12.4
|
||||
Version: 3.12.6
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and MIT
|
||||
Group: System Environment/Daemons
|
||||
@ -11,7 +11,7 @@ Obsoletes: xojpanel < 0.91
|
||||
Provides: xojpanel = 0.91
|
||||
|
||||
Url: http://hplip.sourceforge.net/
|
||||
Source0: http://kent.dl.sourceforge.net/sourceforge/hplip/%{name}-%{version}.tar.gz
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/hplip/hplip-%{version}.tar.gz
|
||||
Source1: hpcups-update-ppds.sh
|
||||
Source2: copy-deviceids.py
|
||||
Patch1: hplip-pstotiff-is-rubbish.patch
|
||||
@ -63,7 +63,7 @@ BuildRequires: cups-devel
|
||||
BuildRequires: python-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: libusb-devel
|
||||
BuildRequires: libusb1-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: sane-backends-devel
|
||||
BuildRequires: dbus-devel
|
||||
@ -464,7 +464,7 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
|
||||
%files common
|
||||
%doc COPYING
|
||||
/lib/udev/rules.d/*.rules
|
||||
%{_prefix}/lib/udev/rules.d/*.rules
|
||||
%dir %{_sysconfdir}/hp
|
||||
%config(noreplace) %{_sysconfdir}/hp/hplip.conf
|
||||
%dir %{_datadir}/hplip
|
||||
@ -528,6 +528,9 @@ fi
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Tue Jun 19 2012 Jiri Popelka <jpopelka@redhat.com> 3.12.6-1
|
||||
- 3.12.6
|
||||
|
||||
* Thu Apr 12 2012 Jiri Popelka <jpopelka@redhat.com> 3.12.4-1
|
||||
- 3.12.4
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user