Update to 4.5.0

This commit is contained in:
Kalev Lember 2021-11-01 13:21:01 +01:00
parent 756eb68d21
commit 9e7b8da1af
4 changed files with 13 additions and 37 deletions

1
.gitignore vendored
View File

@ -23,3 +23,4 @@
/gtk-4.2.0.tar.xz
/gtk-4.2.1.tar.xz
/gtk-4.4.0.tar.xz
/gtk-4.5.0.tar.xz

View File

@ -1,29 +0,0 @@
From 552a4b2c82f41c1dbba410b825673cf67d089b68 Mon Sep 17 00:00:00 2001
From: Kalev Lember <klember@redhat.com>
Date: Mon, 23 Aug 2021 15:38:46 +0200
Subject: [PATCH] build: Fix detection for pre-compiled css files
The default theme changed from Adwaita to Default and this tripped up
the logic to detect if the tarball builds contain pre-built css files or
not. Fix this by looking at pre-compiled css files in themes/Default/
instead of themes/Adwaita/.
---
gtk/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/gtk/meson.build b/gtk/meson.build
index fa66764c50..bfb5105fe5 100644
--- a/gtk/meson.build
+++ b/gtk/meson.build
@@ -842,7 +842,7 @@ gtk_gresources_xml = configure_file(output: 'gtk.gresources.xml',
theme_deps = []
# For git checkouts, but not for tarballs...
-if not fs.exists('theme/Adwaita/Adwaita.css')
+if not fs.exists('theme/Default/Default-light.css')
# ... build the theme files
sassc = find_program('sassc', required: false)
if not sassc.found()
--
2.31.1

View File

@ -3,7 +3,7 @@
%endif
%global glib2_version 2.66.0
%global pango_version 1.47.0
%global pango_version 1.49.1
%global cairo_version 1.14.0
%global gdk_pixbuf_version 2.30.0
%global wayland_protocols_version 1.21
@ -16,15 +16,13 @@
%global __provides_exclude_from ^%{_libdir}/gtk-4.0
Name: gtk4
Version: 4.4.0
Release: 4%{?dist}
Version: 4.5.0
Release: 1%{?dist}
Summary: GTK graphical user interface library
License: LGPLv2+
URL: https://www.gtk.org
Source0: https://download.gnome.org/sources/gtk/4.4/gtk-%{version}.tar.xz
# Backported from upstream
Patch0: 0001-build-Fix-detection-for-pre-compiled-css-files.patch
Source0: https://download.gnome.org/sources/gtk/4.5/gtk-%{version}.tar.xz
BuildRequires: cups-devel
BuildRequires: desktop-file-utils
@ -46,6 +44,9 @@ BuildRequires: pkgconfig(gobject-introspection-1.0)
BuildRequires: pkgconfig(graphene-gobject-1.0)
BuildRequires: pkgconfig(gstreamer-player-1.0)
BuildRequires: pkgconfig(json-glib-1.0)
BuildRequires: pkgconfig(libjpeg)
BuildRequires: pkgconfig(libpng)
BuildRequires: pkgconfig(libtiff-4)
BuildRequires: pkgconfig(pango) >= %{pango_version}
BuildRequires: pkgconfig(rest-0.7)
BuildRequires: pkgconfig(sysprof-4)
@ -64,7 +65,7 @@ BuildRequires: pkgconfig(xinerama)
BuildRequires: pkgconfig(xkbcommon)
BuildRequires: pkgconfig(xrandr)
BuildRequires: pkgconfig(xrender)
BuildRequires: /usr/bin/xsltproc
BuildRequires: /usr/bin/rst2man
# standard icons
Requires: adwaita-icon-theme
@ -226,6 +227,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
%{_mandir}/man1/gtk4-widget-factory.1*
%changelog
* Mon Nov 01 2021 Kalev Lember <klember@redhat.com> - 4.5.0-1
- Update to 4.5.0
* Mon Sep 27 2021 Kalev Lember <klember@redhat.com> - 4.4.0-4
- Build with tracker support enabled (#1908874)

View File

@ -1 +1 @@
SHA512 (gtk-4.4.0.tar.xz) = de0b6508df3fa4523a7e54cf417ac31292c833346409ff89fd4daf886edad16ffe60b6ed77a85451bd36b96098c8437d56c6fd42daca33c52db8dc57a25753b6
SHA512 (gtk-4.5.0.tar.xz) = 07b776a0a0b96cb257e6788c1c9eafbd4f16e688f455a4255abf240fa693c1506c49d78e4ca50bd2eeab0474b8b065673dc96f4bf8d0fe50792a1ac1bcbcceae