Use Fedora standard linker flags
- Resolves rhbz#1543502 Signed-off-by: Rafael dos Santos <rdossant@redhat.com>
This commit is contained in:
parent
eedee25066
commit
a631596958
25
0004-Use-system-LDFLAGS.patch
Normal file
25
0004-Use-system-LDFLAGS.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From fbc4d4feef66df7224fde64adae95525e73bf141 Mon Sep 17 00:00:00 2001
|
||||
From: Rafael dos Santos <rdossant@redhat.com>
|
||||
Date: Tue, 29 May 2018 15:15:24 +0200
|
||||
Subject: [PATCH] Use system LDFLAGS
|
||||
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index ac14404..f0d1372 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -25,7 +25,7 @@ OBJECTS = grubby.o log.o
|
||||
CC = gcc
|
||||
RPM_OPT_FLAGS ?= -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector
|
||||
CFLAGS += $(RPM_OPT_FLAGS) -std=gnu99 -Wall -Werror -Wno-error=unused-function -Wno-unused-function -ggdb
|
||||
-LDFLAGS :=
|
||||
+LDFLAGS := $(RPM_LD_FLAGS)
|
||||
|
||||
grubby_LIBS = -lblkid -lpopt
|
||||
|
||||
--
|
||||
2.17.0
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: grubby
|
||||
Version: 8.40
|
||||
Release: 12%{?dist}
|
||||
Release: 13%{?dist}
|
||||
Summary: Command line tool for updating bootloader configs
|
||||
License: GPLv2+
|
||||
URL: https://github.com/rhinstaller/grubby
|
||||
@ -13,6 +13,7 @@ Patch1: drop-uboot-uImage-creation.patch
|
||||
Patch2: 0001-Change-return-type-in-getRootSpecifier.patch
|
||||
Patch3: 0002-Add-btrfs-subvolume-support-for-grub2.patch
|
||||
Patch4: 0003-Add-tests-for-btrfs-support.patch
|
||||
Patch5: 0004-Use-system-LDFLAGS.patch
|
||||
|
||||
BuildRequires: pkgconfig glib2-devel popt-devel
|
||||
BuildRequires: libblkid-devel git-core
|
||||
@ -71,6 +72,9 @@ fi
|
||||
%{_mandir}/man8/*.8*
|
||||
|
||||
%changelog
|
||||
* Tue May 29 2018 Rafael dos Santos <rdossant@redhat.com> - 8.40-13
|
||||
- Use standard Fedora linker flags (rhbz#1543502)
|
||||
|
||||
* Tue Apr 10 2018 Javier Martinez Canillas <javierm@redhat.com> - 8.40-12
|
||||
- Use .rpmsave as backup suffix when switching to BLS configuration
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user