Move grubby-bls to grubby and obsolete the old grubby package
Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
parent
19db5c489a
commit
214bb840df
36
0004-Honor-sbindir.patch
Normal file
36
0004-Honor-sbindir.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
From a56df998177574ef2db332220c15f11bccd98f7e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Jones <pjones@redhat.com>
|
||||||
|
Date: Wed, 18 Jul 2018 13:41:02 -0400
|
||||||
|
Subject: [PATCH] Honor sbindir
|
||||||
|
|
||||||
|
Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||||
|
---
|
||||||
|
Makefile | 8 ++++----
|
||||||
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index ac144046133..2b18dd6404b 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -42,14 +42,14 @@ test: all
|
||||||
|
@./test.sh
|
||||||
|
|
||||||
|
install: all
|
||||||
|
- mkdir -p $(DESTDIR)$(PREFIX)/sbin
|
||||||
|
+ mkdir -p $(DESTDIR)$(PREFIX)$(sbindir)
|
||||||
|
mkdir -p $(DESTDIR)/$(mandir)/man8
|
||||||
|
- install -m 755 new-kernel-pkg $(DESTDIR)$(PREFIX)/sbin
|
||||||
|
+ install -m 755 new-kernel-pkg $(DESTDIR)$(PREFIX)$(sbindir)
|
||||||
|
install -m 644 new-kernel-pkg.8 $(DESTDIR)/$(mandir)/man8
|
||||||
|
- install -m 755 installkernel $(DESTDIR)$(PREFIX)/sbin
|
||||||
|
+ install -m 755 installkernel $(DESTDIR)$(PREFIX)$(sbindir)
|
||||||
|
install -m 644 installkernel.8 $(DESTDIR)/$(mandir)/man8
|
||||||
|
if [ -f grubby ]; then \
|
||||||
|
- install -m 755 grubby $(DESTDIR)$(PREFIX)/sbin ; \
|
||||||
|
+ install -m 755 grubby $(DESTDIR)$(PREFIX)$(sbindir) ; \
|
||||||
|
install -m 644 grubby.8 $(DESTDIR)/$(mandir)/man8 ; \
|
||||||
|
fi
|
||||||
|
|
||||||
|
--
|
||||||
|
2.17.1
|
||||||
|
|
29
grubby.spec
29
grubby.spec
@ -4,6 +4,9 @@ Release: 15%{?dist}
|
|||||||
Summary: Command line tool for updating bootloader configs
|
Summary: Command line tool for updating bootloader configs
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://github.com/rhinstaller/grubby
|
URL: https://github.com/rhinstaller/grubby
|
||||||
|
Obsoletes: %{name} <= 8.40-14
|
||||||
|
Obsoletes: %{name}-bls <= 8.40-14
|
||||||
|
|
||||||
# we only pull git snaps at the moment
|
# we only pull git snaps at the moment
|
||||||
# git clone git@github.com:rhinstaller/grubby.git
|
# git clone git@github.com:rhinstaller/grubby.git
|
||||||
# git archive --format=tar --prefix=grubby-%%{version}/ HEAD |bzip2 > grubby-%%{version}.tar.bz2
|
# git archive --format=tar --prefix=grubby-%%{version}/ HEAD |bzip2 > grubby-%%{version}.tar.bz2
|
||||||
@ -15,6 +18,7 @@ Patch2: 0001-Change-return-type-in-getRootSpecifier.patch
|
|||||||
Patch3: 0002-Add-btrfs-subvolume-support-for-grub2.patch
|
Patch3: 0002-Add-btrfs-subvolume-support-for-grub2.patch
|
||||||
Patch4: 0003-Add-tests-for-btrfs-support.patch
|
Patch4: 0003-Add-tests-for-btrfs-support.patch
|
||||||
Patch5: 0004-Use-system-LDFLAGS.patch
|
Patch5: 0004-Use-system-LDFLAGS.patch
|
||||||
|
Patch6: 0004-Honor-sbindir.patch
|
||||||
|
|
||||||
BuildRequires: pkgconfig glib2-devel popt-devel
|
BuildRequires: pkgconfig glib2-devel popt-devel
|
||||||
BuildRequires: libblkid-devel git-core
|
BuildRequires: libblkid-devel git-core
|
||||||
@ -59,30 +63,21 @@ make test
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir}
|
make install DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} sbindir=%{_sbindir}
|
||||||
|
|
||||||
rm %{buildroot}/sbin/installkernel
|
rm %{buildroot}%{_sbindir}/installkernel
|
||||||
rm %{buildroot}/sbin/new-kernel-pkg
|
rm %{buildroot}%{_sbindir}/new-kernel-pkg
|
||||||
cp %{SOURCE1} %{buildroot}/sbin/grubby
|
cp %{SOURCE1} %{buildroot}%{_sbindir}/grubby
|
||||||
|
|
||||||
%package bls
|
%files
|
||||||
Summary: Command line tool for updating BootLoaderSpec files
|
|
||||||
Obsoletes: %{name} < 8.40-15
|
|
||||||
BuildArch: noarch
|
|
||||||
|
|
||||||
%description bls
|
|
||||||
This package provides a grubby wrapper that manages BootLoaderSpec files and is
|
|
||||||
meant to only be used for legacy compatibility users with existing grubby users.
|
|
||||||
|
|
||||||
%files bls
|
|
||||||
%{!?_licensedir:%global license %%doc}
|
%{!?_licensedir:%global license %%doc}
|
||||||
%license COPYING
|
%license COPYING
|
||||||
/sbin/grubby
|
%{_sbindir}/grubby
|
||||||
%{_mandir}/man8/*.8*
|
%{_mandir}/man8/*.8*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Fri Jul 13 2018 Javier Martinez Canillas <javierm@redhat.com> - 8.40-15
|
* Wed Jul 18 2018 Peter Jones <pjones@redhat.com> - 8.40-15
|
||||||
- Add a grubby-bls package that contains grubby-bls script and obsoletes grubby
|
- Move grubby-bls to grubby and obsolete the old grubby package
|
||||||
|
|
||||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.40-14
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.40-14
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
Loading…
Reference in New Issue
Block a user