29 lines
1.1 KiB
Diff
29 lines
1.1 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Peter Jones <pjones@redhat.com>
|
|
Date: Tue, 26 Jun 2018 17:16:06 -0400
|
|
Subject: [PATCH] Minor fixes to make armv7hl build as arm-efi
|
|
|
|
- /remove/ the code to use use softfloat unconditionally on arm
|
|
(I can't get our arm bins to build with it for whatever reason...)
|
|
- Fix one type error
|
|
- build the secure boot loader code on arm
|
|
|
|
Signed-off-by: Peter Jones <pjones@redhat.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 5f47a9265f3..b3af931e958 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -854,7 +854,7 @@ fi
|
|
# that floats are a good fit to run instead of what's written in the code.
|
|
# Given that floating point unit is disabled (if present to begin with)
|
|
# when GRUB is running which may result in various hard crashes.
|
|
-if test x"$platform" != xemu ; then
|
|
+if test x"$platform" != xemu -a "x$target_cpu" != xarm ; then
|
|
AC_CACHE_CHECK([for options to get soft-float], grub_cv_target_cc_soft_float, [
|
|
grub_cv_target_cc_soft_float=no
|
|
if test "x$target_cpu" = xarm64; then
|