Once more...
This commit is contained in:
parent
ad4aff0c12
commit
70dc0337f9
@ -25,7 +25,7 @@ I'm currently test-building this patch (replacing your current
|
||||
grub-2.00-no-insmod-on-sb.patch), but this should be more correct. It
|
||||
moves the check into grub_dl_load_file.
|
||||
---
|
||||
grub-core/Makefile.core.def | 17 +-
|
||||
grub-core/Makefile.core.def | 16 +-
|
||||
grub-core/kern/dl.c | 21 +++
|
||||
grub-core/kern/efi/efi.c | 28 ++++
|
||||
grub-core/kern/efi/mm.c | 32 ++++
|
||||
@ -37,13 +37,13 @@ moves the check into grub_dl_load_file.
|
||||
include/grub/efi/efi.h | 4 +
|
||||
include/grub/efi/linux.h | 31 ++++
|
||||
include/grub/i386/linux.h | 1 +
|
||||
12 files changed, 606 insertions(+), 66 deletions(-)
|
||||
12 files changed, 605 insertions(+), 66 deletions(-)
|
||||
create mode 100644 grub-core/loader/efi/linux.c
|
||||
create mode 100644 grub-core/loader/i386/efi/linux.c
|
||||
create mode 100644 include/grub/efi/linux.h
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index fc4767f1985..622381f5208 100644
|
||||
index fc4767f1985..7a18bf28c7c 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -1627,13 +1627,6 @@ module = {
|
||||
@ -71,11 +71,10 @@ index fc4767f1985..622381f5208 100644
|
||||
xen = loader/i386/xen.c;
|
||||
i386_pc = lib/i386/pc/vesa_modes_table.c;
|
||||
mips = loader/mips/linux.c;
|
||||
@@ -1695,9 +1690,15 @@ module = {
|
||||
@@ -1695,9 +1690,14 @@ module = {
|
||||
ia64_efi = loader/ia64/efi/linux.c;
|
||||
arm = loader/arm/linux.c;
|
||||
arm64 = loader/arm64/linux.c;
|
||||
+ arm64 = loader/efi/linux.c;
|
||||
+ emu = loader/emu/linux.c;
|
||||
+ fdt = lib/fdt.c;
|
||||
+
|
||||
|
@ -1173,7 +1173,7 @@ index adc85636633..af2189619a3 100644
|
||||
|
||||
return grub_errno;
|
||||
diff --git a/grub-core/loader/efi/linux.c b/grub-core/loader/efi/linux.c
|
||||
index aea378adf5c..dbf63e20ed8 100644
|
||||
index aea378adf5c..5c2c614c380 100644
|
||||
--- a/grub-core/loader/efi/linux.c
|
||||
+++ b/grub-core/loader/efi/linux.c
|
||||
@@ -33,21 +33,34 @@ struct grub_efi_shim_lock
|
||||
@ -1202,7 +1202,7 @@ index aea378adf5c..dbf63e20ed8 100644
|
||||
- return 1;
|
||||
+ grub_dprintf ("secureboot", "Asking shim to verify kernel signature\n");
|
||||
+ status = shim_lock->verify (data, size);
|
||||
+ grub_dprintf ("secureboot", "shim_lock->verify(): %ld\n", status);
|
||||
+ grub_dprintf ("secureboot", "shim_lock->verify(): %ld\n", (long int)status);
|
||||
+ if (status == GRUB_EFI_SUCCESS)
|
||||
+ {
|
||||
+ grub_dprintf ("secureboot", "Kernel signature verification passed\n");
|
||||
|
@ -38,7 +38,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
create mode 100644 include/grub/sparc64/linux.h
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 622381f5208..52911374be5 100644
|
||||
index 7a18bf28c7c..c16907b5f91 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -195,6 +195,7 @@ kernel = {
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
3 files changed, 88 insertions(+), 37 deletions(-)
|
||||
|
||||
diff --git a/grub-core/loader/efi/linux.c b/grub-core/loader/efi/linux.c
|
||||
index dbf63e20ed8..7fe7201a388 100644
|
||||
index 5c2c614c380..8453b5c8017 100644
|
||||
--- a/grub-core/loader/efi/linux.c
|
||||
+++ b/grub-core/loader/efi/linux.c
|
||||
@@ -66,12 +66,17 @@ grub_linuxefi_secure_validate (void *data, grub_uint32_t size)
|
||||
|
@ -10,7 +10,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
2 files changed, 34 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 52911374be5..6b652231ecc 100644
|
||||
index c16907b5f91..5c06c7b845c 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -191,6 +191,7 @@ kernel = {
|
||||
|
@ -21,7 +21,7 @@ Signed-off-by: Peter Jones <grub2-owner@fedoraproject.org>
|
||||
create mode 100644 grub-core/commands/blscfg.c
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 6b652231ecc..7ed07b3e2fd 100644
|
||||
index 5c06c7b845c..bd529ee8c45 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -769,6 +769,14 @@ module = {
|
||||
|
@ -20,10 +20,10 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
create mode 100644 include/grub/net/url.h
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 7ed07b3e2fd..8a0193fa5e3 100644
|
||||
index bd529ee8c45..6e7c4a4999d 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -2185,6 +2185,7 @@ module = {
|
||||
@@ -2184,6 +2184,7 @@ module = {
|
||||
common = net/ethernet.c;
|
||||
common = net/arp.c;
|
||||
common = net/netbuff.c;
|
||||
|
@ -13,7 +13,7 @@ Subject: [PATCH] Make grub_fatal() also backtrace.
|
||||
create mode 100644 grub-core/lib/arm64/backtrace.c
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 8a0193fa5e3..9983d5fa6ad 100644
|
||||
index 6e7c4a4999d..86c8e38e880 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -175,6 +175,9 @@ kernel = {
|
||||
|
@ -12,15 +12,15 @@ GRUB2 already has a blscfg modle that can parse the config snippets using
|
||||
the bls_import command, change it to blscfg and improve the BLS support.
|
||||
---
|
||||
grub-core/Makefile.core.def | 4 +-
|
||||
grub-core/commands/blscfg.c | 788 ++++++++++++++++++++++++++++++++++++++++---
|
||||
grub-core/commands/blscfg.c | 796 ++++++++++++++++++++++++++++++++++++++++---
|
||||
grub-core/commands/loadenv.c | 77 +----
|
||||
grub-core/commands/loadenv.h | 93 +++++
|
||||
include/grub/compiler.h | 2 +
|
||||
5 files changed, 832 insertions(+), 132 deletions(-)
|
||||
5 files changed, 840 insertions(+), 132 deletions(-)
|
||||
create mode 100644 grub-core/commands/loadenv.h
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 9983d5fa6ad..5cbebe50661 100644
|
||||
index 86c8e38e880..27ee5117b79 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -129,6 +129,7 @@ kernel = {
|
||||
@ -42,7 +42,7 @@ index 9983d5fa6ad..5cbebe50661 100644
|
||||
};
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 4274aca5a9d..9ab45631465 100644
|
||||
index 4274aca5a9d..86796c8cd83 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -30,32 +30,405 @@
|
||||
@ -920,7 +920,11 @@ index 4274aca5a9d..9ab45631465 100644
|
||||
|
||||
finish:
|
||||
if (dev)
|
||||
@@ -187,8 +864,9 @@ static grub_extcmd_t cmd;
|
||||
@@ -184,18 +861,27 @@ finish:
|
||||
}
|
||||
|
||||
static grub_extcmd_t cmd;
|
||||
+static grub_extcmd_t oldcmd;
|
||||
|
||||
GRUB_MOD_INIT(bls)
|
||||
{
|
||||
@ -932,6 +936,20 @@ index 4274aca5a9d..9ab45631465 100644
|
||||
0,
|
||||
NULL,
|
||||
N_("Import Boot Loader Specification snippets."),
|
||||
NULL);
|
||||
+ oldcmd = grub_register_extcmd ("bls_import",
|
||||
+ grub_cmd_blscfg,
|
||||
+ 0,
|
||||
+ NULL,
|
||||
+ N_("Import Boot Loader Specification snippets."),
|
||||
+ NULL);
|
||||
}
|
||||
|
||||
GRUB_MOD_FINI(bls)
|
||||
{
|
||||
grub_unregister_extcmd (cmd);
|
||||
+ grub_unregister_extcmd (oldcmd);
|
||||
}
|
||||
diff --git a/grub-core/commands/loadenv.c b/grub-core/commands/loadenv.c
|
||||
index acd93d123ed..91c99456091 100644
|
||||
--- a/grub-core/commands/loadenv.c
|
||||
|
@ -14,7 +14,7 @@ Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
|
||||
2 files changed, 37 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 5cbebe50661..5c5bdc32275 100644
|
||||
index 27ee5117b79..3ff206bf6cc 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -778,6 +778,7 @@ module = {
|
||||
@ -26,7 +26,7 @@ index 5cbebe50661..5c5bdc32275 100644
|
||||
|
||||
module = {
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 9ab45631465..e5617c3bc6c 100644
|
||||
index 86796c8cd83..e0b65534af4 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -37,7 +37,12 @@ GRUB_MOD_LICENSE ("GPLv3+");
|
||||
@ -144,21 +144,21 @@ index 9ab45631465..e5617c3bc6c 100644
|
||||
grub_dprintf ("blscfg", "scanning %s\n", GRUB_BLS_CONFIG_PATH);
|
||||
r = fs->dir (dev, "/", find_entry, &info);
|
||||
#endif
|
||||
@@ -862,7 +888,7 @@ finish:
|
||||
|
||||
@@ -863,7 +889,7 @@ finish:
|
||||
static grub_extcmd_t cmd;
|
||||
static grub_extcmd_t oldcmd;
|
||||
|
||||
-GRUB_MOD_INIT(bls)
|
||||
+GRUB_MOD_INIT(blscfg)
|
||||
{
|
||||
grub_dprintf("blscfg", "%s got here\n", __func__);
|
||||
cmd = grub_register_extcmd ("blscfg",
|
||||
@@ -873,7 +899,7 @@ GRUB_MOD_INIT(bls)
|
||||
NULL);
|
||||
@@ -880,7 +906,7 @@ GRUB_MOD_INIT(bls)
|
||||
NULL);
|
||||
}
|
||||
|
||||
-GRUB_MOD_FINI(bls)
|
||||
+GRUB_MOD_FINI(blscfg)
|
||||
{
|
||||
grub_unregister_extcmd (cmd);
|
||||
}
|
||||
grub_unregister_extcmd (oldcmd);
|
||||
|
@ -18,10 +18,10 @@ to the kexec command line tool, to allow booting the selected menu entry.
|
||||
create mode 100644 grub-core/loader/emu/linux.c
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 5c5bdc32275..ac3af772572 100644
|
||||
index 3ff206bf6cc..e07d769d896 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -1710,7 +1710,6 @@ module = {
|
||||
@@ -1709,7 +1709,6 @@ module = {
|
||||
|
||||
common = loader/linux.c;
|
||||
common = lib/cmdline.c;
|
||||
|
@ -37,7 +37,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
delete mode 100644 grub-core/lib/i386/backtrace.c
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index ac3af772572..242bf178d5c 100644
|
||||
index e07d769d896..17e758543a5 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -130,6 +130,12 @@ kernel = {
|
||||
@ -63,7 +63,7 @@ index ac3af772572..242bf178d5c 100644
|
||||
i386 = kern/i386/dl.c;
|
||||
i386_xen = kern/i386/dl.c;
|
||||
|
||||
@@ -2277,13 +2280,11 @@ module = {
|
||||
@@ -2276,13 +2279,11 @@ module = {
|
||||
|
||||
module = {
|
||||
name = backtrace;
|
||||
|
@ -16,7 +16,7 @@ Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
|
||||
1 file changed, 4 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index e5617c3bc6c..c0973ff83ea 100644
|
||||
index e0b65534af4..e775c6b8794 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -676,8 +676,8 @@ static int find_entry (const char *filename,
|
||||
|
@ -23,7 +23,7 @@ will measure all modules as they're loaded.
|
||||
create mode 100644 include/grub/tpm.h
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 242bf178d5c..e03835b9dc1 100644
|
||||
index 17e758543a5..40940d33a6d 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -131,6 +131,7 @@ kernel = {
|
||||
|
@ -9,7 +9,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
1 file changed, 44 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index c0973ff83ea..1e5972422d6 100644
|
||||
index e775c6b8794..6ab85df6b3a 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -587,6 +587,7 @@ static void create_entry (struct bls_entry *entry, const char *cfgfile)
|
||||
|
@ -14,7 +14,7 @@ Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 1e5972422d6..72ee497ea2d 100644
|
||||
index 6ab85df6b3a..c52d2b2e05a 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -418,6 +418,9 @@ static int bls_cmp(const void *p0, const void *p1, void *state UNUSED)
|
||||
|
@ -52,7 +52,7 @@ Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
|
||||
1 file changed, 18 insertions(+), 70 deletions(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 72ee497ea2d..111972d5f67 100644
|
||||
index c52d2b2e05a..fb08d8e4c12 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -169,84 +169,35 @@ static void bls_free_entry(struct bls_entry *entry)
|
||||
|
@ -38,7 +38,7 @@ Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 111972d5f67..cd5c29fdf74 100644
|
||||
index fb08d8e4c12..831cdcaccdf 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -448,7 +448,11 @@ static int read_entry (
|
||||
|
@ -19,7 +19,7 @@ Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
|
||||
2 files changed, 38 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index cd5c29fdf74..11fe6e2c29f 100644
|
||||
index 831cdcaccdf..70939a81826 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -381,9 +381,14 @@ static int bls_cmp(const void *p0, const void *p1, void *state UNUSED)
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
|
||||
1 file changed, 12 insertions(+), 50 deletions(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 11fe6e2c29f..23d15adfadc 100644
|
||||
index 70939a81826..cd8659384e4 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -70,6 +70,7 @@ struct bls_entry
|
||||
|
@ -53,10 +53,10 @@ V3:
|
||||
create mode 100644 include/grub/net/efi.h
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index e03835b9dc1..8e542acd589 100644
|
||||
index 40940d33a6d..b49ada8eb4f 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -2181,6 +2181,18 @@ module = {
|
||||
@@ -2180,6 +2180,18 @@ module = {
|
||||
common = hook/datehook.c;
|
||||
};
|
||||
|
||||
@ -75,7 +75,7 @@ index e03835b9dc1..8e542acd589 100644
|
||||
module = {
|
||||
name = net;
|
||||
common = net/net.c;
|
||||
@@ -2195,6 +2207,12 @@ module = {
|
||||
@@ -2194,6 +2206,12 @@ module = {
|
||||
common = net/arp.c;
|
||||
common = net/netbuff.c;
|
||||
common = net/url.c;
|
||||
|
@ -10,10 +10,8 @@ Subject: [PATCH] Minor fixes to make armv7hl build as arm-efi
|
||||
|
||||
Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
grub-core/Makefile.core.def | 1 +
|
||||
grub-core/loader/efi/linux.c | 2 +-
|
||||
3 files changed, 3 insertions(+), 2 deletions(-)
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 5f47a9265f3..b3af931e958 100644
|
||||
@ -28,28 +26,3 @@ index 5f47a9265f3..b3af931e958 100644
|
||||
AC_CACHE_CHECK([for options to get soft-float], grub_cv_target_cc_soft_float, [
|
||||
grub_cv_target_cc_soft_float=no
|
||||
if test "x$target_cpu" = xarm64; then
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 8e542acd589..4041472fe68 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -1709,6 +1709,7 @@ module = {
|
||||
sparc64_ieee1275 = loader/sparc64/ieee1275/linux.c;
|
||||
ia64_efi = loader/ia64/efi/linux.c;
|
||||
arm = loader/arm/linux.c;
|
||||
+ arm = loader/efi/linux.c;
|
||||
arm64 = loader/arm64/linux.c;
|
||||
arm64 = loader/efi/linux.c;
|
||||
emu = loader/emu/linux.c;
|
||||
diff --git a/grub-core/loader/efi/linux.c b/grub-core/loader/efi/linux.c
|
||||
index 7fe7201a388..8453b5c8017 100644
|
||||
--- a/grub-core/loader/efi/linux.c
|
||||
+++ b/grub-core/loader/efi/linux.c
|
||||
@@ -50,7 +50,7 @@ grub_linuxefi_secure_validate (void *data, grub_uint32_t size)
|
||||
|
||||
grub_dprintf ("secureboot", "Asking shim to verify kernel signature\n");
|
||||
status = shim_lock->verify (data, size);
|
||||
- grub_dprintf ("secureboot", "shim_lock->verify(): %ld\n", status);
|
||||
+ grub_dprintf ("secureboot", "shim_lock->verify(): %ld\n", (long int)status);
|
||||
if (status == GRUB_EFI_SUCCESS)
|
||||
{
|
||||
grub_dprintf ("secureboot", "Kernel signature verification passed\n");
|
||||
|
@ -9,7 +9,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 4041472fe68..67a2f997dcb 100644
|
||||
index b49ada8eb4f..b5a4e991f81 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -192,6 +192,7 @@ kernel = {
|
||||
|
@ -10,7 +10,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 67a2f997dcb..971ad1920d6 100644
|
||||
index b5a4e991f81..c1b9eb7940a 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -1682,7 +1682,7 @@ module = {
|
||||
|
@ -9,10 +9,10 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
1 file changed, 6 deletions(-)
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 971ad1920d6..5372d88f77e 100644
|
||||
index c1b9eb7940a..8a967f42ef9 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -2188,12 +2188,6 @@ module = {
|
||||
@@ -2186,12 +2186,6 @@ module = {
|
||||
module = {
|
||||
name = efi_netfs;
|
||||
common = net/efi/efi_netfs.c;
|
||||
|
@ -24,7 +24,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
delete mode 100644 grub-core/kern/efi/fdt.c
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 5372d88f77e..5fae7db10f9 100644
|
||||
index 8a967f42ef9..83e71aeb844 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -242,10 +242,8 @@ kernel = {
|
||||
@ -56,9 +56,9 @@ index 5372d88f77e..5fae7db10f9 100644
|
||||
|
||||
module = {
|
||||
name = linux;
|
||||
@@ -1716,7 +1720,9 @@ module = {
|
||||
@@ -1714,7 +1718,9 @@ module = {
|
||||
arm = loader/arm/linux.c;
|
||||
arm64 = loader/arm64/linux.c;
|
||||
arm64 = loader/efi/linux.c;
|
||||
emu = loader/emu/linux.c;
|
||||
+
|
||||
fdt = lib/fdt.c;
|
||||
@ -66,7 +66,7 @@ index 5372d88f77e..5fae7db10f9 100644
|
||||
|
||||
common = loader/linux.c;
|
||||
common = lib/cmdline.c;
|
||||
@@ -1724,12 +1730,14 @@ module = {
|
||||
@@ -1722,12 +1728,14 @@ module = {
|
||||
efi = loader/efi/linux.c;
|
||||
};
|
||||
|
||||
@ -81,7 +81,7 @@ index 5372d88f77e..5fae7db10f9 100644
|
||||
|
||||
module = {
|
||||
name = xnu;
|
||||
@@ -1790,7 +1798,8 @@ module = {
|
||||
@@ -1788,7 +1796,8 @@ module = {
|
||||
i386_coreboot = lib/LzmaDec.c;
|
||||
enable = i386_pc;
|
||||
enable = i386_coreboot;
|
||||
|
@ -15,7 +15,7 @@ Signed-off-by: Will Thompson <wjt@endlessm.com>
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 23d15adfadc..243fcda57f9 100644
|
||||
index cd8659384e4..82fb6cdd182 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -327,8 +327,6 @@ finish:
|
||||
|
@ -9,7 +9,7 @@ Signed-off-by: Will Thompson <wjt@endlessm.com>
|
||||
1 file changed, 3 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 243fcda57f9..1d0e6ceaf7d 100644
|
||||
index 82fb6cdd182..b61dddb7f43 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -623,7 +623,7 @@ static int find_entry (const char *filename,
|
||||
|
@ -26,7 +26,7 @@ Signed-off-by: Will Thompson <wjt@endlessm.com>
|
||||
1 file changed, 16 insertions(+)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 1d0e6ceaf7d..84714f0e534 100644
|
||||
index b61dddb7f43..9c928dda470 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -327,10 +327,26 @@ finish:
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Will Thompson <wjt@endlessm.com>
|
||||
1 file changed, 6 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 84714f0e534..f9a5b2d5afa 100644
|
||||
index 9c928dda470..bd78559ef68 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -600,23 +600,12 @@ static void create_entry (struct bls_entry *entry, const char *cfgfile)
|
||||
|
@ -15,7 +15,7 @@ Signed-off-by: Will Thompson <wjt@endlessm.com>
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index f9a5b2d5afa..077ca5dfbe6 100644
|
||||
index bd78559ef68..a45f40fe67e 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -514,7 +514,7 @@ static char **bls_make_list (struct bls_entry *entry, const char *key, int *num)
|
||||
|
@ -12,7 +12,7 @@ Signed-off-by: Will Thompson <wjt@endlessm.com>
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 077ca5dfbe6..3339d62d541 100644
|
||||
index a45f40fe67e..11a356de81a 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -166,8 +166,8 @@ static void bls_free_entry(struct bls_entry *entry)
|
||||
|
@ -20,7 +20,7 @@ Signed-off-by: Will Thompson <wjt@endlessm.com>
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index 3339d62d541..f4283708e21 100644
|
||||
index 11a356de81a..53676576ba5 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -843,7 +843,7 @@ grub_cmd_blscfg (grub_extcmd_context_t ctxt UNUSED,
|
||||
|
@ -18,7 +18,7 @@ Signed-off-by: Will Thompson <wjt@endlessm.com>
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
||||
index 5fae7db10f9..e823233cc67 100644
|
||||
index 83e71aeb844..f96b1933eea 100644
|
||||
--- a/grub-core/Makefile.core.def
|
||||
+++ b/grub-core/Makefile.core.def
|
||||
@@ -781,6 +781,7 @@ module = {
|
||||
|
@ -9,7 +9,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
1 file changed, 3 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/grub-core/commands/blscfg.c b/grub-core/commands/blscfg.c
|
||||
index f4283708e21..6f9f8e773c5 100644
|
||||
index 53676576ba5..c6addc4dc12 100644
|
||||
--- a/grub-core/commands/blscfg.c
|
||||
+++ b/grub-core/commands/blscfg.c
|
||||
@@ -43,14 +43,6 @@ GRUB_MOD_LICENSE ("GPLv3+");
|
||||
|
Loading…
Reference in New Issue
Block a user