Reabse to go1.16
Even better bundled provides
This commit is contained in:
parent
8b7777d5f3
commit
e2c9fbb1b1
1
.gitignore
vendored
1
.gitignore
vendored
@ -98,3 +98,4 @@
|
||||
/go1.15.6.src.tar.gz
|
||||
/go1.16beta1.src.tar.gz
|
||||
/go1.16rc1.src.tar.gz
|
||||
/go1.16.src.tar.gz
|
||||
|
@ -1,45 +0,0 @@
|
||||
From 297b61305501fc9fa434551664f69f3b48351924 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Thorogood <me+google@tomthorogood.co.uk>
|
||||
Date: Mon, 01 Feb 2021 13:32:18 +1030
|
||||
Subject: [PATCH] test: fix incorrectly laid out instructions in issue11656.go
|
||||
|
||||
CL 279423 introduced a regression in this test as it incorrectly laid
|
||||
out various instructions. In the case of arm, the second instruction
|
||||
was overwriting the first. In the case of 386, amd64 and s390x, the
|
||||
instructions were being appended to the end of the slice after 64
|
||||
zero bytes.
|
||||
|
||||
This was causing test failures on "linux/s390x on z13".
|
||||
|
||||
Fixes #44028
|
||||
|
||||
Change-Id: Id136212dabdae27db7e91904b0df6a3a9d2f4af4
|
||||
---
|
||||
|
||||
diff --git a/test/fixedbugs/issue11656.go b/test/fixedbugs/issue11656.go
|
||||
index acd3f4f..85fe720 100644
|
||||
--- a/test/fixedbugs/issue11656.go
|
||||
+++ b/test/fixedbugs/issue11656.go
|
||||
@@ -59,10 +59,10 @@
|
||||
ill := make([]byte, 64)
|
||||
switch runtime.GOARCH {
|
||||
case "386", "amd64":
|
||||
- ill = append(ill, 0x89, 0x04, 0x25, 0x00, 0x00, 0x00, 0x00) // MOVL AX, 0
|
||||
+ ill = append(ill[:0], 0x89, 0x04, 0x25, 0x00, 0x00, 0x00, 0x00) // MOVL AX, 0
|
||||
case "arm":
|
||||
- binary.LittleEndian.PutUint32(ill, 0xe3a00000) // MOVW $0, R0
|
||||
- binary.LittleEndian.PutUint32(ill, 0xe5800000) // MOVW R0, (R0)
|
||||
+ binary.LittleEndian.PutUint32(ill[0:4], 0xe3a00000) // MOVW $0, R0
|
||||
+ binary.LittleEndian.PutUint32(ill[4:8], 0xe5800000) // MOVW R0, (R0)
|
||||
case "arm64":
|
||||
binary.LittleEndian.PutUint32(ill, 0xf90003ff) // MOVD ZR, (ZR)
|
||||
case "ppc64":
|
||||
@@ -74,7 +74,7 @@
|
||||
case "mipsle", "mips64le":
|
||||
binary.LittleEndian.PutUint32(ill, 0xfc000000) // MOVV R0, (R0)
|
||||
case "s390x":
|
||||
- ill = append(ill, 0xa7, 0x09, 0x00, 0x00) // MOVD $0, R0
|
||||
+ ill = append(ill[:0], 0xa7, 0x09, 0x00, 0x00) // MOVD $0, R0
|
||||
ill = append(ill, 0xe3, 0x00, 0x00, 0x00, 0x00, 0x24) // MOVD R0, (R0)
|
||||
case "riscv64":
|
||||
binary.LittleEndian.PutUint32(ill, 0x00003023) // MOV X0, (X0)
|
@ -17,6 +17,7 @@
|
||||
|
||||
provides=""
|
||||
for bundle in $(find -name modules.txt); do
|
||||
provides="$provides\n$(cat "$bundle" | grep "^# " | grep -v "# explicit" | sed -r s/"^#.* => "// | sed -r "s/# //" | sed -r "s:(.*) (.*):Provides\: bundled(golang(\1)) = \2:")"
|
||||
provides="$provides\n$(cat "$bundle" | grep "^# " | grep -v "# explicit" | sed -r s/"^#.* => "// | sed -r "s/# //" | sed -r "s:(.*) v(.*):Provides\: bundled(golang(\1)) = \2:")"
|
||||
done
|
||||
#TODO replace - with . in version per packaging guidelines
|
||||
echo -e "$provides" | sort -u
|
||||
|
31
golang.spec
31
golang.spec
@ -106,7 +106,7 @@
|
||||
%endif
|
||||
|
||||
%global go_api 1.16
|
||||
%global go_prerelease rc1
|
||||
#global go_prerelease {nil}
|
||||
%global go_version %{go_api}%{?go_prerelease}
|
||||
|
||||
# For rpmdev-bumpspec and releng automation
|
||||
@ -140,16 +140,17 @@ BuildRequires: pcre-devel, glibc-static, perl-interpreter, procps-ng
|
||||
Provides: go = %{version}-%{release}
|
||||
|
||||
# Bundled/Vendored provides generated by bundled-deps.sh based on the in tree module data
|
||||
Provides: bundled(golang(github.com/google/pprof)) = v0.0.0-20200229191704-1ebb73c60ed3
|
||||
Provides: bundled(golang(github.com/ianlancetaylor/demangle)) = v0.0.0-20200414190113-039b1ae3a340
|
||||
Provides: bundled(golang(golang.org/x/arch)) = v0.0.0-20200511175325-f7c78586839d
|
||||
Provides: bundled(golang(golang.org/x/crypto)) = v0.0.0-20200622213623-75b288015ac9
|
||||
Provides: bundled(golang(golang.org/x/mod)) = v0.3.0
|
||||
Provides: bundled(golang(golang.org/x/net)) = v0.0.0-20201008223702-a5fa9d4b7c91
|
||||
Provides: bundled(golang(golang.org/x/sys)) = v0.0.0-20200501145240-bc7a7d42d5c3
|
||||
Provides: bundled(golang(golang.org/x/text)) = v0.3.3-0.20200430171850-afb9336c4530
|
||||
Provides: bundled(golang(golang.org/x/tools)) = v0.0.0-20200616133436-c1934b75d054
|
||||
Provides: bundled(golang(golang.org/x/xerrors)) = v0.0.0-20200806184451-1a77d5e9f316
|
||||
# - in version filed substituted with . per versioning guidelines
|
||||
Provides: bundled(golang(github.com/google/pprof)) = 0.0.0.20201203190320.1bf35d6f28c2
|
||||
Provides: bundled(golang(github.com/ianlancetaylor/demangle)) = 0.0.0.20200824232613.28f6c0f3b639
|
||||
Provides: bundled(golang(golang.org/x/arch)) = 0.0.0.20201008161808.52c3e6f60cff
|
||||
Provides: bundled(golang(golang.org/x/crypto)) = 0.0.0.20201016220609.9e8e0b390897
|
||||
Provides: bundled(golang(golang.org/x/mod)) = 0.4.1
|
||||
Provides: bundled(golang(golang.org/x/net)) = 0.0.0.20201209123823.ac852fbbde11
|
||||
Provides: bundled(golang(golang.org/x/sys)) = 0.0.0.20201204225414.ed752295db88
|
||||
Provides: bundled(golang(golang.org/x/text)) = 0.3.4
|
||||
Provides: bundled(golang(golang.org/x/tools)) = 0.0.0.20210107193943.4ed967dd8eff
|
||||
Provides: bundled(golang(golang.org/x/xerrors)) = 0.0.0.20200804184101.5ec99f83aff1
|
||||
|
||||
Requires: %{name}-bin = %{version}-%{release}
|
||||
Requires: %{name}-src = %{version}-%{release}
|
||||
@ -158,9 +159,6 @@ Requires: go-srpm-macros
|
||||
Patch1: 0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
|
||||
Patch2: 0002-syscall-expose-IfInfomsg.X__ifi_pad-on-s390x.patch
|
||||
Patch3: 0003-cmd-go-disable-Google-s-proxy-and-sumdb.patch
|
||||
# CL https://go-review.googlesource.com/c/go/+/288278
|
||||
# Fixes bug in the test on s390x and other arches
|
||||
Patch4: CL288278.patch
|
||||
|
||||
# Having documentation separate was broken
|
||||
Obsoletes: %{name}-docs < 1.1-4
|
||||
@ -532,6 +530,11 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Feb 18 2021 Jakub Čajka <jcajka@redhat.com> - 1.16-1
|
||||
- Update to go1.16
|
||||
- Improved bundled provides
|
||||
- Resolves: BZ#1913835
|
||||
|
||||
* Sun Jan 31 2021 Neal Gompa <ngompa13@gmail.com> - 1.16-0.rc1.1
|
||||
- Update to go1.16rc1
|
||||
- Related: BZ#1913835
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (go1.16rc1.src.tar.gz) = 83b739c515dadd13fa6b8eaebc3a0783a5d74275c8c95221a70329cc638ded20228be114961c81d3f90150d625af12ecf2b7ec793fbc0d5c0c8a9c799b9626fe
|
||||
SHA512 (go1.16.src.tar.gz) = 9c43e0ebb2d35c694b652cae8d4040ce3f3c8c014abd9496c92c78cc015ecea5b5331e7c2acf098d0c24dec222454ea09d834df4b6bc90d46e9feeac0ac578bf
|
||||
|
Loading…
Reference in New Issue
Block a user