accomdate the move of hostname command for rawhide
This commit is contained in:
parent
7025cc82ad
commit
c91e9b6b85
13
golang-f21-hostname.patch
Normal file
13
golang-f21-hostname.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: go/src/pkg/os/os_test.go
|
||||
===================================================================
|
||||
--- go.orig/src/pkg/os/os_test.go
|
||||
+++ go/src/pkg/os/os_test.go
|
||||
@@ -842,7 +842,7 @@ func run(t *testing.T, cmd []string) str
|
||||
if err != nil {
|
||||
t.Fatal(err)
|
||||
}
|
||||
- p, err := StartProcess("/bin/hostname", []string{"hostname"}, &ProcAttr{Files: []*File{nil, w, Stderr}})
|
||||
+ p, err := StartProcess("/usr/bin/hostname", []string{"hostname"}, &ProcAttr{Files: []*File{nil, w, Stderr}})
|
||||
if err != nil {
|
||||
t.Fatal(err)
|
||||
}
|
11
golang.spec
11
golang.spec
@ -32,7 +32,14 @@ License: BSD
|
||||
URL: http://golang.org/
|
||||
Source0: https://go.googlecode.com/files/go%{version}.src.tar.gz
|
||||
|
||||
# this command moved places
|
||||
%if 0%{?fedora} >= 21
|
||||
BuildRequires: /usr/bin/hostname
|
||||
Patch1: golang-f21-hostname.patch
|
||||
%else
|
||||
BuildRequires: /bin/hostname
|
||||
%endif
|
||||
|
||||
BuildRequires: emacs xemacs xemacs-packages-extra
|
||||
|
||||
# We strip the meta dependency, but go does require glibc.
|
||||
@ -124,6 +131,10 @@ end
|
||||
# increase verbosity of build
|
||||
%patch0 -p1
|
||||
|
||||
%if 0%{?fedora} >= 21
|
||||
%patch1 -p1
|
||||
%endif
|
||||
|
||||
# Fix BZ#1010271
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
|
Loading…
Reference in New Issue
Block a user