Rebase to 1.22.3
Removes re-enable-cgo.patch Resolves: RHEL-35634 Resolves: RHEL-35883 Resolves: RHEL-10068 Resolves: RHEL-34924
This commit is contained in:
parent
0783cb998f
commit
9f27ddf429
3
.gitignore
vendored
3
.gitignore
vendored
@ -71,3 +71,6 @@
|
||||
/go1.22.1-2-openssl-fips.tar.gz
|
||||
/go1.22.2.tar.gz
|
||||
/go1.22.2-1-openssl-fips.tar.gz
|
||||
/go1.22.3.src.tar.gz
|
||||
/go1.22.3-1-openssl-fips.tar.gz
|
||||
/go1.22.3.tar.gz
|
||||
|
14
golang.spec
14
golang.spec
@ -93,7 +93,7 @@
|
||||
%endif
|
||||
|
||||
%global go_api 1.22
|
||||
%global go_version 1.22.2
|
||||
%global go_version 1.22.3
|
||||
%global version %{go_version}
|
||||
%global pkg_release 1
|
||||
|
||||
@ -144,7 +144,6 @@ Patch221: fix_TestScript_list_std.patch
|
||||
Patch1939923: skip_test_rhbz1939923.patch
|
||||
|
||||
Patch4: modify_go.env.patch
|
||||
Patch5: re-enable-cgo.patch
|
||||
Patch6: skip_TestCrashDumpsAllThreads.patch
|
||||
|
||||
# Having documentation separate was broken
|
||||
@ -253,9 +252,10 @@ pushd ..
|
||||
tar -xf %{SOURCE1}
|
||||
popd
|
||||
patch_dir="../go-go%{version}-%{pkg_release}-openssl-fips/patches"
|
||||
# Add --no-backup-if-mismatch option to avoid creating .orig temp files
|
||||
for p in "$patch_dir"/*.patch; do
|
||||
echo "Applying $p"
|
||||
patch -p1 < $p
|
||||
patch --no-backup-if-mismatch -p1 < $p
|
||||
done
|
||||
|
||||
# Configure crypto tests
|
||||
@ -529,6 +529,14 @@ cd ..
|
||||
%files -n go-toolset
|
||||
|
||||
%changelog
|
||||
* Wed May 22 2024 Alejandro Sáez <asm@redhat.com> - 1.22.3-1
|
||||
- Rebase to 1.22.3
|
||||
- Removes re-enable-cgo.patch
|
||||
- Resolves: RHEL-35634
|
||||
- Resolves: RHEL-35883
|
||||
- Resolves: RHEL-10068
|
||||
- Resolves: RHEL-34924
|
||||
|
||||
* Thu Apr 18 2024 Derek Parker <deparker@redhat.com> - 1.22.2-1
|
||||
- Rebase to 1.22.2
|
||||
- Resolves: RHEL-28941
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 09ff18f22def1766faa746df87e57d5b68454246 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Alejandro=20S=C3=A1ez?= <asm@redhat.com>
|
||||
Date: Tue, 5 Mar 2024 10:03:13 +0100
|
||||
Subject: [PATCH] Re-enable CGO in cmd/go and cmd/pprof
|
||||
|
||||
---
|
||||
src/cmd/dist/build.go | 7 -------
|
||||
1 file changed, 7 deletions(-)
|
||||
|
||||
diff --git a/src/cmd/dist/build.go b/src/cmd/dist/build.go
|
||||
index 32e59b446a..941abdcebd 100644
|
||||
--- a/src/cmd/dist/build.go
|
||||
+++ b/src/cmd/dist/build.go
|
||||
@@ -1304,13 +1304,6 @@ func timelog(op, name string) {
|
||||
// to switch between the host and target configurations when cross-compiling.
|
||||
func toolenv() []string {
|
||||
var env []string
|
||||
- if !mustLinkExternal(goos, goarch, false) {
|
||||
- // Unless the platform requires external linking,
|
||||
- // we disable cgo to get static binaries for cmd/go and cmd/pprof,
|
||||
- // so that they work on systems without the same dynamic libraries
|
||||
- // as the original build system.
|
||||
- env = append(env, "CGO_ENABLED=0")
|
||||
- }
|
||||
if isRelease || os.Getenv("GO_BUILDER_NAME") != "" {
|
||||
// Add -trimpath for reproducible builds of releases.
|
||||
// Include builders so that -trimpath is well-tested ahead of releases.
|
||||
--
|
||||
2.43.2
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (go1.22.2.tar.gz) = c9c6f0a745229a41ff17fdb5192a5700c5eead2dfd7c3de9273ccfda64db0ee73dceb6bfc5d7cd2df87e31bbee53b96360742a9f853c79456bb178f2da001065
|
||||
SHA512 (go1.22.2-1-openssl-fips.tar.gz) = 01a7924f86be2030207b32bbac5b0b4f5b5e8430349eb1d0a1ade8a48536e4402fdf000f8c07e7bd270df338e5f97553f6933045ad96411aa9b2dfd7f127d280
|
||||
SHA512 (go1.22.3.tar.gz) = f17e489672bf791b9631891c134b0466afce29fea68e5c148d3d3cb57519e0f2b10f3b63234ab1ab445315761c2f3d7ececf78cc8b1e2bbb43879c543058ae00
|
||||
SHA512 (go1.22.3-1-openssl-fips.tar.gz) = a666fffd3459598b0ac7b93e5dd9d3925877fc5cc6a140bf6e97831013204b13224149f888e2bd3ef0e2629d46ac838aacd40a8668606c50342556b506a9a5d6
|
||||
|
Loading…
Reference in New Issue
Block a user