patching the tzinfo test
This commit is contained in:
parent
726440c406
commit
999ceca490
11
golang.spec
11
golang.spec
@ -39,7 +39,7 @@
|
|||||||
|
|
||||||
Name: golang
|
Name: golang
|
||||||
Version: 1.3.1
|
Version: 1.3.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: The Go Programming Language
|
Summary: The Go Programming Language
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -80,6 +80,9 @@ Patch4: ./go1.3-tar_reuse_buffer_writeHeader.patch
|
|||||||
# https://code.google.com/p/go/source/detail?r=1b17b3426e3c
|
# https://code.google.com/p/go/source/detail?r=1b17b3426e3c
|
||||||
Patch5: ./go1.3-tar-fix_writing_of_pax_headers.patch
|
Patch5: ./go1.3-tar-fix_writing_of_pax_headers.patch
|
||||||
|
|
||||||
|
# https://code.google.com/p/go/issues/detail?id=8547
|
||||||
|
Patch6: ./skip_syndey_time_test.patch
|
||||||
|
|
||||||
# Having documentation separate was broken
|
# Having documentation separate was broken
|
||||||
Obsoletes: %{name}-docs < 1.1-4
|
Obsoletes: %{name}-docs < 1.1-4
|
||||||
|
|
||||||
@ -357,6 +360,9 @@ end
|
|||||||
# buffer the PAX header
|
# buffer the PAX header
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
|
|
||||||
|
# new tzinfo breaks a single unit test
|
||||||
|
%patch6 -p1
|
||||||
|
|
||||||
# create a [dirty] gcc wrapper to allow us to build with our own flags
|
# create a [dirty] gcc wrapper to allow us to build with our own flags
|
||||||
# (dirty because it is spoofing 'gcc' since CC value is stored in the go tool)
|
# (dirty because it is spoofing 'gcc' since CC value is stored in the go tool)
|
||||||
# TODO: remove this and just set CFLAGS/LDFLAGS once upstream supports it
|
# TODO: remove this and just set CFLAGS/LDFLAGS once upstream supports it
|
||||||
@ -898,6 +904,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 11 2014 Vincent Batts <vbatts@fedoraproject.org> - 1.3.1-3
|
||||||
|
- patching the tzinfo failure
|
||||||
|
|
||||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-2
|
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
13
skip_syndey_time_test.patch
Normal file
13
skip_syndey_time_test.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: go/src/pkg/time/format_test.go
|
||||||
|
===================================================================
|
||||||
|
--- go.orig/src/pkg/time/format_test.go
|
||||||
|
+++ go/src/pkg/time/format_test.go
|
||||||
|
@@ -183,7 +183,7 @@ func TestParse(t *testing.T) {
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
-func TestParseInSydney(t *testing.T) {
|
||||||
|
+func testParseInSydney(t *testing.T) {
|
||||||
|
loc, err := LoadLocation("Australia/Sydney")
|
||||||
|
if err != nil {
|
||||||
|
t.Fatal(err)
|
Loading…
Reference in New Issue
Block a user