update to go1.3.3
This commit is contained in:
parent
8cfb9c493a
commit
94c0b3b623
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
||||
/go1.3.src.tar.gz
|
||||
/go1.3.1.src.tar.gz
|
||||
/go1.3.2.src.tar.gz
|
||||
/go1.3.3.src.tar.gz
|
||||
|
11
golang.spec
11
golang.spec
@ -38,7 +38,7 @@
|
||||
%endif
|
||||
|
||||
Name: golang
|
||||
Version: 1.3.2
|
||||
Version: 1.3.3
|
||||
Release: 1%{?dist}
|
||||
Summary: The Go Programming Language
|
||||
|
||||
@ -80,9 +80,6 @@ Patch4: ./go1.3-tar_reuse_buffer_writeHeader.patch
|
||||
# https://code.google.com/p/go/source/detail?r=1b17b3426e3c
|
||||
Patch5: ./go1.3-tar-fix_writing_of_pax_headers.patch
|
||||
|
||||
# https://code.google.com/p/go/issues/detail?id=8547
|
||||
Patch6: ./skip_syndey_time_test.patch
|
||||
|
||||
# Having documentation separate was broken
|
||||
Obsoletes: %{name}-docs < 1.1-4
|
||||
|
||||
@ -360,9 +357,6 @@ end
|
||||
# buffer the PAX header
|
||||
%patch5 -p1
|
||||
|
||||
# new tzinfo breaks a single unit test
|
||||
%patch6 -p1
|
||||
|
||||
# create a [dirty] gcc wrapper to allow us to build with our own flags
|
||||
# (dirty because it is spoofing 'gcc' since CC value is stored in the go tool)
|
||||
# TODO: remove this and just set CFLAGS/LDFLAGS once upstream supports it
|
||||
@ -904,6 +898,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 01 2014 Vincent Batts <vbatts@fedoraproject.org> - 1.3.3-1
|
||||
- update to go1.3.3 (bz1146882)
|
||||
|
||||
* Mon Sep 29 2014 Vincent Batts <vbatts@fedoraproject.org> - 1.3.2-1
|
||||
- update to go1.3.2 (bz1147324)
|
||||
|
||||
|
@ -1,13 +0,0 @@
|
||||
Index: go/src/pkg/time/format_test.go
|
||||
===================================================================
|
||||
--- go.orig/src/pkg/time/format_test.go
|
||||
+++ go/src/pkg/time/format_test.go
|
||||
@@ -183,7 +183,7 @@ func TestParse(t *testing.T) {
|
||||
}
|
||||
}
|
||||
|
||||
-func TestParseInSydney(t *testing.T) {
|
||||
+func testParseInSydney(t *testing.T) {
|
||||
loc, err := LoadLocation("Australia/Sydney")
|
||||
if err != nil {
|
||||
t.Fatal(err)
|
Loading…
Reference in New Issue
Block a user