updating to go1.5rc1
This commit is contained in:
parent
f2f58b5244
commit
831ba34f74
@ -1,33 +0,0 @@
|
||||
commit a1d093d95dfb888e55f960943bd3ad3d181ec743
|
||||
Author: Vincent Batts <vbatts@hashbangbash.com>
|
||||
Date: Mon Aug 3 12:26:38 2015 -0400
|
||||
|
||||
archive/tar: don't treat multiple file system links as a tar hardlink
|
||||
|
||||
Do not assume that if stat shows multiple links that we should mark the
|
||||
file as a hardlink in the tar format. If the hardlink link was not
|
||||
referenced, this caused a link to "/". On an overlay file system, all
|
||||
files have multiple links.
|
||||
|
||||
The caller must keep the inode references and set TypeLink, Size = 0,
|
||||
and LinkName themselves.
|
||||
|
||||
Change-Id: I873b8a235bc8f8fbb271db74ee54232da36ca013
|
||||
Reviewed-on: https://go-review.googlesource.com/13045
|
||||
Reviewed-by: Ian Lance Taylor <iant@golang.org>
|
||||
|
||||
diff --git a/src/archive/tar/stat_unix.go b/src/archive/tar/stat_unix.go
|
||||
index 27d112f..cb843db 100644
|
||||
--- a/src/archive/tar/stat_unix.go
|
||||
+++ b/src/archive/tar/stat_unix.go
|
||||
@@ -28,10 +28,5 @@ func statUnix(fi os.FileInfo, h *Header) error {
|
||||
h.AccessTime = statAtime(sys)
|
||||
h.ChangeTime = statCtime(sys)
|
||||
// TODO(bradfitz): major/minor device numbers?
|
||||
- if fi.Mode().IsRegular() && sys.Nlink > 1 {
|
||||
- h.Typeflag = TypeLink
|
||||
- h.Size = 0
|
||||
- // TODO(vbatts): Linkname?
|
||||
- }
|
||||
return nil
|
||||
}
|
@ -1,13 +0,0 @@
|
||||
diff --git a/src/cmd/link/internal/ld/elf.go b/src/cmd/link/internal/ld/elf.go
|
||||
index cf52f2e..7cdb8c4 100644
|
||||
--- a/src/cmd/link/internal/ld/elf.go
|
||||
+++ b/src/cmd/link/internal/ld/elf.go
|
||||
@@ -713,7 +713,7 @@ var Elfstrdat []byte
|
||||
* On FreeBSD, cannot be larger than a page.
|
||||
*/
|
||||
const (
|
||||
- ELFRESERVE = 3072
|
||||
+ ELFRESERVE = 3104
|
||||
)
|
||||
|
||||
/*
|
24
golang.spec
24
golang.spec
@ -37,11 +37,11 @@
|
||||
%endif
|
||||
|
||||
%global go_api 1.5
|
||||
%global go_version 1.5beta3
|
||||
%global go_version 1.5rc1
|
||||
|
||||
Name: golang
|
||||
Version: 1.5
|
||||
Release: 0.9.beta3%{?dist}
|
||||
Release: 0.10.rc1%{?dist}
|
||||
Summary: The Go Programming Language
|
||||
|
||||
License: BSD
|
||||
@ -78,14 +78,6 @@ Patch213: go1.5beta1-disable-TestGdbPython.patch
|
||||
# this is not possible in the limitied build chroot
|
||||
Patch214: go1.5beta2-disable-TestCloneNEWUSERAndRemapNoRootDisableSetgroups.patch
|
||||
|
||||
# debuginfo doesn't fit in the 3072 reserved space for ELF headers
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1248071
|
||||
Patch215: golang/go1.5beta2-increase-elfreserve-for-debug.patch
|
||||
|
||||
# upstream commit that fixes hardlinks in archive/tar
|
||||
# should be included in go1.5
|
||||
Patch216: go1.3beta3-tar-hardlink-fix.patch
|
||||
|
||||
# Having documentation separate was broken
|
||||
Obsoletes: %{name}-docs < 1.1-4
|
||||
|
||||
@ -221,12 +213,6 @@ end
|
||||
# disable TestCloneNEWUSERAndRemapNoRootDisableSetgroups
|
||||
%patch214 -p1
|
||||
|
||||
# ELFRESERVE
|
||||
%patch215 -p1
|
||||
|
||||
# archive/tar hardlinks
|
||||
%patch216 -p1
|
||||
|
||||
%build
|
||||
# go1.5 bootstrapping. The compiler is written in golang.
|
||||
export GOROOT_BOOTSTRAP=%{goroot}
|
||||
@ -357,7 +343,7 @@ cd src
|
||||
CC="gcc" \
|
||||
CFLAGS="$RPM_OPT_FLAGS" \
|
||||
LDFLAGS="$RPM_LD_FLAGS" \
|
||||
./run.bash --no-rebuild -v -k ||:
|
||||
./run.bash --no-rebuild -v -k
|
||||
cd ..
|
||||
|
||||
|
||||
@ -424,6 +410,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Aug 06 2015 Vincent Batts <vbatts@fedoraproject.org> - 1.5-0.10.rc1
|
||||
- updating to go1.5rc1
|
||||
- checks are back in place
|
||||
|
||||
* Tue Aug 04 2015 Vincent Batts <vbatts@fedoraproject.org> - 1.5-0.9.beta3
|
||||
- pull in upstream archive/tar fix
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user