Rebase to 1.11beta2
This commit is contained in:
parent
75f7f03cb6
commit
62f2ae0511
1
.gitignore
vendored
1
.gitignore
vendored
@ -54,3 +54,4 @@
|
||||
/go1.10.2.src.tar.gz
|
||||
/go1.10.3.src.tar.gz
|
||||
/go1.11beta1.src.tar.gz
|
||||
/go1.11beta2.src.tar.gz
|
||||
|
@ -1,51 +0,0 @@
|
||||
From b55fe6a3702922f35b8d440f32fd5a54ee92f5f8 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jakub=20=C4=8Cajka?= <jcajka@redhat.com>
|
||||
Date: Mon, 25 Jun 2018 12:31:53 +0200
|
||||
Subject: [PATCH] cmd/go: call flag.Parse to properly initialize test
|
||||
environment variables
|
||||
|
||||
Executing tests in cmd/go/internal/modfetch/gitrepo/fetch_test.go in enviroment
|
||||
witout outside connectivity in to the internet results in tests failure:
|
||||
|
||||
2018/06/25 12:48:26 git clone --mirror https://vcs-test.golang.org/git/gitrepo1 /tmp/gitrepo-test-221822392/gitrepo2 in : exit status 128:
|
||||
Cloning into bare repository '/tmp/gitrepo-test-221822392/gitrepo2'...
|
||||
fatal: unable to access 'https://vcs-test.golang.org/git/gitrepo1/': Could not resolve host: vcs-test.golang.org
|
||||
FAIL cmd/go/internal/modfetch/gitrepo 0.144s
|
||||
|
||||
Call flag.Parse in TestMain to properly initialize test environment variables
|
||||
|
||||
Fixes #26007
|
||||
|
||||
Change-Id: I059e27db69c0ca0e01db724035a25d6fefb094b5
|
||||
Reviewed-on: https://go-review.googlesource.com/120735
|
||||
Run-TryBot: Ian Lance Taylor <iant@golang.org>
|
||||
Reviewed-by: Brad Fitzpatrick <bradfitz@golang.org>
|
||||
---
|
||||
src/cmd/go/internal/modfetch/gitrepo/fetch_test.go | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/cmd/go/internal/modfetch/gitrepo/fetch_test.go b/src/cmd/go/internal/modfetch/gitrepo/fetch_test.go
|
||||
index ca932808e8..622249e67d 100644
|
||||
--- a/src/cmd/go/internal/modfetch/gitrepo/fetch_test.go
|
||||
+++ b/src/cmd/go/internal/modfetch/gitrepo/fetch_test.go
|
||||
@@ -7,6 +7,7 @@ package gitrepo
|
||||
import (
|
||||
"archive/zip"
|
||||
"bytes"
|
||||
+ "flag"
|
||||
"fmt"
|
||||
"internal/testenv"
|
||||
"io/ioutil"
|
||||
@@ -23,6 +24,9 @@ import (
|
||||
)
|
||||
|
||||
func TestMain(m *testing.M) {
|
||||
+ // needed for initializing the test environment variables as testing.Short
|
||||
+ // and HasExternalNetwork
|
||||
+ flag.Parse()
|
||||
os.Exit(testMain(m))
|
||||
}
|
||||
|
||||
--
|
||||
2.14.4
|
||||
|
11
golang.spec
11
golang.spec
@ -102,11 +102,11 @@
|
||||
%endif
|
||||
|
||||
%global go_api 1.11
|
||||
%global go_version 1.11beta1
|
||||
%global go_version 1.11beta2
|
||||
|
||||
Name: golang
|
||||
Version: 1.11
|
||||
Release: 0.beta1.2%{?dist}
|
||||
Release: 0.beta2.1%{?dist}
|
||||
Summary: The Go Programming Language
|
||||
# source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
|
||||
License: BSD and Public Domain
|
||||
@ -183,8 +183,7 @@ Requires: go-srpm-macros
|
||||
|
||||
Patch1: 0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
|
||||
Patch2: 0002-syscall-expose-IfInfomsg.X__ifi_pad-on-s390x.patch
|
||||
Patch3: 0001-cmd-go-call-flag.Parse-to-properly-initialize-test-e.patch
|
||||
Patch4: 0003-Don-t-compress-dwarf-by-derfault-as-rpm-debuginfo-is.patch
|
||||
Patch3: 0003-Don-t-compress-dwarf-by-derfault-as-rpm-debuginfo-is.patch
|
||||
|
||||
# Having documentation separate was broken
|
||||
Obsoletes: %{name}-docs < 1.1-4
|
||||
@ -311,7 +310,6 @@ Requires: %{name} = %{version}-%{release}
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
cp %{SOURCE1} ./src/runtime/
|
||||
|
||||
@ -548,6 +546,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Jul 20 2018 Jakub Čajka <jcajka@redhat.com> - 1.11-0.beta2.1
|
||||
- Rebase to 1.11beta2
|
||||
|
||||
* Wed Jul 18 2018 Jakub Čajka <jcajka@redhat.com> - 1.11-0.beta1.2
|
||||
- Turn off DWARF compression by default as it is not supported by rpm/debuginfo
|
||||
- Related: BZ#1602096
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (go1.11beta1.src.tar.gz) = a7369cbb05429f0c2ac0aca27ec67a4fe931f4a496ecd77cb901cbb14f8db5f925736b2d7b1af24e0ad0860aa50334911444c4bef5b92c23d73918a3128a71f3
|
||||
SHA512 (go1.11beta2.src.tar.gz) = 0b88364f15c1b41c19c2dca3e69e4bb848d8534540f80b50e9cca00889398f464647530a972ec763b925e2d850ee4e88f08abda3ec01384462ff423e281e24aa
|
||||
|
Loading…
Reference in New Issue
Block a user