- Rebase disable_static_tests_part2.patch to Go 1.21.3
- Add missing strict fips runtime detection patch - Temporarily disable FIPS tests on aarch64 due to builder kernel bugs - Remove fix-memory-leak patch as it is fixed upstream - Resolves: RHEL-12620
This commit is contained in:
parent
3eea0b0835
commit
616386c231
@ -1,13 +1,13 @@
|
||||
diff --git a/src/cmd/dist/test.go b/src/cmd/dist/test.go
|
||||
index 9f26606..2408505 100644
|
||||
index 36a20e8b2a..8c2dd1b44b 100644
|
||||
--- a/src/cmd/dist/test.go
|
||||
+++ b/src/cmd/dist/test.go
|
||||
@@ -1259,7 +1259,7 @@ func (t *tester) registerCgoTests() {
|
||||
@@ -1125,7 +1125,7 @@ func (t *tester) registerCgoTests(heading string) {
|
||||
} else {
|
||||
panic("unknown linkmode with static build: " + linkmode)
|
||||
}
|
||||
- gt.tags = append(gt.tags, "static")
|
||||
+ gt.tags = append(gt.tags, "static", "no_openssl")
|
||||
}
|
||||
gt.ldflags = strings.Join(ldflags, " ")
|
||||
|
||||
t.registerTest("cgo:"+name, "../misc/cgo/test", gt, opts...)
|
||||
|
14
golang.spec
14
golang.spec
@ -56,7 +56,7 @@
|
||||
%endif
|
||||
|
||||
# Controls what ever we fail on failed tests
|
||||
%ifarch x86_64 %{arm} aarch64 ppc64le s390x
|
||||
%ifarch x86_64 %{arm} ppc64le s390x
|
||||
%global fail_on_tests 1
|
||||
%else
|
||||
%global fail_on_tests 0
|
||||
@ -97,7 +97,7 @@
|
||||
|
||||
Name: golang
|
||||
Version: %{version}
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
|
||||
Summary: The Go Programming Language
|
||||
# source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
|
||||
@ -145,7 +145,6 @@ Patch1939923: skip_test_rhbz1939923.patch
|
||||
|
||||
Patch2: disable_static_tests_part1.patch
|
||||
Patch3: disable_static_tests_part2.patch
|
||||
Patch6: fix-memory-leak-evp-sign-verify.patch
|
||||
|
||||
# Having documentation separate was broken
|
||||
Obsoletes: %{name}-docs < 1.1-4
|
||||
@ -244,6 +243,7 @@ tar -xf %{SOURCE1}
|
||||
popd
|
||||
patch -p1 < ../go-go%{version}-%{pkg_release}-openssl-fips/patches/000-initial-setup.patch
|
||||
patch -p1 < ../go-go%{version}-%{pkg_release}-openssl-fips/patches/001-initial-openssl-for-fips.patch
|
||||
patch -p1 < ../go-go%{version}-%{pkg_release}-openssl-fips/patches/002-strict-fips-runtime-detection.patch
|
||||
|
||||
# Configure crypto tests
|
||||
pushd ../go-go%{version}-%{pkg_release}-openssl-fips
|
||||
@ -253,7 +253,6 @@ popd
|
||||
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch6 -p1
|
||||
|
||||
%patch221 -p1
|
||||
|
||||
@ -519,6 +518,13 @@ cd ..
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Oct 31 2023 Archana Ravindar <aravinda@redhat.com> - 1.21.3-2
|
||||
- Rebase disable_static_tests_part2.patch to Go 1.21.3
|
||||
- Add missing strict fips runtime detection patch
|
||||
- Temporarily disable FIPS tests on aarch64 due to builder kernel bugs
|
||||
- Remove fix-memory-leak patch as it is fixed upstream
|
||||
- Resolves: RHEL-12620
|
||||
|
||||
* Fri Oct 20 2023 Archana Ravindar <aravinda@redhat.com> - 1.21.3-1
|
||||
- Rebase Go to 1.21.3
|
||||
- Resolves: RHEL-12620
|
||||
|
Loading…
Reference in New Issue
Block a user