Update to 1.18beta2
- Remove testshared-size-limit patch (now upstream) 83fc097 - Related: rhbz#2002859
This commit is contained in:
parent
0848775a51
commit
43672d0906
1
.gitignore
vendored
1
.gitignore
vendored
@ -109,3 +109,4 @@
|
|||||||
/go1.17.4.src.tar.gz
|
/go1.17.4.src.tar.gz
|
||||||
/go1.17.5.src.tar.gz
|
/go1.17.5.src.tar.gz
|
||||||
/go1.18beta1.src.tar.gz
|
/go1.18beta1.src.tar.gz
|
||||||
|
/go1.18beta2.src.tar.gz
|
||||||
|
15
golang.spec
15
golang.spec
@ -107,14 +107,14 @@
|
|||||||
|
|
||||||
# Comment out go_prerelease and go_patch as needed
|
# Comment out go_prerelease and go_patch as needed
|
||||||
%global go_api 1.18
|
%global go_api 1.18
|
||||||
%global go_prerelease beta1
|
%global go_prerelease beta2
|
||||||
#global go_patch 1
|
#global go_patch 1
|
||||||
|
|
||||||
%global go_version %{go_api}%{?go_patch:.%{go_patch}}%{?go_prerelease:~%{go_prerelease}}
|
%global go_version %{go_api}%{?go_patch:.%{go_patch}}%{?go_prerelease:~%{go_prerelease}}
|
||||||
%global go_source %{go_api}%{?go_patch:.%{go_patch}}%{?go_prerelease}
|
%global go_source %{go_api}%{?go_patch:.%{go_patch}}%{?go_prerelease}
|
||||||
|
|
||||||
# For rpmdev-bumpspec and releng automation
|
# For rpmdev-bumpspec and releng automation
|
||||||
%global baserelease 2
|
%global baserelease 1
|
||||||
|
|
||||||
Name: golang
|
Name: golang
|
||||||
Version: %{go_version}
|
Version: %{go_version}
|
||||||
@ -148,14 +148,14 @@ Provides: go = %{version}-%{release}
|
|||||||
Provides: bundled(golang(github.com/google/pprof)) = 0.0.0.20211104044539.f987b9c94b31
|
Provides: bundled(golang(github.com/google/pprof)) = 0.0.0.20211104044539.f987b9c94b31
|
||||||
Provides: bundled(golang(github.com/ianlancetaylor/demangle)) = 0.0.0.20210905161508.09a460cdf81d
|
Provides: bundled(golang(github.com/ianlancetaylor/demangle)) = 0.0.0.20210905161508.09a460cdf81d
|
||||||
Provides: bundled(golang(golang.org/x/arch)) = 0.0.0.20210923205945.b76863e36670
|
Provides: bundled(golang(golang.org/x/arch)) = 0.0.0.20210923205945.b76863e36670
|
||||||
Provides: bundled(golang(golang.org/x/crypto)) = 0.0.0.20211108221036.ceb1ce70b4fa
|
Provides: bundled(golang(golang.org/x/crypto)) = 0.0.0.20211215153901.e495a2d5b3d3
|
||||||
Provides: bundled(golang(golang.org/x/mod)) = 0.6.0.dev.0.20211102181907.3a5865c02020
|
Provides: bundled(golang(golang.org/x/mod)) = 0.6.0.dev.0.20211102181907.3a5865c02020
|
||||||
Provides: bundled(golang(golang.org/x/net)) = 0.0.0.20211209124913.491a49abca63
|
Provides: bundled(golang(golang.org/x/net)) = 0.0.0.20211209124913.491a49abca63
|
||||||
Provides: bundled(golang(golang.org/x/sync)) = 0.0.0.20210220032951.036812b2e83c
|
Provides: bundled(golang(golang.org/x/sync)) = 0.0.0.20210220032951.036812b2e83c
|
||||||
Provides: bundled(golang(golang.org/x/sys)) = 0.0.0.20211205182925.97ca703d548d
|
Provides: bundled(golang(golang.org/x/sys)) = 0.0.0.20211205182925.97ca703d548d
|
||||||
Provides: bundled(golang(golang.org/x/term)) = 0.0.0.20210927222741.03fcf44c2211
|
Provides: bundled(golang(golang.org/x/term)) = 0.0.0.20210927222741.03fcf44c2211
|
||||||
Provides: bundled(golang(golang.org/x/text)) = 0.3.8.0.20211105212822.18b340fc7af2
|
Provides: bundled(golang(golang.org/x/text)) = 0.3.8.0.20211105212822.18b340fc7af2
|
||||||
Provides: bundled(golang(golang.org/x/tools)) = 0.1.9.0.20211207220608.fd2bfb79a16a
|
Provides: bundled(golang(golang.org/x/tools)) = 0.1.9.0.20220124164225.97de9ec46646
|
||||||
Provides: bundled(golang(golang.org/x/xerrors)) = 0.0.0.20200804184101.5ec99f83aff1
|
Provides: bundled(golang(golang.org/x/xerrors)) = 0.0.0.20200804184101.5ec99f83aff1
|
||||||
|
|
||||||
Requires: %{name}-bin = %{version}-%{release}
|
Requires: %{name}-bin = %{version}-%{release}
|
||||||
@ -165,8 +165,6 @@ Requires: go-srpm-macros
|
|||||||
Patch1: 0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
|
Patch1: 0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
|
||||||
Patch2: 0002-syscall-expose-IfInfomsg.X__ifi_pad-on-s390x.patch
|
Patch2: 0002-syscall-expose-IfInfomsg.X__ifi_pad-on-s390x.patch
|
||||||
Patch3: 0003-cmd-go-disable-Google-s-proxy-and-sumdb.patch
|
Patch3: 0003-cmd-go-disable-Google-s-proxy-and-sumdb.patch
|
||||||
#https://go-review.googlesource.com/c/go/+/371634
|
|
||||||
Patch4: testshared-size-limit.patch
|
|
||||||
|
|
||||||
# Having documentation separate was broken
|
# Having documentation separate was broken
|
||||||
Obsoletes: %{name}-docs < 1.1-4
|
Obsoletes: %{name}-docs < 1.1-4
|
||||||
@ -543,6 +541,11 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 31 2022 Mike Rochefort <mroche@redhat.com> - 1.18~beta2-1
|
||||||
|
- Update to 1.18beta2
|
||||||
|
- Remove testshared-size-limit patch (now upstream) 83fc097
|
||||||
|
- Related: rhbz#2002859
|
||||||
|
|
||||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.18~beta1-2
|
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.18~beta1-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (go1.18beta1.src.tar.gz) = d7653939df98e7743ad88f9cb5f22ddf16a6ceae1097c80cfcf97a6cc22471f5a3fd455e08c9ec7aad5f1de0533e834bd2aa6f56527d121bfc2fbdd2b42e991c
|
SHA512 (go1.18beta2.src.tar.gz) = 8bea4e94c1536b12ea02b73b2cdbc703e05e65837ca50f41b4e71ec3265632609053d542ac08c145b96c94397177095d998cdedad58995b94e4da195f6f66196
|
||||||
|
@ -1,39 +0,0 @@
|
|||||||
From 69f7249bb644b8eaea9c67c369423fbbfdb6efbf Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jakub Čajka <jcajka@redhat.com>
|
|
||||||
Date: Mon, 13 Dec 2021 15:57:25 +0100
|
|
||||||
Subject: [PATCH] misc/cgo/testshared: increase size limit in size check
|
|
||||||
|
|
||||||
Recently in Fedora we switched binutils ld's separate-code on. This
|
|
||||||
led to increased size of binaries, especially on 64k aligned arches.
|
|
||||||
For example trivial test binary size grew from 80k to 211k on ppc64le
|
|
||||||
tripping the size check(RHBZ#2030308). Therefore adjusting the size limit.
|
|
||||||
|
|
||||||
Change-Id: Ic722d90c338739c0b285f40b12ba4d675e9626a2
|
|
||||||
---
|
|
||||||
|
|
||||||
diff --git a/misc/cgo/testshared/shared_test.go b/misc/cgo/testshared/shared_test.go
|
|
||||||
index d5d018f..6508152 100644
|
|
||||||
--- a/misc/cgo/testshared/shared_test.go
|
|
||||||
+++ b/misc/cgo/testshared/shared_test.go
|
|
||||||
@@ -462,7 +462,9 @@
|
|
||||||
run(t, "trivial executable", "../../bin/trivial")
|
|
||||||
AssertIsLinkedTo(t, "../../bin/trivial", soname)
|
|
||||||
AssertHasRPath(t, "../../bin/trivial", gorootInstallDir)
|
|
||||||
- checkSize(t, "../../bin/trivial", 100000) // it is 19K on linux/amd64, 100K should be enough
|
|
||||||
+ // It is 19K on linux/amd64, with separate-code in binutils ld and 64k being most common alignment
|
|
||||||
+ // 4*64k should be enough, but this might need revision eventually.
|
|
||||||
+ checkSize(t, "../../bin/trivial", 256000)
|
|
||||||
}
|
|
||||||
|
|
||||||
// Build a trivial program in PIE mode that links against the shared runtime and check it runs.
|
|
||||||
@@ -471,7 +473,9 @@
|
|
||||||
run(t, "trivial executable", "./trivial.pie")
|
|
||||||
AssertIsLinkedTo(t, "./trivial.pie", soname)
|
|
||||||
AssertHasRPath(t, "./trivial.pie", gorootInstallDir)
|
|
||||||
- checkSize(t, "./trivial.pie", 100000) // it is 19K on linux/amd64, 100K should be enough
|
|
||||||
+ // It is 19K on linux/amd64, with separate-code in binutils ld and 64k being most common alignment
|
|
||||||
+ // 4*64k should be enough, but this might need revision eventually.
|
|
||||||
+ checkSize(t, "./trivial.pie", 256000)
|
|
||||||
}
|
|
||||||
|
|
||||||
// Check that the file size does not exceed a limit.
|
|
Loading…
Reference in New Issue
Block a user