Turn on back DWARF compression by default
Use less memory on 32bit targets during build
This commit is contained in:
parent
62f2ae0511
commit
4043bb182d
1310
0001-cmd-compile-set-stricter-inlining-threshold-in-large.patch
Normal file
1310
0001-cmd-compile-set-stricter-inlining-threshold-in-large.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,26 +0,0 @@
|
|||||||
From 6d0f113b34e323234eeb279984af83ba98e61c10 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Jakub=20=C4=8Cajka?= <jcajka@redhat.com>
|
|
||||||
Date: Wed, 18 Jul 2018 09:42:28 +0200
|
|
||||||
Subject: [PATCH 3/3] Don't compress dwarf by derfault as rpm/debuginfo is not
|
|
||||||
yet ready for it.
|
|
||||||
|
|
||||||
---
|
|
||||||
src/cmd/link/internal/ld/main.go | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/cmd/link/internal/ld/main.go b/src/cmd/link/internal/ld/main.go
|
|
||||||
index 23462f1154..565da989dd 100644
|
|
||||||
--- a/src/cmd/link/internal/ld/main.go
|
|
||||||
+++ b/src/cmd/link/internal/ld/main.go
|
|
||||||
@@ -123,7 +123,7 @@ func Main(arch *sys.Arch, theArch Arch) {
|
|
||||||
flag.BoolVar(&ctxt.linkShared, "linkshared", false, "link against installed Go shared libraries")
|
|
||||||
flag.Var(&ctxt.LinkMode, "linkmode", "set link `mode`")
|
|
||||||
flag.Var(&ctxt.BuildMode, "buildmode", "set build `mode`")
|
|
||||||
- flag.BoolVar(&ctxt.compressDWARF, "compressdwarf", true, "compress DWARF if possible")
|
|
||||||
+ flag.BoolVar(&ctxt.compressDWARF, "compressdwarf", false, "compress DWARF if possible")
|
|
||||||
objabi.Flagfn1("B", "add an ELF NT_GNU_BUILD_ID `note` when using ELF", addbuildinfo)
|
|
||||||
objabi.Flagfn1("L", "add specified `directory` to library path", func(a string) { Lflag(ctxt, a) })
|
|
||||||
objabi.AddVersionFlag() // -V
|
|
||||||
--
|
|
||||||
2.14.4
|
|
||||||
|
|
10
golang.spec
10
golang.spec
@ -106,7 +106,7 @@
|
|||||||
|
|
||||||
Name: golang
|
Name: golang
|
||||||
Version: 1.11
|
Version: 1.11
|
||||||
Release: 0.beta2.1%{?dist}
|
Release: 0.beta2.2%{?dist}
|
||||||
Summary: The Go Programming Language
|
Summary: The Go Programming Language
|
||||||
# source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
|
# source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
|
||||||
License: BSD and Public Domain
|
License: BSD and Public Domain
|
||||||
@ -183,7 +183,7 @@ Requires: go-srpm-macros
|
|||||||
|
|
||||||
Patch1: 0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
|
Patch1: 0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
|
||||||
Patch2: 0002-syscall-expose-IfInfomsg.X__ifi_pad-on-s390x.patch
|
Patch2: 0002-syscall-expose-IfInfomsg.X__ifi_pad-on-s390x.patch
|
||||||
Patch3: 0003-Don-t-compress-dwarf-by-derfault-as-rpm-debuginfo-is.patch
|
Patch3: 0001-cmd-compile-set-stricter-inlining-threshold-in-large.patch
|
||||||
|
|
||||||
# Having documentation separate was broken
|
# Having documentation separate was broken
|
||||||
Obsoletes: %{name}-docs < 1.1-4
|
Obsoletes: %{name}-docs < 1.1-4
|
||||||
@ -546,6 +546,12 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 27 2018 Jakub Čajka <jcajka@redhat.com> - 1.11-0.beta2.2
|
||||||
|
- Turn on back DWARF compression by default
|
||||||
|
- Use less memory on 32bit targets during build
|
||||||
|
- Resolves: BZ#1607270
|
||||||
|
- Related: BZ#1602096
|
||||||
|
|
||||||
* Fri Jul 20 2018 Jakub Čajka <jcajka@redhat.com> - 1.11-0.beta2.1
|
* Fri Jul 20 2018 Jakub Čajka <jcajka@redhat.com> - 1.11-0.beta2.1
|
||||||
- Rebase to 1.11beta2
|
- Rebase to 1.11beta2
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user