update to go1.5beta2
This commit is contained in:
parent
beda572475
commit
2ecad653a5
1
.gitignore
vendored
1
.gitignore
vendored
@ -19,3 +19,4 @@
|
|||||||
/go1.4rc2.src.tar.gz
|
/go1.4rc2.src.tar.gz
|
||||||
/go1.5beta1.src.tar.gz
|
/go1.5beta1.src.tar.gz
|
||||||
/golang-19087:a15f344a9efa-xattrs.tar
|
/golang-19087:a15f344a9efa-xattrs.tar
|
||||||
|
/go1.5beta2.src.tar.gz
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
commit 9adf684686bad7c6319080d0b1da8308a77b08c9
|
|
||||||
Author: Russ Cox <rsc@golang.org>
|
|
||||||
Date: Tue Jul 14 15:15:37 2015 -0400
|
|
||||||
|
|
||||||
cmd/go: fix TestVendorRun when $GOROOT is inside a symlinked path
|
|
||||||
|
|
||||||
Fixes #11305.
|
|
||||||
|
|
||||||
Change-Id: Icaa3a009aa4ab214c9aaf74f52c3e622fa266a9d
|
|
||||||
Reviewed-on: https://go-review.googlesource.com/12194
|
|
||||||
Reviewed-by: David Crawshaw <crawshaw@golang.org>
|
|
||||||
Reviewed-by: Ian Lance Taylor <iant@golang.org>
|
|
||||||
|
|
||||||
diff --git a/src/cmd/go/go_test.go b/src/cmd/go/go_test.go
|
|
||||||
index 98486c5..af54396 100644
|
|
||||||
--- a/src/cmd/go/go_test.go
|
|
||||||
+++ b/src/cmd/go/go_test.go
|
|
||||||
@@ -188,7 +188,11 @@ func (tg *testgoData) cd(dir string) {
|
|
||||||
if tg.wd == "" {
|
|
||||||
tg.wd = tg.pwd()
|
|
||||||
}
|
|
||||||
+ abs, err := filepath.Abs(dir)
|
|
||||||
tg.must(os.Chdir(dir))
|
|
||||||
+ if err == nil {
|
|
||||||
+ tg.setenv("PWD", abs)
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
// sleep sleeps for one tick, where a tick is a conservative estimate
|
|
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/src/syscall/exec_linux_test.go b/src/syscall/exec_linux_test.go
|
||||||
|
index 60d2734..b16540f 100644
|
||||||
|
--- a/src/syscall/exec_linux_test.go
|
||||||
|
+++ b/src/syscall/exec_linux_test.go
|
||||||
|
@@ -89,7 +89,7 @@ func kernelVersion(t *testing.T) (int, int) {
|
||||||
|
return major, minor
|
||||||
|
}
|
||||||
|
|
||||||
|
-func TestCloneNEWUSERAndRemapNoRootDisableSetgroups(t *testing.T) {
|
||||||
|
+func testCloneNEWUSERAndRemapNoRootDisableSetgroups(t *testing.T) {
|
||||||
|
if os.Getuid() == 0 {
|
||||||
|
t.Skip("skipping unprivileged user only test")
|
||||||
|
}
|
@ -1,3 +1,9 @@
|
|||||||
|
commit f8eb1e50541c8a9e55545d7470dbeab96073a632
|
||||||
|
Author: Vincent Batts <vbatts@hashbangbash.com>
|
||||||
|
Date: Thu Jul 16 11:38:45 2015 -0400
|
||||||
|
|
||||||
|
p224
|
||||||
|
|
||||||
diff --git a/api/go1.txt b/api/go1.txt
|
diff --git a/api/go1.txt b/api/go1.txt
|
||||||
index 5e3dea5..1a1ee83 100644
|
index 5e3dea5..1a1ee83 100644
|
||||||
--- a/api/go1.txt
|
--- a/api/go1.txt
|
||||||
@ -98,7 +104,7 @@ index f3b84e1..ca0b7cf 100644
|
|||||||
initP384()
|
initP384()
|
||||||
initP521()
|
initP521()
|
||||||
diff --git a/src/crypto/elliptic/elliptic_test.go b/src/crypto/elliptic/elliptic_test.go
|
diff --git a/src/crypto/elliptic/elliptic_test.go b/src/crypto/elliptic/elliptic_test.go
|
||||||
index 7e27913..0051d53 100644
|
index 7e27913..e0034fc 100644
|
||||||
--- a/src/crypto/elliptic/elliptic_test.go
|
--- a/src/crypto/elliptic/elliptic_test.go
|
||||||
+++ b/src/crypto/elliptic/elliptic_test.go
|
+++ b/src/crypto/elliptic/elliptic_test.go
|
||||||
@@ -6,27 +6,25 @@ package elliptic
|
@@ -6,27 +6,25 @@ package elliptic
|
||||||
@ -240,16 +246,16 @@ index 7e27913..0051d53 100644
|
|||||||
func TestMarshal(t *testing.T) {
|
func TestMarshal(t *testing.T) {
|
||||||
- p224 := P224()
|
- p224 := P224()
|
||||||
- _, x, y, err := GenerateKey(p224, rand.Reader)
|
- _, x, y, err := GenerateKey(p224, rand.Reader)
|
||||||
+ p254 := P254()
|
+ p256 := P256()
|
||||||
+ _, x, y, err := GenerateKey(p254, rand.Reader)
|
+ _, x, y, err := GenerateKey(p256, rand.Reader)
|
||||||
if err != nil {
|
if err != nil {
|
||||||
t.Error(err)
|
t.Error(err)
|
||||||
return
|
return
|
||||||
}
|
}
|
||||||
- serialized := Marshal(p224, x, y)
|
- serialized := Marshal(p224, x, y)
|
||||||
- xx, yy := Unmarshal(p224, serialized)
|
- xx, yy := Unmarshal(p224, serialized)
|
||||||
+ serialized := Marshal(p254, x, y)
|
+ serialized := Marshal(p256, x, y)
|
||||||
+ xx, yy := Unmarshal(p254, serialized)
|
+ xx, yy := Unmarshal(p256, serialized)
|
||||||
if xx == nil {
|
if xx == nil {
|
||||||
t.Error("failed to unmarshal")
|
t.Error("failed to unmarshal")
|
||||||
return
|
return
|
||||||
@ -1114,7 +1120,7 @@ index 83f9916..dea8589 100644
|
|||||||
priv, err = ecdsa.GenerateKey(elliptic.P256(), rand.Reader)
|
priv, err = ecdsa.GenerateKey(elliptic.P256(), rand.Reader)
|
||||||
case "P384":
|
case "P384":
|
||||||
diff --git a/src/crypto/x509/x509.go b/src/crypto/x509/x509.go
|
diff --git a/src/crypto/x509/x509.go b/src/crypto/x509/x509.go
|
||||||
index be6c013..aa55f55 100644
|
index be6c013..428053a 100644
|
||||||
--- a/src/crypto/x509/x509.go
|
--- a/src/crypto/x509/x509.go
|
||||||
+++ b/src/crypto/x509/x509.go
|
+++ b/src/crypto/x509/x509.go
|
||||||
@@ -308,9 +308,6 @@ func getPublicKeyAlgorithmFromOID(oid asn1.ObjectIdentifier) PublicKeyAlgorithm
|
@@ -308,9 +308,6 @@ func getPublicKeyAlgorithmFromOID(oid asn1.ObjectIdentifier) PublicKeyAlgorithm
|
||||||
@ -1153,13 +1159,12 @@ index be6c013..aa55f55 100644
|
|||||||
case elliptic.P256():
|
case elliptic.P256():
|
||||||
return oidNamedCurveP256, true
|
return oidNamedCurveP256, true
|
||||||
case elliptic.P384():
|
case elliptic.P384():
|
||||||
@@ -1466,9 +1458,6 @@ func signingParamsForPublicKey(pub interface{}, requestedSigAlgo SignatureAlgori
|
@@ -1466,7 +1458,7 @@ func signingParamsForPublicKey(pub interface{}, requestedSigAlgo SignatureAlgori
|
||||||
pubType = ECDSA
|
pubType = ECDSA
|
||||||
|
|
||||||
switch pub.Curve {
|
switch pub.Curve {
|
||||||
- case elliptic.P224(), elliptic.P256():
|
- case elliptic.P224(), elliptic.P256():
|
||||||
- hashFunc = crypto.SHA256
|
+ case elliptic.P256():
|
||||||
- sigAlgo.Algorithm = oidSignatureECDSAWithSHA256
|
hashFunc = crypto.SHA256
|
||||||
|
sigAlgo.Algorithm = oidSignatureECDSAWithSHA256
|
||||||
case elliptic.P384():
|
case elliptic.P384():
|
||||||
hashFunc = crypto.SHA384
|
|
||||||
sigAlgo.Algorithm = oidSignatureECDSAWithSHA384
|
|
||||||
|
30
golang.spec
30
golang.spec
@ -37,11 +37,11 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%global go_api 1.5
|
%global go_api 1.5
|
||||||
%global go_version 1.5beta1
|
%global go_version 1.5beta2
|
||||||
|
|
||||||
Name: golang
|
Name: golang
|
||||||
Version: 1.4.99
|
Version: 1.4.99
|
||||||
Release: 2.%{go_version}%{?dist}
|
Release: 3.%{go_version}%{?dist}
|
||||||
Summary: The Go Programming Language
|
Summary: The Go Programming Language
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -74,10 +74,9 @@ Patch1: golang-1.2-remove-ECC-p224.patch
|
|||||||
# https://github.com/golang/go/issues/11214
|
# https://github.com/golang/go/issues/11214
|
||||||
Patch213: go1.5beta1-disable-TestGdbPython.patch
|
Patch213: go1.5beta1-disable-TestGdbPython.patch
|
||||||
|
|
||||||
# disable TestVendorRun and TestVendorGOPATH
|
# disable TestCloneNEWUSERAndRemapNoRootDisableSetgroups
|
||||||
# https://github.com/golang/go/commit/9adf684686bad7c6319080d0b1da8308a77b08c9
|
# this is not possible in the limitied build chroot
|
||||||
Patch214: go1.5beta1-fix-TestVendorRun.patch
|
Patch214: go1.5beta2-disable-TestCloneNEWUSERAndRemapNoRootDisableSetgroups.patch
|
||||||
|
|
||||||
|
|
||||||
# Having documentation separate was broken
|
# Having documentation separate was broken
|
||||||
Obsoletes: %{name}-docs < 1.1-4
|
Obsoletes: %{name}-docs < 1.1-4
|
||||||
@ -211,7 +210,7 @@ end
|
|||||||
# disable TestGdbPython
|
# disable TestGdbPython
|
||||||
%patch213 -p1
|
%patch213 -p1
|
||||||
|
|
||||||
# disable TestVendorRun and TestVendorGOPATH
|
# disable TestCloneNEWUSERAndRemapNoRootDisableSetgroups
|
||||||
%patch214 -p1
|
%patch214 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -230,7 +229,9 @@ export GOHOSTARCH=%{gohostarch}
|
|||||||
|
|
||||||
pushd src
|
pushd src
|
||||||
# use our gcc options for this build, but store gcc as default for compiler
|
# use our gcc options for this build, but store gcc as default for compiler
|
||||||
CC="gcc $RPM_OPT_FLAGS $RPM_LD_FLAGS" \
|
CFLAGS="$RPM_OPT_FLAGS" \
|
||||||
|
LDFLAGS="$RPM_LD_FLAGS" \
|
||||||
|
CC="gcc" \
|
||||||
CC_FOR_TARGET="gcc" \
|
CC_FOR_TARGET="gcc" \
|
||||||
GOOS=linux \
|
GOOS=linux \
|
||||||
GOARCH=%{gohostarch} \
|
GOARCH=%{gohostarch} \
|
||||||
@ -338,10 +339,12 @@ cd src
|
|||||||
|
|
||||||
# XXX reenable. likely go1.5beta2 https://github.com/golang/go/commit/9adf684686bad7c6319080d0b1da8308a77b08c9
|
# XXX reenable. likely go1.5beta2 https://github.com/golang/go/commit/9adf684686bad7c6319080d0b1da8308a77b08c9
|
||||||
#CGO_ENABLED=0 ./run.bash --no-rebuild
|
#CGO_ENABLED=0 ./run.bash --no-rebuild
|
||||||
#CC="gcc $RPM_OPT_FLAGS $RPM_LD_FLAGS" \
|
|
||||||
CC="gcc $RPM_LD_FLAGS" \
|
#CFLAGS="$RPM_OPT_FLAGS" \
|
||||||
CC_FOR_TARGET="gcc" \
|
#LDFLAGS="$RPM_LD_FLAGS" \
|
||||||
#./run.bash --no-rebuild
|
#CC="gcc" \
|
||||||
|
#CC_FOR_TARGET="gcc" \
|
||||||
|
#./run.bash --no-rebuild
|
||||||
cd ..
|
cd ..
|
||||||
|
|
||||||
|
|
||||||
@ -408,6 +411,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 10 2015 Vincent Batts <vbatts@fedoraproject.org> - 1.4.99-3.1.5beta2
|
||||||
|
- updating to go1.5beta2
|
||||||
|
|
||||||
* Fri Jul 10 2015 Vincent Batts <vbatts@fedoraproject.org> - 1.4.99-2.1.5beta1
|
* Fri Jul 10 2015 Vincent Batts <vbatts@fedoraproject.org> - 1.4.99-2.1.5beta1
|
||||||
- add checksum to sources and fixed one patch
|
- add checksum to sources and fixed one patch
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -1,2 +1,3 @@
|
|||||||
d76dc07e475b2905b5fec1cf319b6356 golang-19087:a15f344a9efa-xattrs.tar
|
d76dc07e475b2905b5fec1cf319b6356 golang-19087:a15f344a9efa-xattrs.tar
|
||||||
aa82b90515edd1fa814e5ecb4ee771a4 go1.5beta1.src.tar.gz
|
aa82b90515edd1fa814e5ecb4ee771a4 go1.5beta1.src.tar.gz
|
||||||
|
a1389a16aeecd934fc175e4a57f59417 go1.5beta2.src.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user