Drop incorrect change for hostname location. The hostname binary moved place in Fedora 17 as part of the usr move feature and /bin is symlinked to /usr/bin. Just specify the actualy proper package name instead of a specific binary path.
Cleanup sources file just to include the current source. Please use "fedpkg new-sources" command to properly upload sources. Otherwise each time a build is done, or even "fedpra srpm" or "fedpkg prep" it downloads all the sources specified in the file
This commit is contained in:
parent
0d13e2d904
commit
19dca7ffd3
@ -1,11 +0,0 @@
|
||||
--- src/os/os_test.go.orig 2014-02-20 13:14:45.543644182 -0600
|
||||
+++ src/os/os_test.go 2014-02-20 13:14:55.934813622 -0600
|
||||
@@ -854,7 +854,7 @@
|
||||
t.Fatal(err)
|
||||
}
|
||||
defer r.Close()
|
||||
- p, err := StartProcess("/bin/hostname", []string{"hostname"}, &ProcAttr{Files: []*File{nil, w, Stderr}})
|
||||
+ p, err := StartProcess("/usr/bin/hostname", []string{"hostname"}, &ProcAttr{Files: []*File{nil, w, Stderr}})
|
||||
if err != nil {
|
||||
t.Fatal(err)
|
||||
}
|
15
golang.spec
15
golang.spec
@ -50,16 +50,9 @@ Source0: https://storage.googleapis.com/golang/go%{go_version}.src.tar.gz
|
||||
|
||||
# go1.5 bootstrapping. The compiler is written in golang.
|
||||
BuildRequires: golang > 1.4
|
||||
BuildRequires: hostname
|
||||
# use the arch dependent path in the bootstrap
|
||||
Patch212: ./golang-1.5-bootstrap-binary-path.patch
|
||||
|
||||
# this command moved places
|
||||
%if 0%{?fedora} >= 21
|
||||
BuildRequires: /usr/bin/hostname
|
||||
Patch210: golang-f21-hostname.patch
|
||||
%else
|
||||
BuildRequires: /bin/hostname
|
||||
%endif
|
||||
Patch212: golang-1.5-bootstrap-binary-path.patch
|
||||
|
||||
Provides: go = %{version}-%{release}
|
||||
Requires: %{name}-bin
|
||||
@ -194,10 +187,6 @@ end
|
||||
%prep
|
||||
%setup -q -n go
|
||||
|
||||
%if 0%{?fedora} >= 21
|
||||
%patch210 -p0
|
||||
%endif
|
||||
|
||||
# increase verbosity of build
|
||||
%patch0 -p1
|
||||
|
||||
|
5
sources
5
sources
@ -1,6 +1 @@
|
||||
d76dc07e475b2905b5fec1cf319b6356 golang-19087:a15f344a9efa-xattrs.tar
|
||||
aa82b90515edd1fa814e5ecb4ee771a4 go1.5beta1.src.tar.gz
|
||||
a1389a16aeecd934fc175e4a57f59417 go1.5beta2.src.tar.gz
|
||||
0020be59b7711307ebd37ac116a6ee34 go1.5beta3.src.tar.gz
|
||||
778f51addfb8ddaf61ed0165a534d4e3 go1.5rc1.src.tar.gz
|
||||
3f072baece07fa42d18376419afad323 go1.5.src.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user