Resolves: BZ#1404679
expose IfInfomsg.X__ifi_pad on s390x
This commit is contained in:
parent
66c8bd8593
commit
0dbd49fdd7
11
golang.spec
11
golang.spec
@ -91,7 +91,7 @@
|
|||||||
|
|
||||||
Name: golang
|
Name: golang
|
||||||
Version: 1.7.4
|
Version: 1.7.4
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: The Go Programming Language
|
Summary: The Go Programming Language
|
||||||
# source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
|
# source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
|
||||||
License: BSD and Public Domain
|
License: BSD and Public Domain
|
||||||
@ -137,6 +137,9 @@ Patch217: ppc64x-overflow-2.patch
|
|||||||
# Fix for https://github.com/golang/go/issues/17276
|
# Fix for https://github.com/golang/go/issues/17276
|
||||||
Patch218: tzdata-fix.patch
|
Patch218: tzdata-fix.patch
|
||||||
|
|
||||||
|
# Proposed patch by mmunday https://golang.org/cl/35262
|
||||||
|
Patch219: s390x-expose-IfInfomsg-X__ifi_pad.patch
|
||||||
|
|
||||||
# Having documentation separate was broken
|
# Having documentation separate was broken
|
||||||
Obsoletes: %{name}-docs < 1.1-4
|
Obsoletes: %{name}-docs < 1.1-4
|
||||||
|
|
||||||
@ -264,6 +267,8 @@ Summary: Golang shared object libraries
|
|||||||
|
|
||||||
%patch218 -p1
|
%patch218 -p1
|
||||||
|
|
||||||
|
%patch219 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# print out system information
|
# print out system information
|
||||||
uname -a
|
uname -a
|
||||||
@ -480,6 +485,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 20 2017 Jakub Čajka <jcajka@redhat.com> - 1.7.4-2
|
||||||
|
- Resolves: BZ#1404679
|
||||||
|
- expose IfInfomsg.X__ifi_pad on s390x
|
||||||
|
|
||||||
* Fri Dec 02 2016 Jakub Čajka <jcajka@redhat.com> - 1.7.4-1
|
* Fri Dec 02 2016 Jakub Čajka <jcajka@redhat.com> - 1.7.4-1
|
||||||
- Bump to 1.7.4
|
- Bump to 1.7.4
|
||||||
- Resolves: BZ#1400732
|
- Resolves: BZ#1400732
|
||||||
|
36
s390x-expose-IfInfomsg-X__ifi_pad.patch
Normal file
36
s390x-expose-IfInfomsg-X__ifi_pad.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
From 84b8c9ceaa5257f7ff4ab059ff208246ecdfe9d9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Munday <munday@ca.ibm.com>
|
||||||
|
Date: Tue, 17 Jan 2017 11:33:38 -0500
|
||||||
|
Subject: [PATCH] syscall: expose IfInfomsg.X__ifi_pad on s390x
|
||||||
|
|
||||||
|
Exposing this field on s390x improves compatibility with the other
|
||||||
|
linux architectures, all of which already expose it.
|
||||||
|
|
||||||
|
Fixes #18628 and updates #18632.
|
||||||
|
|
||||||
|
Change-Id: I08e8e1eb705f898cd8822f8bee0d61ce11d514b5
|
||||||
|
---
|
||||||
|
|
||||||
|
diff --git a/src/syscall/ztypes_linux_s390x.go b/src/syscall/ztypes_linux_s390x.go
|
||||||
|
index 63c4a83..b589425 100644
|
||||||
|
--- a/src/syscall/ztypes_linux_s390x.go
|
||||||
|
+++ b/src/syscall/ztypes_linux_s390x.go
|
||||||
|
@@ -449,12 +449,12 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
type IfInfomsg struct {
|
||||||
|
- Family uint8
|
||||||
|
- _ uint8
|
||||||
|
- Type uint16
|
||||||
|
- Index int32
|
||||||
|
- Flags uint32
|
||||||
|
- Change uint32
|
||||||
|
+ Family uint8
|
||||||
|
+ X__ifi_pad uint8
|
||||||
|
+ Type uint16
|
||||||
|
+ Index int32
|
||||||
|
+ Flags uint32
|
||||||
|
+ Change uint32
|
||||||
|
}
|
||||||
|
|
||||||
|
type IfAddrmsg struct {
|
Loading…
Reference in New Issue
Block a user