Rebase to 1.6.2
This commit is contained in:
parent
b2c2028475
commit
04b972ebf4
1
.gitignore
vendored
1
.gitignore
vendored
@ -30,3 +30,4 @@
|
|||||||
/go1.6rc1.src.tar.gz
|
/go1.6rc1.src.tar.gz
|
||||||
/go1.6.src.tar.gz
|
/go1.6.src.tar.gz
|
||||||
/go1.6.1.src.tar.gz
|
/go1.6.1.src.tar.gz
|
||||||
|
/go1.6.2.src.tar.gz
|
||||||
|
@ -1,206 +0,0 @@
|
|||||||
diff -up go/src/syscall/types_linux.go.than go/src/syscall/types_linux.go
|
|
||||||
--- go/src/syscall/types_linux.go.than 2016-04-12 09:49:46.699333091 -0400
|
|
||||||
+++ go/src/syscall/types_linux.go 2016-04-12 09:50:18.859856525 -0400
|
|
||||||
@@ -105,6 +105,9 @@ struct my_epoll_event {
|
|
||||||
// alignment requirements of EABI
|
|
||||||
int32_t padFd;
|
|
||||||
#endif
|
|
||||||
+#ifdef __powerpc64__
|
|
||||||
+ int32_t _padFd;
|
|
||||||
+#endif
|
|
||||||
int32_t fd;
|
|
||||||
int32_t pad;
|
|
||||||
};
|
|
||||||
diff -up go/src/syscall/ztypes_linux_ppc64.go.than go/src/syscall/ztypes_linux_ppc64.go
|
|
||||||
--- go/src/syscall/ztypes_linux_ppc64.go.than 2016-04-12 09:50:27.499997298 -0400
|
|
||||||
+++ go/src/syscall/ztypes_linux_ppc64.go 2016-04-12 09:54:27.593909191 -0400
|
|
||||||
@@ -113,9 +113,9 @@ type Stat_t struct {
|
|
||||||
Atim Timespec
|
|
||||||
Mtim Timespec
|
|
||||||
Ctim Timespec
|
|
||||||
- X__unused4 uint64
|
|
||||||
- X__unused5 uint64
|
|
||||||
- X__unused6 uint64
|
|
||||||
+ _ uint64
|
|
||||||
+ _ uint64
|
|
||||||
+ _ uint64
|
|
||||||
}
|
|
||||||
|
|
||||||
type Statfs_t struct {
|
|
||||||
@@ -143,7 +143,7 @@ type Dirent struct {
|
|
||||||
}
|
|
||||||
|
|
||||||
type Fsid struct {
|
|
||||||
- X__val [2]int32
|
|
||||||
+ _ [2]int32
|
|
||||||
}
|
|
||||||
|
|
||||||
type Flock_t struct {
|
|
||||||
@@ -247,7 +247,6 @@ type Cmsghdr struct {
|
|
||||||
Len uint64
|
|
||||||
Level int32
|
|
||||||
Type int32
|
|
||||||
- X__cmsg_data [0]uint8
|
|
||||||
}
|
|
||||||
|
|
||||||
type Inet4Pktinfo struct {
|
|
||||||
@@ -361,7 +360,7 @@ const (
|
|
||||||
IFLA_LINKINFO = 0x12
|
|
||||||
IFLA_NET_NS_PID = 0x13
|
|
||||||
IFLA_IFALIAS = 0x14
|
|
||||||
- IFLA_MAX = 0x22
|
|
||||||
+ IFLA_MAX = 0x25
|
|
||||||
RT_SCOPE_UNIVERSE = 0x0
|
|
||||||
RT_SCOPE_SITE = 0xc8
|
|
||||||
RT_SCOPE_LINK = 0xfd
|
|
||||||
@@ -454,7 +453,7 @@ type RtAttr struct {
|
|
||||||
|
|
||||||
type IfInfomsg struct {
|
|
||||||
Family uint8
|
|
||||||
- X__ifi_pad uint8
|
|
||||||
+ _ uint8
|
|
||||||
Type uint16
|
|
||||||
Index int32
|
|
||||||
Flags uint32
|
|
||||||
@@ -511,7 +510,6 @@ type InotifyEvent struct {
|
|
||||||
Mask uint32
|
|
||||||
Cookie uint32
|
|
||||||
Len uint32
|
|
||||||
- Name [0]uint8
|
|
||||||
}
|
|
||||||
|
|
||||||
const SizeofInotifyEvent = 0x10
|
|
||||||
@@ -532,6 +530,15 @@ type PtraceRegs struct {
|
|
||||||
Result uint64
|
|
||||||
}
|
|
||||||
|
|
||||||
+type ptracePsw struct {
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+type ptraceFpregs struct {
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+type ptracePer struct {
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
type FdSet struct {
|
|
||||||
Bits [16]int64
|
|
||||||
}
|
|
||||||
@@ -551,7 +558,7 @@ type Sysinfo_t struct {
|
|
||||||
Totalhigh uint64
|
|
||||||
Freehigh uint64
|
|
||||||
Unit uint32
|
|
||||||
- X_f [0]uint8
|
|
||||||
+ _ [0]uint8
|
|
||||||
Pad_cgo_1 [4]byte
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -575,6 +582,7 @@ type Ustat_t struct {
|
|
||||||
|
|
||||||
type EpollEvent struct {
|
|
||||||
Events uint32
|
|
||||||
+ _ int32
|
|
||||||
Fd int32
|
|
||||||
Pad int32
|
|
||||||
}
|
|
||||||
diff -up go/src/syscall/ztypes_linux_ppc64le.go.than go/src/syscall/ztypes_linux_ppc64le.go
|
|
||||||
--- go/src/syscall/ztypes_linux_ppc64le.go.than 2016-04-12 09:54:37.134064629 -0400
|
|
||||||
+++ go/src/syscall/ztypes_linux_ppc64le.go 2016-04-12 09:58:11.097550772 -0400
|
|
||||||
@@ -105,7 +105,7 @@ type Stat_t struct {
|
|
||||||
Mode uint32
|
|
||||||
Uid uint32
|
|
||||||
Gid uint32
|
|
||||||
- X__pad2 int32
|
|
||||||
+ _ int32
|
|
||||||
Rdev uint64
|
|
||||||
Size int64
|
|
||||||
Blksize int64
|
|
||||||
@@ -113,9 +113,9 @@ type Stat_t struct {
|
|
||||||
Atim Timespec
|
|
||||||
Mtim Timespec
|
|
||||||
Ctim Timespec
|
|
||||||
- X__glibc_reserved4 uint64
|
|
||||||
- X__glibc_reserved5 uint64
|
|
||||||
- X__glibc_reserved6 uint64
|
|
||||||
+ _ uint64
|
|
||||||
+ _ uint64
|
|
||||||
+ _ uint64
|
|
||||||
}
|
|
||||||
|
|
||||||
type Statfs_t struct {
|
|
||||||
@@ -143,7 +143,7 @@ type Dirent struct {
|
|
||||||
}
|
|
||||||
|
|
||||||
type Fsid struct {
|
|
||||||
- X__val [2]int32
|
|
||||||
+ _ [2]int32
|
|
||||||
}
|
|
||||||
|
|
||||||
type Flock_t struct {
|
|
||||||
@@ -247,7 +247,6 @@ type Cmsghdr struct {
|
|
||||||
Len uint64
|
|
||||||
Level int32
|
|
||||||
Type int32
|
|
||||||
- X__cmsg_data [0]uint8
|
|
||||||
}
|
|
||||||
|
|
||||||
type Inet4Pktinfo struct {
|
|
||||||
@@ -361,7 +360,7 @@ const (
|
|
||||||
IFLA_LINKINFO = 0x12
|
|
||||||
IFLA_NET_NS_PID = 0x13
|
|
||||||
IFLA_IFALIAS = 0x14
|
|
||||||
- IFLA_MAX = 0x22
|
|
||||||
+ IFLA_MAX = 0x23
|
|
||||||
RT_SCOPE_UNIVERSE = 0x0
|
|
||||||
RT_SCOPE_SITE = 0xc8
|
|
||||||
RT_SCOPE_LINK = 0xfd
|
|
||||||
@@ -454,7 +453,7 @@ type RtAttr struct {
|
|
||||||
|
|
||||||
type IfInfomsg struct {
|
|
||||||
Family uint8
|
|
||||||
- X__ifi_pad uint8
|
|
||||||
+ _ uint8
|
|
||||||
Type uint16
|
|
||||||
Index int32
|
|
||||||
Flags uint32
|
|
||||||
@@ -511,7 +510,6 @@ type InotifyEvent struct {
|
|
||||||
Mask uint32
|
|
||||||
Cookie uint32
|
|
||||||
Len uint32
|
|
||||||
- Name [0]uint8
|
|
||||||
}
|
|
||||||
|
|
||||||
const SizeofInotifyEvent = 0x10
|
|
||||||
@@ -532,6 +530,15 @@ type PtraceRegs struct {
|
|
||||||
Result uint64
|
|
||||||
}
|
|
||||||
|
|
||||||
+type ptracePsw struct {
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+type ptraceFpregs struct {
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+type ptracePer struct {
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
type FdSet struct {
|
|
||||||
Bits [16]int64
|
|
||||||
}
|
|
||||||
@@ -551,7 +558,7 @@ type Sysinfo_t struct {
|
|
||||||
Totalhigh uint64
|
|
||||||
Freehigh uint64
|
|
||||||
Unit uint32
|
|
||||||
- X_f [0]uint8
|
|
||||||
+ _ [0]uint8
|
|
||||||
Pad_cgo_1 [4]byte
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -575,6 +582,7 @@ type Ustat_t struct {
|
|
||||||
|
|
||||||
type EpollEvent struct {
|
|
||||||
Events uint32
|
|
||||||
+ _ int32
|
|
||||||
Fd int32
|
|
||||||
Pad int32
|
|
||||||
}
|
|
19
golang.spec
19
golang.spec
@ -82,10 +82,10 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%global go_api 1.6
|
%global go_api 1.6
|
||||||
%global go_version 1.6.1
|
%global go_version 1.6.2
|
||||||
|
|
||||||
Name: golang
|
Name: golang
|
||||||
Version: 1.6.1
|
Version: 1.6.2
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Go Programming Language
|
Summary: The Go Programming Language
|
||||||
# source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
|
# source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
|
||||||
@ -117,14 +117,6 @@ Patch0: golang-1.2-verbose-build.patch
|
|||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1038683
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1038683
|
||||||
Patch1: golang-1.2-remove-ECC-p224.patch
|
Patch1: golang-1.2-remove-ECC-p224.patch
|
||||||
|
|
||||||
# Resolves RHBZ 1304591
|
|
||||||
# https://github.com/golang/go/issues/14384
|
|
||||||
Patch100: mmap-cgo-stackalign.patch
|
|
||||||
|
|
||||||
# Resolves RHBZ 1326366
|
|
||||||
# https://github.com/golang/go/issues/15135
|
|
||||||
Patch101: golang-1.6-epoll-power64.patch
|
|
||||||
|
|
||||||
# use the arch dependent path in the bootstrap
|
# use the arch dependent path in the bootstrap
|
||||||
Patch212: golang-1.5-bootstrap-binary-path.patch
|
Patch212: golang-1.5-bootstrap-binary-path.patch
|
||||||
|
|
||||||
@ -250,9 +242,6 @@ Summary: Golang shared object libraries
|
|||||||
# remove the P224 curve
|
# remove the P224 curve
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
|
||||||
%patch100 -p1
|
|
||||||
%patch101 -p1 -b .epoll
|
|
||||||
|
|
||||||
# use the arch dependent path in the bootstrap
|
# use the arch dependent path in the bootstrap
|
||||||
%patch212 -p1
|
%patch212 -p1
|
||||||
|
|
||||||
@ -465,6 +454,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 26 2016 Jakub Čajka <jcajka@redhat.com> - 1.6.2-1
|
||||||
|
- rebase to 1.6.2
|
||||||
|
- Resolves: bz1329206 - golang-1.6.2.src is available
|
||||||
|
|
||||||
* Wed Apr 13 2016 Jakub Čajka <jcajka@redhat.com> - 1.6.1-1
|
* Wed Apr 13 2016 Jakub Čajka <jcajka@redhat.com> - 1.6.1-1
|
||||||
- rebase to 1.6.1
|
- rebase to 1.6.1
|
||||||
- Resolves: bz1324344 - CVE-2016-3959
|
- Resolves: bz1324344 - CVE-2016-3959
|
||||||
|
@ -1,43 +0,0 @@
|
|||||||
From 315f4c70f123cfbf061d097543af555547acd9c7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Shenghou Ma <minux@golang.org>
|
|
||||||
Date: Thu, 18 Feb 2016 16:29:39 -0500
|
|
||||||
Subject: [PATCH] runtime: use correct psABI SP alignment before calling libc
|
|
||||||
mmap
|
|
||||||
|
|
||||||
Fixes #14384.
|
|
||||||
|
|
||||||
Change-Id: Ib025cf2d20754b4c2db52f0a8a4717fd303371d6
|
|
||||||
Reviewed-on: https://go-review.googlesource.com/19660
|
|
||||||
Run-TryBot: Minux Ma <minux@golang.org>
|
|
||||||
TryBot-Result: Gobot Gobot <gobot@golang.org>
|
|
||||||
Reviewed-by: Ian Lance Taylor <iant@golang.org>
|
|
||||||
Reviewed-by: Austin Clements <austin@google.com>
|
|
||||||
---
|
|
||||||
src/runtime/sys_linux_amd64.s | 6 +++++-
|
|
||||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/runtime/sys_linux_amd64.s b/src/runtime/sys_linux_amd64.s
|
|
||||||
index aed85cb..f407078 100644
|
|
||||||
--- a/src/runtime/sys_linux_amd64.s
|
|
||||||
+++ b/src/runtime/sys_linux_amd64.s
|
|
||||||
@@ -258,7 +258,7 @@ TEXT runtime·sysMmap(SB),NOSPLIT,$0
|
|
||||||
|
|
||||||
// Call the function stored in _cgo_mmap using the GCC calling convention.
|
|
||||||
// This must be called on the system stack.
|
|
||||||
-TEXT runtime·callCgoMmap(SB),NOSPLIT,$0
|
|
||||||
+TEXT runtime·callCgoMmap(SB),NOSPLIT,$16
|
|
||||||
MOVQ addr+0(FP), DI
|
|
||||||
MOVQ n+8(FP), SI
|
|
||||||
MOVL prot+16(FP), DX
|
|
||||||
@@ -266,7 +266,11 @@ TEXT runtime·callCgoMmap(SB),NOSPLIT,$0
|
|
||||||
MOVL fd+24(FP), R8
|
|
||||||
MOVL off+28(FP), R9
|
|
||||||
MOVQ _cgo_mmap(SB), AX
|
|
||||||
+ MOVQ SP, BX
|
|
||||||
+ ANDQ $~15, SP // alignment as per amd64 psABI
|
|
||||||
+ MOVQ BX, 0(SP)
|
|
||||||
CALL AX
|
|
||||||
+ MOVQ 0(SP), SP
|
|
||||||
MOVQ AX, ret+32(FP)
|
|
||||||
RET
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user