updated to gnutls 3.5.6
This commit is contained in:
parent
3cf950d530
commit
dc821ab455
1
.gitignore
vendored
1
.gitignore
vendored
@ -68,3 +68,4 @@ gnutls-2.10.1-nosrp.tar.bz2
|
||||
/gnutls-3.5.3-hobbled.tar.xz
|
||||
/gnutls-3.5.4-hobbled.tar.xz
|
||||
/gnutls-3.5.5-hobbled.tar.xz
|
||||
/gnutls-3.5.6-hobbled.tar.xz
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 7bf494eb0838f328c1247f60deb637552c1fb170 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Tue, 11 Oct 2016 11:28:39 -0400
|
||||
Subject: [PATCH] priorities: Do read crypto policy files with mtime of zero
|
||||
|
||||
In a default Fedora Atomic Host installation,
|
||||
`/etc/crypto-policies/backends/gnutls.config` is a symlink to the
|
||||
default in `/usr/share/`. On an OSTree-managed system, files in
|
||||
`/usr` have an mtime of zero (to help deduplication).
|
||||
|
||||
The simple fix here is to still try to read the first time, even if
|
||||
the file has an mtime of zero.
|
||||
---
|
||||
lib/priority.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/priority.c b/lib/priority.c
|
||||
index 0fa38f9..880fa58 100644
|
||||
--- a/lib/priority.c
|
||||
+++ b/lib/priority.c
|
||||
@@ -945,7 +945,8 @@ static void _gnutls_update_system_priorities(void)
|
||||
return;
|
||||
}
|
||||
|
||||
- if (sb.st_mtime == system_priority_last_mod) {
|
||||
+ if (system_priority_buf != NULL &&
|
||||
+ sb.st_mtime == system_priority_last_mod) {
|
||||
_gnutls_debug_log("system priority %s has not changed\n",
|
||||
system_priority_file);
|
||||
return;
|
||||
--
|
||||
2.7.4
|
||||
|
@ -2,8 +2,8 @@
|
||||
%bcond_without guile
|
||||
Summary: A TLS protocol implementation
|
||||
Name: gnutls
|
||||
Version: 3.5.5
|
||||
Release: 2%{?dist}
|
||||
Version: 3.5.6
|
||||
Release: 1%{?dist}
|
||||
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
||||
License: GPLv3+ and LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
@ -35,7 +35,6 @@ Source2: hobble-gnutls
|
||||
Patch1: gnutls-3.2.7-rpath.patch
|
||||
Patch2: gnutls-3.5.1-default-policy.patch
|
||||
Patch3: gnutls-3.4.2-no-now-guile.patch
|
||||
Patch4: 0001-priorities-Do-read-crypto-policy-files-with-mtime-of.patch
|
||||
|
||||
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
||||
Provides: bundled(gnulib) = 20130424
|
||||
@ -138,7 +137,6 @@ This package contains Guile bindings for the library.
|
||||
%patch1 -p1 -b .rpath
|
||||
%patch2 -p1 -b .default-policy
|
||||
%patch3 -p1 -b .guile
|
||||
%patch4 -p1
|
||||
|
||||
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
||||
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
||||
@ -269,6 +267,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Nov 4 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.5.6-1
|
||||
- New upstream release
|
||||
|
||||
* Tue Oct 11 2016 walters@redhat.com - 3.5.5-2
|
||||
- Apply patch to fix compatibility with ostree (#1383708)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user