Apply patch for ostree compat
This commit is contained in:
parent
b441c90d18
commit
3cf950d530
@ -0,0 +1,33 @@
|
||||
From 7bf494eb0838f328c1247f60deb637552c1fb170 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Tue, 11 Oct 2016 11:28:39 -0400
|
||||
Subject: [PATCH] priorities: Do read crypto policy files with mtime of zero
|
||||
|
||||
In a default Fedora Atomic Host installation,
|
||||
`/etc/crypto-policies/backends/gnutls.config` is a symlink to the
|
||||
default in `/usr/share/`. On an OSTree-managed system, files in
|
||||
`/usr` have an mtime of zero (to help deduplication).
|
||||
|
||||
The simple fix here is to still try to read the first time, even if
|
||||
the file has an mtime of zero.
|
||||
---
|
||||
lib/priority.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/priority.c b/lib/priority.c
|
||||
index 0fa38f9..880fa58 100644
|
||||
--- a/lib/priority.c
|
||||
+++ b/lib/priority.c
|
||||
@@ -945,7 +945,8 @@ static void _gnutls_update_system_priorities(void)
|
||||
return;
|
||||
}
|
||||
|
||||
- if (sb.st_mtime == system_priority_last_mod) {
|
||||
+ if (system_priority_buf != NULL &&
|
||||
+ sb.st_mtime == system_priority_last_mod) {
|
||||
_gnutls_debug_log("system priority %s has not changed\n",
|
||||
system_priority_file);
|
||||
return;
|
||||
--
|
||||
2.7.4
|
||||
|
@ -3,7 +3,7 @@
|
||||
Summary: A TLS protocol implementation
|
||||
Name: gnutls
|
||||
Version: 3.5.5
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# The libraries are LGPLv2.1+, utilities are GPLv3+
|
||||
License: GPLv3+ and LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
@ -35,6 +35,7 @@ Source2: hobble-gnutls
|
||||
Patch1: gnutls-3.2.7-rpath.patch
|
||||
Patch2: gnutls-3.5.1-default-policy.patch
|
||||
Patch3: gnutls-3.4.2-no-now-guile.patch
|
||||
Patch4: 0001-priorities-Do-read-crypto-policy-files-with-mtime-of.patch
|
||||
|
||||
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
|
||||
Provides: bundled(gnulib) = 20130424
|
||||
@ -137,6 +138,7 @@ This package contains Guile bindings for the library.
|
||||
%patch1 -p1 -b .rpath
|
||||
%patch2 -p1 -b .default-policy
|
||||
%patch3 -p1 -b .guile
|
||||
%patch4 -p1
|
||||
|
||||
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
|
||||
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
|
||||
@ -267,6 +269,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Oct 11 2016 walters@redhat.com - 3.5.5-2
|
||||
- Apply patch to fix compatibility with ostree (#1383708)
|
||||
|
||||
* Mon Oct 10 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.5.5-1
|
||||
- New upstream release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user