Rebase to upstream release 5.2.4
Add workaround for broken info generation (upstream bug https://sourceforge.net/p/gnuplot/bugs/1963/) from Debian Use explicit path for texdir.
This commit is contained in:
parent
0e0986456d
commit
f4e8798e5c
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@
|
||||
/gnuplot-5.0.5.tar.gz
|
||||
/gnuplot-5.0.6.tar.gz
|
||||
/gnuplot-5.0.6-clean.tar.gz
|
||||
/gnuplot-5.2.4-clean.tar.gz
|
||||
|
27
gnuplot-5.2.2-doc.patch
Normal file
27
gnuplot-5.2.2-doc.patch
Normal file
@ -0,0 +1,27 @@
|
||||
diff -up gnuplot-5.2.4/docs/gnuplot.doc gnuplot-5.2.4/docs/gnuplot
|
||||
diff -up gnuplot-5.2.4/docs/gnuplot-ja.doc gnuplot-5.2.4/docs/gnuplot-ja
|
||||
diff -up gnuplot-5.2.4/docs/Makefile.am.doc gnuplot-5.2.4/docs/Makefile.am
|
||||
--- gnuplot-5.2.4/docs/Makefile.am.doc 2017-12-22 18:32:48.000000000 +0100
|
||||
+++ gnuplot-5.2.4/docs/Makefile.am 2018-08-08 14:00:40.014932164 +0200
|
||||
@@ -322,7 +322,7 @@ ${ELCS}: gnuplot-eldoc.el
|
||||
# that only appears to work with a non-generated texi file for input.
|
||||
|
||||
gnuplot.info: gnuplot.texi
|
||||
- $(AM_V_GEN) $(MAKEINFO) -I$(srcdir) $< --no-split --output=$@
|
||||
+ $(AM_V_GEN) $(MAKEINFO) -I$(srcdir) $< --no-split --force --output=$@
|
||||
|
||||
install-info: gnuplot.info
|
||||
$(AM_V_at) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(infodir)
|
||||
diff -up gnuplot-5.2.4/docs/Makefile.in.doc gnuplot-5.2.4/docs/Makefile.in
|
||||
--- gnuplot-5.2.4/docs/Makefile.in.doc 2018-06-01 03:51:14.000000000 +0200
|
||||
+++ gnuplot-5.2.4/docs/Makefile.in 2018-08-08 14:03:26.797479806 +0200
|
||||
@@ -1090,7 +1090,7 @@ ${ELCS}: gnuplot-eldoc.el
|
||||
# that only appears to work with a non-generated texi file for input.
|
||||
|
||||
gnuplot.info: gnuplot.texi
|
||||
- $(AM_V_GEN) $(MAKEINFO) -I$(srcdir) $< --no-split --output=$@
|
||||
+ $(AM_V_GEN) $(MAKEINFO) -I$(srcdir) $< --no-split --force --output=$@
|
||||
|
||||
install-info: gnuplot.info
|
||||
$(AM_V_at) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(infodir)
|
||||
diff -up gnuplot-5.2.4/docs/psdoc/ps_file.doc gnuplot-5.2.4/docs/psdoc/ps_file
|
@ -1,6 +1,6 @@
|
||||
diff -up gnuplot-5.0.6/demo/circles.dem.nolena gnuplot-5.0.6/demo/circles.dem
|
||||
--- gnuplot-5.0.6/demo/circles.dem.nolena 2017-06-26 12:44:54.497798902 -0400
|
||||
+++ gnuplot-5.0.6/demo/circles.dem 2017-06-26 12:45:05.006547459 -0400
|
||||
diff -up gnuplot-5.2.4/demo/circles.dem.nolena gnuplot-5.2.4/demo/circles.dem
|
||||
--- gnuplot-5.2.4/demo/circles.dem.nolena 2017-12-22 18:32:30.000000000 +0100
|
||||
+++ gnuplot-5.2.4/demo/circles.dem 2018-08-08 10:14:21.308379527 +0200
|
||||
@@ -98,21 +98,6 @@ pause -1 "Hit return to continue"
|
||||
|
||||
reset
|
||||
@ -23,10 +23,10 @@ diff -up gnuplot-5.0.6/demo/circles.dem.nolena gnuplot-5.0.6/demo/circles.dem
|
||||
set title "Delaunay triangulation of Hemisphere points, some empty circles in red"
|
||||
unset key
|
||||
|
||||
diff -up gnuplot-5.0.6/demo/Makefile.am.nolena gnuplot-5.0.6/demo/Makefile.am
|
||||
--- gnuplot-5.0.6/demo/Makefile.am.nolena 2017-06-26 12:44:33.146309782 -0400
|
||||
+++ gnuplot-5.0.6/demo/Makefile.am 2017-06-26 12:44:43.322066306 -0400
|
||||
@@ -64,7 +64,7 @@ epslatex:
|
||||
diff -up gnuplot-5.2.4/demo/Makefile.am.nolena gnuplot-5.2.4/demo/Makefile.am
|
||||
--- gnuplot-5.2.4/demo/Makefile.am.nolena 2017-12-23 07:29:12.000000000 +0100
|
||||
+++ gnuplot-5.2.4/demo/Makefile.am 2018-08-08 10:18:08.787797877 +0200
|
||||
@@ -68,7 +68,7 @@ epslatex:
|
||||
dvips epslatex
|
||||
|
||||
##m4-files-begin
|
||||
@ -35,19 +35,19 @@ diff -up gnuplot-5.0.6/demo/Makefile.am.nolena gnuplot-5.0.6/demo/Makefile.am
|
||||
using.bin gnuplot.cfg world.cor 1.dat 2.dat 3.dat arrowstyle.dat \
|
||||
asciimat.dat battery.dat big_peak.dat candlesticks.dat cities.dat \
|
||||
clip14in.dat ctg-y2.dat delaunay-edges.dat ellipses.dat empty-circles.dat \
|
||||
@@ -97,7 +97,7 @@ stringvar.dem surface1.dem surface2.dem
|
||||
tics.dem timedat.dem transparent.dem transparent_solids.dem using.dem \
|
||||
utf8.dem varcolor.dem vector.dem world2.dem world.dem demo.edf density.fnc \
|
||||
@@ -107,7 +107,7 @@ textrotate.dem tics.dem timedat.dem tran
|
||||
ttics.dem using.dem utf8.dem varcolor.dem vector.dem violinplot.dem \
|
||||
volatile.dem world2.dem world.dem zerror.dem demo.edf density.fnc \
|
||||
hexa.fnc line.fnc reflect.fnc gen-random.inc stat.inc GM1_sugar.pdb \
|
||||
-bldg.png GM1_bonds.r3d blutux.rgb lena.rgb sound.par sound2.par start.par \
|
||||
+bldg.png GM1_bonds.r3d blutux.rgb sound.par sound2.par start.par \
|
||||
gnuplot.rot gnu-valley random-points gpdemos.tcl html
|
||||
##m4-files-end
|
||||
|
||||
diff -up gnuplot-5.0.6/demo/Makefile.in.nolena gnuplot-5.0.6/demo/Makefile.in
|
||||
--- gnuplot-5.0.6/demo/Makefile.in.nolena 2017-06-26 12:43:56.569184965 -0400
|
||||
+++ gnuplot-5.0.6/demo/Makefile.in 2017-06-26 12:44:17.562682652 -0400
|
||||
@@ -331,7 +331,7 @@ SUBDIRS = $(PLUGIN_DIR)
|
||||
diff -up gnuplot-5.2.4/demo/Makefile.in.nolena gnuplot-5.2.4/demo/Makefile.in
|
||||
--- gnuplot-5.2.4/demo/Makefile.in.nolena 2018-06-01 03:51:13.000000000 +0200
|
||||
+++ gnuplot-5.2.4/demo/Makefile.in 2018-08-08 10:18:14.455683660 +0200
|
||||
@@ -330,7 +330,7 @@ SUBDIRS = $(PLUGIN_DIR)
|
||||
DIST_SUBDIRS = plugin
|
||||
DEMO = all.dem
|
||||
GNUPLOT = gnuplot
|
||||
@ -56,18 +56,18 @@ diff -up gnuplot-5.0.6/demo/Makefile.in.nolena gnuplot-5.0.6/demo/Makefile.in
|
||||
using.bin gnuplot.cfg world.cor 1.dat 2.dat 3.dat arrowstyle.dat \
|
||||
asciimat.dat battery.dat big_peak.dat candlesticks.dat cities.dat \
|
||||
clip14in.dat ctg-y2.dat delaunay-edges.dat ellipses.dat empty-circles.dat \
|
||||
@@ -364,7 +364,7 @@ stringvar.dem surface1.dem surface2.dem
|
||||
tics.dem timedat.dem transparent.dem transparent_solids.dem using.dem \
|
||||
utf8.dem varcolor.dem vector.dem world2.dem world.dem demo.edf density.fnc \
|
||||
@@ -369,7 +369,7 @@ textrotate.dem tics.dem timedat.dem tran
|
||||
ttics.dem using.dem utf8.dem varcolor.dem vector.dem violinplot.dem \
|
||||
volatile.dem world2.dem world.dem zerror.dem demo.edf density.fnc \
|
||||
hexa.fnc line.fnc reflect.fnc gen-random.inc stat.inc GM1_sugar.pdb \
|
||||
-bldg.png GM1_bonds.r3d blutux.rgb lena.rgb sound.par sound2.par start.par \
|
||||
+bldg.png GM1_bonds.r3d blutux.rgb sound.par sound2.par start.par \
|
||||
gnuplot.rot gnu-valley random-points gpdemos.tcl html
|
||||
|
||||
@BUILD_PLUGIN_TRUE@PLUGIN_DIR = plugin
|
||||
diff -up gnuplot-5.0.6/demo/rgbalpha.dem.nolena gnuplot-5.0.6/demo/rgbalpha.dem
|
||||
--- gnuplot-5.0.6/demo/rgbalpha.dem.nolena 2017-06-26 12:46:06.232082511 -0400
|
||||
+++ gnuplot-5.0.6/demo/rgbalpha.dem 2017-06-26 12:46:37.431336005 -0400
|
||||
diff -up gnuplot-5.2.4/demo/rgbalpha.dem.nolena gnuplot-5.2.4/demo/rgbalpha.dem
|
||||
--- gnuplot-5.2.4/demo/rgbalpha.dem.nolena 2017-12-22 18:32:30.000000000 +0100
|
||||
+++ gnuplot-5.2.4/demo/rgbalpha.dem 2018-08-08 10:14:21.309379507 +0200
|
||||
@@ -18,8 +18,8 @@ set yrange [ 0. : 128. ]
|
||||
# Alpha = linear gradient on x
|
||||
|
20
gnuplot.spec
20
gnuplot.spec
@ -1,6 +1,6 @@
|
||||
%global major 5
|
||||
%global minor 0
|
||||
%global patchlevel 6
|
||||
%global minor 2
|
||||
%global patchlevel 4
|
||||
|
||||
%global x11_app_defaults_dir %{_datadir}/X11/app-defaults
|
||||
|
||||
@ -13,7 +13,7 @@
|
||||
Summary: A program for plotting mathematical expressions and data
|
||||
Name: gnuplot
|
||||
Version: %{major}.%{minor}.%{patchlevel}
|
||||
Release: 14%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# MIT .. term/PostScript/aglfn.txt
|
||||
License: gnuplot and MIT
|
||||
URL: http://www.gnuplot.info/
|
||||
@ -30,7 +30,8 @@ Patch1: gnuplot-4.2.0-fonts.patch
|
||||
Patch3: gnuplot-4.6.1-plot-sigsegv.patch
|
||||
Patch4: gnuplot-4.6.4-singlethread.patch
|
||||
Patch5: gnuplot-5.0.0-lua_checkint.patch
|
||||
Patch6: gnuplot-5.0.6-no-lena.patch
|
||||
Patch6: gnuplot-5.2.4-no-lena.patch
|
||||
Patch7: gnuplot-5.2.2-doc.patch
|
||||
|
||||
Requires: %{name}-common = %{version}-%{release}
|
||||
Requires: dejavu-sans-fonts
|
||||
@ -161,6 +162,7 @@ plotting tool.
|
||||
%patch4 -p1 -b .isinglethread
|
||||
%patch5 -p1 -b .checkint
|
||||
%patch6 -p1 -b .nolena
|
||||
%patch7 -p1 -b .doc
|
||||
sed -i -e 's:"/usr/lib/X11/app-defaults":"%{x11_app_defaults_dir}":' src/gplt_x11.c
|
||||
iconv -f windows-1252 -t utf-8 ChangeLog > ChangeLog.aux
|
||||
mv ChangeLog.aux ChangeLog
|
||||
@ -174,7 +176,7 @@ chmod 644 demo/html/webify_canvas.pl
|
||||
rm -rf demo/plugin/*.so demo/plugin/*.o
|
||||
|
||||
%global configure_opts --with-readline=builtin --without-linux-vga \\\
|
||||
--enable-history-file
|
||||
--enable-history-file --with-texdir=/usr/share/texlive/texmf-dist/tex/latex/gnuplot
|
||||
|
||||
# at first create minimal version of gnuplot for server SIG purposes
|
||||
mkdir minimal
|
||||
@ -344,9 +346,15 @@ fi
|
||||
|
||||
%files latex
|
||||
%doc ChangeLog Copyright
|
||||
%{_datadir}/texmf/tex/latex/gnuplot/
|
||||
%{_datadir}/texlive/texmf-dist/tex/latex/gnuplot/
|
||||
|
||||
%changelog
|
||||
* Thu Feb 6 2020 Pavel Cahyna <pcahyna@redhat.com> - 5.2.4-1
|
||||
- Rebase to upstream release 5.2.4
|
||||
- Add workaround for broken info generation (upstream bug
|
||||
https://sourceforge.net/p/gnuplot/bugs/1963/) from Debian
|
||||
- Use explicit path for texdir
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gnuplot-5.0.6-clean.tar.gz) = b2f974c02e4120c27e4107ed87720d0f317cb3b888dbc51781afcab18469b19d178ed181fd5fe5ccd55bff025c1747147f804942baafe6f93edc9d8ed32feaa5
|
||||
SHA512 (gnuplot-5.2.4-clean.tar.gz) = 1fbcab4c04f1a8d0632cc3a4bb91144363f50a61ebfe78ddb21f0331a11b7feb3447144f3abfad6ac58df9b4517748faa26840cf6903d023a80d32735ceb1e5b
|
||||
|
Loading…
Reference in New Issue
Block a user