import gnome-terminal-3.40.3-1.el9
This commit is contained in:
parent
0928e873c7
commit
bc3b8fd9df
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/gnome-terminal-3.40.1.tar.xz
|
||||
SOURCES/gnome-terminal-3.40.3.tar.xz
|
||||
|
@ -1 +1 @@
|
||||
0f64a1abe39b5dd42cdefe3e19b6afd818988600 SOURCES/gnome-terminal-3.40.1.tar.xz
|
||||
ea6da6d44534bebce8835e5933b5e28a59147830 SOURCES/gnome-terminal-3.40.3.tar.xz
|
||||
|
@ -1,35 +0,0 @@
|
||||
From 8709588cc5ec11e7b1007e7d67aa4df74faf5c68 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Mon, 23 Feb 2015 18:54:36 +0100
|
||||
Subject: [PATCH] build: Don't treat warnings as errors
|
||||
|
||||
---
|
||||
configure.ac | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f22050d6a2e3..d6d936eb0a96 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -225,12 +225,12 @@ CC_CHECK_FLAGS_APPEND([WARN_CFLAGS],[CFLAGS],[ \
|
||||
-Wall \
|
||||
-Wcast-align \
|
||||
-Wendif-labels \
|
||||
- "-Werror=format=2 -Werror=format-nonliteral -Werror=format-security" \
|
||||
- -Werror=implicit-function-declaration \
|
||||
- -Werror=init-self \
|
||||
- -Werror=missing-include-dirs \
|
||||
- -Werror=missing-prototypes \
|
||||
- -Werror=pointer-arith \
|
||||
+ "-Wformat=2 -Wformat-nonliteral -Wformat-security" \
|
||||
+ -Wimplicit-function-declaration \
|
||||
+ -Winit-self \
|
||||
+ -Wmissing-include-dirs \
|
||||
+ -Wmissing-prototypes \
|
||||
+ -Wpointer-arith \
|
||||
-Wextra \
|
||||
-Wfloat-equal \
|
||||
-Wimplicit \
|
||||
--
|
||||
2.19.1
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,4 +1,4 @@
|
||||
From 70c75d16f4124b9ee8f219b9ce42e25d1a52d81d Mon Sep 17 00:00:00 2001
|
||||
From 49ed8af3bbeb7b72950b7308c72f83a9403dd883 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Mon, 12 May 2014 14:57:18 +0200
|
||||
Subject: [PATCH 01/16] Restore transparency
|
||||
@ -138,10 +138,10 @@ index 4098f90bf10e..35bd24791417 100644
|
||||
|
||||
/* Called once per Preferences window, to destroy stuff that doesn't depend on the profile being edited */
|
||||
diff --git a/src/terminal-schemas.h b/src/terminal-schemas.h
|
||||
index 08b6e85fccac..f79697dd6018 100644
|
||||
index b146ba82eae3..d2917fac37f2 100644
|
||||
--- a/src/terminal-schemas.h
|
||||
+++ b/src/terminal-schemas.h
|
||||
@@ -76,6 +76,9 @@ G_BEGIN_DECLS
|
||||
@@ -78,6 +78,9 @@ G_BEGIN_DECLS
|
||||
#define TERMINAL_PROFILE_VISIBLE_NAME_KEY "visible-name"
|
||||
#define TERMINAL_PROFILE_WORD_CHAR_EXCEPTIONS_KEY "word-char-exceptions"
|
||||
|
||||
@ -231,10 +231,10 @@ index 537cd2e1d8b1..d87bbb6f24ec 100644
|
||||
uuid_unparse (u, uuidstr);
|
||||
priv->uuid = g_strdup (uuidstr);
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From b25b0df8b4a9f1e5c9d071ca747bce01cb3f6466 Mon Sep 17 00:00:00 2001
|
||||
From 10b806c480110bb8dae3bdae87f4c7f366e632cc Mon Sep 17 00:00:00 2001
|
||||
From: Lars Uebernickel <lars.uebernickel@canonical.com>
|
||||
Date: Wed, 28 May 2014 14:11:02 +0200
|
||||
Subject: [PATCH 02/16] window: Make the drawing robust across all themes
|
||||
@ -293,10 +293,10 @@ index d87bbb6f24ec..c79e06387c94 100644
|
||||
widget_class->screen_changed = terminal_window_screen_changed;
|
||||
widget_class->style_updated = terminal_window_style_updated;
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From 723cff566e0f1f7a31b020b2aba39066f4cc070b Mon Sep 17 00:00:00 2001
|
||||
From 31af2e59bb75553c24ee53deeccb22aab1438ade Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Fri, 13 Nov 2015 15:16:42 +0100
|
||||
Subject: [PATCH 03/16] screen, window: Extra padding around transparent
|
||||
@ -428,10 +428,10 @@ index c79e06387c94..6d1fa95d8b3a 100644
|
||||
|
||||
return GTK_WIDGET_CLASS (terminal_window_parent_class)->draw (widget, cr);
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From e4ae7323aa2c8cf91790b6e23ed44209f9ef8888 Mon Sep 17 00:00:00 2001
|
||||
From efb58ed854892d81da00363a32a84c37fc9702d9 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Fri, 18 May 2018 20:15:34 +0200
|
||||
Subject: [PATCH 04/16] screen: Try harder to find a foreground process group
|
||||
@ -498,10 +498,10 @@ index 2ed7fdea8349..9b88cd986909 100644
|
||||
#endif
|
||||
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From d5f4d6925e69a6e9f608615bef38f92c1ef71ac6 Mon Sep 17 00:00:00 2001
|
||||
From 31c500155edbc893e79df97fbd5b291af2ed4f91 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Thu, 3 May 2018 16:49:28 +0200
|
||||
Subject: [PATCH 05/16] screen: Track the current foreground process
|
||||
@ -751,10 +751,10 @@ index 9b88cd986909..c66938271860 100644
|
||||
return FALSE;
|
||||
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From 3348b25d12ea2fc72843ba7326b6fa266031b69e Mon Sep 17 00:00:00 2001
|
||||
From 800ac8908d3675b2e885edf2e972c0fa42d7ea51 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Thu, 10 May 2018 19:23:16 +0200
|
||||
Subject: [PATCH 06/16] Notify when a long-running foreground process group
|
||||
@ -775,10 +775,10 @@ https://bugzilla.gnome.org/show_bug.cgi?id=711059
|
||||
4 files changed, 174 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/terminal-app.c b/src/terminal-app.c
|
||||
index ff91e1561f39..a86688d34c33 100644
|
||||
index cf790fb44fc8..499011a8165a 100644
|
||||
--- a/src/terminal-app.c
|
||||
+++ b/src/terminal-app.c
|
||||
@@ -730,6 +730,31 @@ app_menu_quit_cb (GSimpleAction *action,
|
||||
@@ -739,6 +739,31 @@ app_menu_quit_cb (GSimpleAction *action,
|
||||
gtk_widget_destroy (GTK_WIDGET (window));
|
||||
}
|
||||
|
||||
@ -810,7 +810,7 @@ index ff91e1561f39..a86688d34c33 100644
|
||||
/* Class implementation */
|
||||
|
||||
G_DEFINE_TYPE (TerminalApp, terminal_app, GTK_TYPE_APPLICATION)
|
||||
@@ -753,6 +778,10 @@ terminal_app_startup (GApplication *application)
|
||||
@@ -762,6 +787,10 @@ terminal_app_startup (GApplication *application)
|
||||
{ "quit", app_menu_quit_cb, NULL, NULL, NULL }
|
||||
};
|
||||
|
||||
@ -821,7 +821,7 @@ index ff91e1561f39..a86688d34c33 100644
|
||||
g_application_set_resource_base_path (application, TERMINAL_RESOURCES_PATH_PREFIX);
|
||||
|
||||
G_APPLICATION_CLASS (terminal_app_parent_class)->startup (application);
|
||||
@@ -763,6 +792,9 @@ terminal_app_startup (GApplication *application)
|
||||
@@ -772,6 +801,9 @@ terminal_app_startup (GApplication *application)
|
||||
g_action_map_add_action_entries (G_ACTION_MAP (application),
|
||||
action_entries, G_N_ELEMENTS (action_entries),
|
||||
application);
|
||||
@ -1071,10 +1071,10 @@ index 20cfbceb36b0..a987025e0524 100644
|
||||
|
||||
G_END_DECLS
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From a4595840170ac9457717989da7b07dee653740e0 Mon Sep 17 00:00:00 2001
|
||||
From 91d3a2c296febe824b4143f878965a0f9397238f Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Tue, 10 Apr 2018 15:39:35 +0200
|
||||
Subject: [PATCH 07/16] profile: Split the Command tab into two nested GtkGrids
|
||||
@ -1346,10 +1346,10 @@ index 64f8295bf2b0..426993a4e154 100644
|
||||
</object>
|
||||
<packing>
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From 0c4d86519524ddf002999c6f3b214c2b41bb3678 Mon Sep 17 00:00:00 2001
|
||||
From 81dc06bd563af0b3391a71e70b4604a11461caa5 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Tue, 10 Apr 2018 16:01:51 +0200
|
||||
Subject: [PATCH 08/16] Revert "profile: Remove the "Command" sub-heading"
|
||||
@ -1639,10 +1639,10 @@ index 426993a4e154..7f4a94c88b6b 100644
|
||||
</object>
|
||||
<packing>
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From 47807c171a1df778f0d7a3a9e23ff174c3e80f2e Mon Sep 17 00:00:00 2001
|
||||
From ee98a681f6a6281672ba02e90efb472ff6d273a4 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Thu, 30 Jun 2016 16:02:13 +0200
|
||||
Subject: [PATCH 09/16] Revert "screen: Remove unused description and
|
||||
@ -1818,10 +1818,10 @@ index df59b1a58273..9a9a562a9d84 100644
|
||||
char *terminal_screen_get_current_dir (TerminalScreen *screen);
|
||||
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From 60da29daf408667dcbbdf51f4830c0eed8c1495b Mon Sep 17 00:00:00 2001
|
||||
From 3596c195e594caff9370392a181e001ab1106be2 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Thu, 30 Jun 2016 17:39:48 +0200
|
||||
Subject: [PATCH 10/16] Revert "Remove the static title setting from profile
|
||||
@ -1953,10 +1953,10 @@ index 35bd24791417..df1f219608c4 100644
|
||||
gtk_builder_get_object (builder,
|
||||
"use-custom-command-checkbutton"),
|
||||
diff --git a/src/terminal-schemas.h b/src/terminal-schemas.h
|
||||
index f79697dd6018..e37fad2992ea 100644
|
||||
index d2917fac37f2..16e5c3264725 100644
|
||||
--- a/src/terminal-schemas.h
|
||||
+++ b/src/terminal-schemas.h
|
||||
@@ -69,6 +69,7 @@ G_BEGIN_DECLS
|
||||
@@ -71,6 +71,7 @@ G_BEGIN_DECLS
|
||||
#define TERMINAL_PROFILE_SCROLL_ON_KEYSTROKE_KEY "scroll-on-keystroke"
|
||||
#define TERMINAL_PROFILE_SCROLL_ON_OUTPUT_KEY "scroll-on-output"
|
||||
#define TERMINAL_PROFILE_TEXT_BLINK_MODE_KEY "text-blink-mode"
|
||||
@ -1997,10 +1997,10 @@ index 7f237b3b46b7..a3386dac16b5 100644
|
||||
(!prop_name ||
|
||||
prop_name == I_(TERMINAL_PROFILE_USE_SYSTEM_FONT_KEY) ||
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From 842429b887b6b14b878e7e4a2fd00475962c5714 Mon Sep 17 00:00:00 2001
|
||||
From ffd0ffa95467e538413f0410597174e3c0233692 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Tue, 17 Feb 2015 17:06:17 +0100
|
||||
Subject: [PATCH 11/16] Restore translations for setting a title and
|
||||
@ -3741,10 +3741,10 @@ index 5aa43b113ed9..f892290c256f 100644
|
||||
#: ../src/profile-preferences.glade.h:74
|
||||
msgid "_Update login records when command is launched"
|
||||
diff --git a/po/oc.po b/po/oc.po
|
||||
index 9a6f6186019a..6e51ea2f8980 100644
|
||||
index 169828e2828f..b4bdec693f2f 100644
|
||||
--- a/po/oc.po
|
||||
+++ b/po/oc.po
|
||||
@@ -2944,8 +2944,8 @@ msgstr "Tampar _la fenèstra"
|
||||
@@ -3010,8 +3010,8 @@ msgstr "Tampar _la fenèstra"
|
||||
#~ msgid "Save as..."
|
||||
#~ msgstr "Enregistrar jos..."
|
||||
|
||||
@ -3755,7 +3755,7 @@ index 9a6f6186019a..6e51ea2f8980 100644
|
||||
|
||||
#~ msgid "_Detach tab"
|
||||
#~ msgstr "Des_tacar l'onglet"
|
||||
@@ -3405,8 +3405,8 @@ msgstr "Tampar _la fenèstra"
|
||||
@@ -3471,8 +3471,8 @@ msgstr "Tampar _la fenèstra"
|
||||
#~ msgid "_Use the system fixed width font"
|
||||
#~ msgstr "_Utilizar la poliça de chassa fixa del sistèma"
|
||||
|
||||
@ -3766,7 +3766,7 @@ index 9a6f6186019a..6e51ea2f8980 100644
|
||||
|
||||
#~ msgid "The shortcut key “%s” is already bound to the “%s” action"
|
||||
#~ msgstr "L'acorchi de clavièr « %s » es ja atribuit a l'accion « %s »"
|
||||
@@ -3723,8 +3723,8 @@ msgstr "Tampar _la fenèstra"
|
||||
@@ -3789,8 +3789,8 @@ msgstr "Tampar _la fenèstra"
|
||||
#~ msgid "Run;"
|
||||
#~ msgstr "Executar;Consòla;Shell;"
|
||||
|
||||
@ -4038,10 +4038,10 @@ index adca7d5acba9..6379cee7f0a3 100644
|
||||
#: ../src/gnome-terminal.glade2.h:87
|
||||
msgid "_Update login records when command is launched"
|
||||
diff --git a/po/sk.po b/po/sk.po
|
||||
index 765dcf2a034d..96bff962d86e 100644
|
||||
index e6745075ee55..20d303c8a302 100644
|
||||
--- a/po/sk.po
|
||||
+++ b/po/sk.po
|
||||
@@ -3076,3 +3076,15 @@ msgstr "_Zavrieť okno"
|
||||
@@ -3086,3 +3086,15 @@ msgstr "_Zavrieť okno"
|
||||
#~ "\n"
|
||||
#~ "Viac informácii o jednotlivých príkazoch získate pomocou „%s PRÍKAZ --"
|
||||
#~ "help“.\n"
|
||||
@ -4740,10 +4740,10 @@ index 80cb23434a60..20e2a93ce3f0 100644
|
||||
+msgid "Transparent background"
|
||||
+msgstr "透明背景"
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From 3c1f5551e5db30e1194b8d50e224c2d7aef9b54a Mon Sep 17 00:00:00 2001
|
||||
From 5d71d4d1728cc106230b28f208d95450c49db59a Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Wed, 25 May 2016 13:47:36 +0200
|
||||
Subject: [PATCH 12/16] Restore the action and shortcut to set a static title
|
||||
@ -4888,10 +4888,10 @@ index 6d1fa95d8b3a..69596045d43e 100644
|
||||
{ "tab-detach", action_tab_detach_cb, NULL, NULL, NULL },
|
||||
{ "tab-move-left", action_tab_move_left_cb, NULL, NULL, NULL },
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From fec24458f5a978034b95c063e59a3a3e5a2376af Mon Sep 17 00:00:00 2001
|
||||
From 8df8cab8326904951559876d7600ce8135ca8d88 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Thu, 30 Jun 2016 18:14:36 +0200
|
||||
Subject: [PATCH 13/16] screen: Style fix
|
||||
@ -4918,10 +4918,10 @@ index a3386dac16b5..19c265839dc7 100644
|
||||
const char *p;
|
||||
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From 781dec0d0beeda7a313bfd46d0e2ac7704011049 Mon Sep 17 00:00:00 2001
|
||||
From 023fe19f34ddd3b5efab064015d707dd005e34dc Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Thu, 30 Jun 2016 16:58:15 +0200
|
||||
Subject: [PATCH 14/16] Restore the rest of the title handling options and make
|
||||
@ -5063,10 +5063,10 @@ index 93f1460c2207..5e816f71c10e 100644
|
||||
{
|
||||
TERMINAL_EXIT_CLOSE,
|
||||
diff --git a/src/terminal-schemas.h b/src/terminal-schemas.h
|
||||
index e37fad2992ea..c416eb5a2090 100644
|
||||
index 16e5c3264725..bb3048fafe48 100644
|
||||
--- a/src/terminal-schemas.h
|
||||
+++ b/src/terminal-schemas.h
|
||||
@@ -69,6 +69,7 @@ G_BEGIN_DECLS
|
||||
@@ -71,6 +71,7 @@ G_BEGIN_DECLS
|
||||
#define TERMINAL_PROFILE_SCROLL_ON_KEYSTROKE_KEY "scroll-on-keystroke"
|
||||
#define TERMINAL_PROFILE_SCROLL_ON_OUTPUT_KEY "scroll-on-output"
|
||||
#define TERMINAL_PROFILE_TEXT_BLINK_MODE_KEY "text-blink-mode"
|
||||
@ -5535,10 +5535,10 @@ index 69596045d43e..b8ab17eac3c5 100644
|
||||
|
||||
static void
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From 67eddc128168422b34cc30ca77d2b10755110ffd Mon Sep 17 00:00:00 2001
|
||||
From 749289f4bf0359dd67519d82cf66a33fff4548e3 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Wed, 3 Apr 2019 15:38:09 +0200
|
||||
Subject: [PATCH 15/16] Update the title with the current foreground process
|
||||
@ -5571,10 +5571,10 @@ index d67da299d14a..0939471736a3 100644
|
||||
<default>'close'</default>
|
||||
<summary>What to do with the terminal when the child command exits</summary>
|
||||
diff --git a/src/terminal-schemas.h b/src/terminal-schemas.h
|
||||
index c416eb5a2090..70acf3c9e6b9 100644
|
||||
index bb3048fafe48..d5ee2a88b22f 100644
|
||||
--- a/src/terminal-schemas.h
|
||||
+++ b/src/terminal-schemas.h
|
||||
@@ -68,6 +68,7 @@ G_BEGIN_DECLS
|
||||
@@ -70,6 +70,7 @@ G_BEGIN_DECLS
|
||||
#define TERMINAL_PROFILE_SCROLLBAR_POLICY_KEY "scrollbar-policy"
|
||||
#define TERMINAL_PROFILE_SCROLL_ON_KEYSTROKE_KEY "scroll-on-keystroke"
|
||||
#define TERMINAL_PROFILE_SCROLL_ON_OUTPUT_KEY "scroll-on-output"
|
||||
@ -5710,10 +5710,10 @@ index c715e592a19a..8566312b879e 100644
|
||||
retval = G_SOURCE_REMOVE;
|
||||
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
||||
From 209c613cbd506c517a089f946fa4122212ba2f94 Mon Sep 17 00:00:00 2001
|
||||
From 823ee952840f976a3bda0a26cb4095c81e5c2dcb Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Thu, 27 Feb 2020 19:32:08 +0100
|
||||
Subject: [PATCH 16/16] screen, window: Preserve current toolbox, if any
|
||||
@ -5723,13 +5723,13 @@ advertises the name of the current toolbox container.
|
||||
|
||||
https://gitlab.freedesktop.org/terminal-wg/specifications/issues/17
|
||||
---
|
||||
src/terminal-screen.c | 30 +++++++++++++++++++++++++++++-
|
||||
src/terminal-screen.c | 33 ++++++++++++++++++++++++++++++++-
|
||||
src/terminal-screen.h | 6 ++++++
|
||||
src/terminal-window.c | 26 ++++++++++++++++++++++++--
|
||||
3 files changed, 59 insertions(+), 3 deletions(-)
|
||||
3 files changed, 62 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/terminal-screen.c b/src/terminal-screen.c
|
||||
index 8566312b879e..01350db0fb28 100644
|
||||
index 8566312b879e..c37dbdcd02be 100644
|
||||
--- a/src/terminal-screen.c
|
||||
+++ b/src/terminal-screen.c
|
||||
@@ -879,6 +879,25 @@ terminal_screen_reexec_from_screen (TerminalScreen *screen,
|
||||
@ -5758,12 +5758,15 @@ index 8566312b879e..01350db0fb28 100644
|
||||
{
|
||||
g_return_val_if_fail (TERMINAL_IS_SCREEN (screen), FALSE);
|
||||
|
||||
@@ -890,8 +909,17 @@ terminal_screen_reexec_from_screen (TerminalScreen *screen,
|
||||
@@ -890,8 +909,20 @@ terminal_screen_reexec_from_screen (TerminalScreen *screen,
|
||||
terminal_unref_exec_data ExecData* data = exec_data_clone (parent_screen->priv->exec_data, FALSE);
|
||||
gs_free char* cwd = terminal_screen_get_current_dir (parent_screen);
|
||||
|
||||
+ if (override_command != NULL)
|
||||
+ {
|
||||
+ g_return_val_if_fail (parent_screen->priv->exec_data != NULL, FALSE);
|
||||
+ g_return_val_if_fail (data != NULL, FALSE);
|
||||
+
|
||||
+ g_strfreev (data->argv);
|
||||
+ data->argv = g_strdupv (override_command);
|
||||
+
|
||||
@ -5832,5 +5835,5 @@ index b8ab17eac3c5..ba23e7c99d3d 100644
|
||||
if (mode == TERMINAL_NEW_TERMINAL_MODE_WINDOW)
|
||||
gtk_window_present (GTK_WINDOW (window));
|
||||
--
|
||||
2.30.2
|
||||
2.31.1
|
||||
|
||||
|
@ -6,40 +6,36 @@
|
||||
%define vte_version 0.64.0
|
||||
%define desktop_file_utils_version 0.2.90
|
||||
|
||||
Name: gnome-terminal
|
||||
Version: 3.40.1
|
||||
Release: 2%{?dist}
|
||||
Name: gnome-terminal
|
||||
Version: 3.40.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Terminal emulator for GNOME
|
||||
|
||||
License: GPLv3+ and GFDL and LGPLv2+
|
||||
URL: http://www.gnome.org/
|
||||
Source0: http://download.gnome.org/sources/gnome-terminal/3.40/gnome-terminal-%{version}.tar.xz
|
||||
URL: https://wiki.gnome.org/Apps/Terminal
|
||||
Source0: https://download.gnome.org/sources/%{name}/3.40/%{name}-%{version}.tar.xz
|
||||
Source1: org.gnome.Terminal.gschema.override
|
||||
|
||||
Patch0: gnome-terminal-backports-from-upstream.patch
|
||||
|
||||
Patch100: gnome-terminal-cntr-ntfy-autottl-ts.patch
|
||||
Patch101: 0001-build-Don-t-treat-warnings-as-errors.patch
|
||||
|
||||
BuildRequires: docbook-style-xsl
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: gtk3-devel >= %{gtk3_version}
|
||||
BuildRequires: gsettings-desktop-schemas-devel
|
||||
BuildRequires: vte291-devel >= %{vte_version}
|
||||
BuildRequires: pkgconfig(dconf)
|
||||
BuildRequires: pkgconfig(glib-2.0) >= %{glib2_version}
|
||||
BuildRequires: pkgconfig(gsettings-desktop-schemas)
|
||||
BuildRequires: pkgconfig(gtk+-3.0) >= %{gtk3_version}
|
||||
BuildRequires: pkgconfig(libnautilus-extension)
|
||||
BuildRequires: pkgconfig(libpcre2-8)
|
||||
BuildRequires: pkgconfig(uuid)
|
||||
BuildRequires: pkgconfig(vte-2.91) >= %{vte_version}
|
||||
BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
|
||||
BuildRequires: docbook-style-xsl
|
||||
BuildRequires: gettext-devel >= %{gettext_version}
|
||||
BuildRequires: autoconf automake libtool
|
||||
BuildRequires: itstool
|
||||
BuildRequires: dconf-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libxslt
|
||||
BuildRequires: nautilus-devel
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gnome-shell
|
||||
BuildRequires: pcre2-devel
|
||||
BuildRequires: systemd
|
||||
BuildRequires: vala-devel
|
||||
BuildRequires: yelp-tools
|
||||
BuildRequires: itstool
|
||||
BuildRequires: libxslt
|
||||
BuildRequires: make
|
||||
BuildRequires: systemd-rpm-macros
|
||||
BuildRequires: yelp-tools
|
||||
|
||||
Requires: dbus
|
||||
Requires: glib2%{?_isa} >= %{glib2_version}
|
||||
@ -63,13 +59,9 @@ This package provides a Nautilus extension that adds the 'Open in Terminal'
|
||||
option to the right-click context menu in Nautilus.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .backports
|
||||
%patch100 -p1 -b .cntr-ntfy-autottl-ts
|
||||
%patch101 -p1 -b .warnings
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
autoreconf -f -i
|
||||
%configure \
|
||||
--disable-silent-rules \
|
||||
--disable-static \
|
||||
@ -82,14 +74,14 @@ autoreconf -f -i
|
||||
%install
|
||||
%make_install
|
||||
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0/*.la
|
||||
rm -f %{buildroot}%{_libdir}/nautilus/extensions-3.0/*.la
|
||||
|
||||
cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/glib-2.0/schemas
|
||||
install -p -m 644 %{SOURCE1} %{buildroot}%{_datadir}/glib-2.0/schemas
|
||||
|
||||
%find_lang %{gettext_package} --with-gnome
|
||||
|
||||
%check
|
||||
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/org.gnome.Terminal.desktop
|
||||
desktop-file-validate %{buildroot}%{_datadir}/applications/org.gnome.Terminal.desktop
|
||||
make check
|
||||
|
||||
%files -f %{gettext_package}.lang
|
||||
@ -107,13 +99,21 @@ make check
|
||||
%{_datadir}/icons/hicolor/scalable/apps/org.gnome.Terminal.svg
|
||||
%{_datadir}/icons/hicolor/symbolic/apps/org.gnome.Terminal-symbolic.svg
|
||||
%{_datadir}/man/man1/gnome-terminal.1*
|
||||
|
||||
%dir %{_libdir}/gnome-terminal
|
||||
%{_libdir}/gnome-terminal/gschemas.compiled
|
||||
|
||||
%{_userunitdir}/gnome-terminal-server.service
|
||||
|
||||
%files nautilus
|
||||
%{_libdir}/nautilus/extensions-3.0/libterminal-nautilus.so
|
||||
%{_datadir}/metainfo/org.gnome.Terminal.Nautilus.metainfo.xml
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Sep 16 2021 David King <amigadave@amigadave.com> - 3.40.3-1
|
||||
- Update to 3.40.3 (#1998957)
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 3.40.1-2
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
Loading…
Reference in New Issue
Block a user