Update to 3.2.0

This commit is contained in:
Mohamed El Morabity 2011-10-04 00:22:47 +02:00
parent 041221a4b5
commit 30cdc2884b
4 changed files with 14 additions and 48 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/gnome-shell-extensions-3.1.91.tar.xz
/gnome-shell-extensions-e102c0c6.tar.xz
/gnome-shell-extensions-3.2.0.tar.xz

View File

@ -1,21 +0,0 @@
diff -up gnome-shell-extensions/extensions/workspace-indicator/extension.js.orig gnome-shell-extensions/extensions/workspace-indicator/extension.js
--- gnome-shell-extensions/extensions/workspace-indicator/extension.js.orig 2011-10-02 15:12:36.925984895 +0200
+++ gnome-shell-extensions/extensions/workspace-indicator/extension.js 2011-10-02 16:50:04.212312784 +0200
@@ -21,7 +21,7 @@ WorkspaceIndicator.prototype = {
this._currentWorkspace = global.screen.get_active_workspace().index();
this.statusLabel = new St.Label({ text: this._labelText() });
- this.actor.set_child(this.statusLabel);
+ this.actor.add_actor(this.statusLabel);
this.workspacesItems = [];
this._workspaceSection = new PopupMenu.PopupMenuSection();
@@ -94,7 +94,7 @@ WorkspaceIndicator.prototype = {
}
function init(meta) {
- Panel.STANDARD_TRAY_ICON_ORDER.unshift('workspace-indicator');
+ Panel.STANDARD_STATUS_AREA_ORDER.unshift('workspace-indicator');
}
let _indicator;

View File

@ -1,33 +1,20 @@
%global commit e102c0c6
%global checkout 20111001git%{commit}
%global pkg_prefix gnome-shell-extension
Name: gnome-shell-extensions
Version: 3.1.91
Release: 3.%{checkout}%{?dist}
# Release: 3%{?dist}
Version: 3.2.0
Release: 1%{?dist}
Summary: Modify and extend GNOME Shell functionality and behavior
Group: User Interface/Desktops
License: GPLv2+
URL: http://live.gnome.org/GnomeShell/Extensions
# Using git archive since upstream hasn't created tarballs. Picking up a
# snapshot from master for a couple of minor but relevant changes
# git clone git://git.gnome.org/gnome-shell-extensions.git
# (cd gnome-shell-extensions && git archive --format=tar \
# --prefix=gnome-shell-extensions/ git_commithash | xz > \
# gnome-shell-extensions-<git_commithash_abbr>.tar.xz )
Source0: gnome-shell-extensions-%{commit}.tar.xz
# Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-shell-extensions/3.2/%{name}-%{version}.tar.xz
# Fix workspace indicator extension with GNOME Shell 3.2
Patch0: %{name}-3.1.91-workspace_indicator.patch
Source0: http://ftp.gnome.org/pub/GNOME/sources/gnome-shell-extensions/3.2/%{name}-%{version}.tar.xz
# Since we build from a git checkout
BuildRequires: gnome-common
BuildRequires: intltool
BuildRequires: glib2-devel
BuildRequires: intltool
BuildRequires: pkgconfig(gnome-desktop-3.0)
BuildRequires: pkgconfig(libgtop-2.0)
Requires: gnome-shell >= 3.2
Requires: gnome-shell >= 3.2.0
BuildArch: noarch
%description
@ -57,7 +44,7 @@ Enabled extensions:
Summary: Files common to GNOME Shell Extensions
Group: User Interface/Desktops
License: GPLv2+
Requires: gnome-shell >= 3.2
Requires: gnome-shell >= 3.2.0
Provides: %{name}-common = %{version}-%{release}
Obsoletes: %{name}-common < %{version}-%{release}
@ -247,11 +234,7 @@ This extension adds a systems status menu for rotating monitors
%prep
%setup -q -n %{name}
%patch0 -p1 -b .workspace_indicator
# make g-s-e work with g-s 3.2
sed -i "s|3.1.91|3.2|g" configure.ac
%setup -q
%build
@ -271,7 +254,7 @@ make install DESTDIR=$RPM_BUILD_ROOT
%files -n %{pkg_prefix}-common -f %{name}.lang
%defattr(-,root,root,-)
%doc COPYING HACKING NEWS README
%doc COPYING NEWS README
%dir %{_datadir}/gnome-shell/extensions/
@ -387,6 +370,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
%changelog
* Mon Oct 03 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 3.2.0-1
- Update to 3.2.0
* Mon Sep 26 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 3.1.91-3.20111001gite102c0c6
- Update to a newer git snapshot
- Fix GNOME Shell version to work with GS 3.2.0

View File

@ -1 +1 @@
49da893294ae10d91b5d661f9374484a gnome-shell-extensions-e102c0c6.tar.xz
f67a451349d8b052e3801af6280f89e4 gnome-shell-extensions-3.2.0.tar.xz