Fix extensions to work with GNOME 3.2
This commit is contained in:
parent
ce24ead4a3
commit
041221a4b5
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/gnome-shell-extensions-3.1.91.tar.xz
|
||||
/gnome-shell-extensions-e102c0c6.tar.xz
|
||||
|
21
gnome-shell-extensions-3.1.91-workspace_indicator.patch
Normal file
21
gnome-shell-extensions-3.1.91-workspace_indicator.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up gnome-shell-extensions/extensions/workspace-indicator/extension.js.orig gnome-shell-extensions/extensions/workspace-indicator/extension.js
|
||||
--- gnome-shell-extensions/extensions/workspace-indicator/extension.js.orig 2011-10-02 15:12:36.925984895 +0200
|
||||
+++ gnome-shell-extensions/extensions/workspace-indicator/extension.js 2011-10-02 16:50:04.212312784 +0200
|
||||
@@ -21,7 +21,7 @@ WorkspaceIndicator.prototype = {
|
||||
|
||||
this._currentWorkspace = global.screen.get_active_workspace().index();
|
||||
this.statusLabel = new St.Label({ text: this._labelText() });
|
||||
- this.actor.set_child(this.statusLabel);
|
||||
+ this.actor.add_actor(this.statusLabel);
|
||||
|
||||
this.workspacesItems = [];
|
||||
this._workspaceSection = new PopupMenu.PopupMenuSection();
|
||||
@@ -94,7 +94,7 @@ WorkspaceIndicator.prototype = {
|
||||
}
|
||||
|
||||
function init(meta) {
|
||||
- Panel.STANDARD_TRAY_ICON_ORDER.unshift('workspace-indicator');
|
||||
+ Panel.STANDARD_STATUS_AREA_ORDER.unshift('workspace-indicator');
|
||||
}
|
||||
|
||||
let _indicator;
|
@ -1,23 +1,25 @@
|
||||
#global commit 6b5e3a3e
|
||||
#global checkout 20110830git%{commit}
|
||||
%global commit e102c0c6
|
||||
%global checkout 20111001git%{commit}
|
||||
%global pkg_prefix gnome-shell-extension
|
||||
|
||||
Name: gnome-shell-extensions
|
||||
Version: 3.1.91
|
||||
#Release: 3.%{checkout}%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Release: 3.%{checkout}%{?dist}
|
||||
# Release: 3%{?dist}
|
||||
Summary: Modify and extend GNOME Shell functionality and behavior
|
||||
Group: User Interface/Desktops
|
||||
License: GPLv2+
|
||||
URL: http://live.gnome.org/GnomeShell/Extensions
|
||||
|
||||
# Using git archive since upstream hasn't released 3.1.91 yet.
|
||||
# Using git archive since upstream hasn't created tarballs. Picking up a
|
||||
# snapshot from master for a couple of minor but relevant changes
|
||||
# git clone git://git.gnome.org/gnome-shell-extensions.git
|
||||
# (cd gnome-shell-extensions && git archive --format=tar \
|
||||
# --prefix=%{name}-%{version}/ %{version} \
|
||||
# | xz ) > %{name}-%{version}.tar.xz
|
||||
Source0: %{name}-%{version}.tar.xz
|
||||
#Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-shell-extensions/3.1/%{name}-%{version}.tar.xz
|
||||
# --prefix=gnome-shell-extensions/ git_commithash | xz > \
|
||||
# gnome-shell-extensions-<git_commithash_abbr>.tar.xz )
|
||||
Source0: gnome-shell-extensions-%{commit}.tar.xz
|
||||
# Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-shell-extensions/3.2/%{name}-%{version}.tar.xz
|
||||
# Fix workspace indicator extension with GNOME Shell 3.2
|
||||
Patch0: %{name}-3.1.91-workspace_indicator.patch
|
||||
|
||||
# Since we build from a git checkout
|
||||
BuildRequires: gnome-common
|
||||
@ -25,7 +27,7 @@ BuildRequires: intltool
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: pkgconfig(gnome-desktop-3.0)
|
||||
BuildRequires: pkgconfig(libgtop-2.0)
|
||||
Requires: gnome-shell >= 3.1.91
|
||||
Requires: gnome-shell >= 3.2
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
@ -55,6 +57,7 @@ Enabled extensions:
|
||||
Summary: Files common to GNOME Shell Extensions
|
||||
Group: User Interface/Desktops
|
||||
License: GPLv2+
|
||||
Requires: gnome-shell >= 3.2
|
||||
Provides: %{name}-common = %{version}-%{release}
|
||||
Obsoletes: %{name}-common < %{version}-%{release}
|
||||
|
||||
@ -244,9 +247,11 @@ This extension adds a systems status menu for rotating monitors
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
# make g-s-e work with g-s 3.1.90
|
||||
# sed -i "s|3.1.4|3.1.90|g" configure.ac
|
||||
%setup -q -n %{name}
|
||||
%patch0 -p1 -b .workspace_indicator
|
||||
|
||||
# make g-s-e work with g-s 3.2
|
||||
sed -i "s|3.1.91|3.2|g" configure.ac
|
||||
|
||||
|
||||
%build
|
||||
@ -382,6 +387,11 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Sep 26 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 3.1.91-3.20111001gite102c0c6
|
||||
- Update to a newer git snapshot
|
||||
- Fix GNOME Shell version to work with GS 3.2.0
|
||||
- Add Requires on GS 3.2.0 or above to gnome-shell-common
|
||||
|
||||
* Wed Sep 14 2011 Mohamed El Morabity <melmorabity@fedorapeople.org> - 3.1.91-2
|
||||
- Enable xrandr-indicator and workspace-indicator extensions
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user