gnome-settings-daemon/libcommon-static-library.patch
Kalev Lember d070bdaf18 Fix missing libcommon.so library
Turn libcommon into a static library, similar to how it was with the
autotools build.

This makes gnome-settings-daemon installable again, and makes it
possible for other programs that BR gnome-settings-daemon-devel to
build again.
2018-02-07 08:00:51 +01:00

14 lines
381 B
Diff

diff --git a/plugins/common/meson.build b/plugins/common/meson.build
index ec54cc1a3d65..f62d5a94a028 100644
--- a/plugins/common/meson.build
+++ b/plugins/common/meson.build
@@ -52,7 +52,7 @@ if enable_wacom
deps += libwacom_dep
endif
-libcommon = shared_module(
+libcommon = static_library(
plugin_name,
sources: sources,
include_directories: [top_inc, data_inc],