gnome-settings-daemon/fallback-mounter.patch
2011-07-26 17:08:12 +02:00

29 lines
915 B
Diff

diff --git a/plugins/automount/Makefile.am b/plugins/automount/Makefile.am
index 209feb1..ace425a 100644
--- a/plugins/automount/Makefile.am
+++ b/plugins/automount/Makefile.am
@@ -17,7 +17,8 @@ gnome_fallback_mount_helper_CFLAGS = \
gnome_fallback_mount_helper_LDADD = \
$(SETTINGS_PLUGIN_LIBS) \
- $(X11_LIBS)
+ $(X11_LIBS) \
+ $(top_builddir)/gnome-settings-daemon/libgsd-profile.la
autostartdir = $(sysconfdir)/xdg/autostart
autostart_in_files = gnome-fallback-mount-helper.desktop.in
diff --git a/plugins/automount/gnome-fallback-mount-helper.c b/plugins/automount/gnome-fallback-mount-helper.c
index ff5d192..9f7a1fa 100644
--- a/plugins/automount/gnome-fallback-mount-helper.c
+++ b/plugins/automount/gnome-fallback-mount-helper.c
@@ -22,7 +22,9 @@
#include "config.h"
#include <glib.h>
+#include <glib/gi18n.h>
#include <unistd.h>
+#include <gtk/gtk.h>
#include "gsd-automount-manager.h"