fix smartcard stuff

This commit is contained in:
Matthias Clasen 2010-05-27 23:31:48 +00:00
parent d129002054
commit be971aa368
2 changed files with 16 additions and 0 deletions

View File

@ -39,6 +39,8 @@ Patch3: slight-hinting.patch
# https://bugzilla.gnome.org/show_bug.cgi?id=610319
Patch4: keyboard-icon.patch
Patch5: not-smart.patch
%description
A daemon to share settings from GNOME to other applications. It also
handles global keybindings, as well as a number of desktop-wide settings.
@ -58,6 +60,7 @@ developing applications that use %{name}.
%setup -q
%patch3 -p1 -b .slight-hinting
%patch4 -p1 -b .keyboard-icon
%patch5 -p1 -b .not-smart
autoreconf -i -f

13
not-smart.patch Normal file
View File

@ -0,0 +1,13 @@
diff -up gnome-settings-daemon-2.31.2/plugins/smartcard/Makefile.am.not-smart gnome-settings-daemon-2.31.2/plugins/smartcard/Makefile.am
--- gnome-settings-daemon-2.31.2/plugins/smartcard/Makefile.am.not-smart 2010-05-06 07:19:56.000000000 -0400
+++ gnome-settings-daemon-2.31.2/plugins/smartcard/Makefile.am 2010-05-27 19:27:18.619425527 -0400
@@ -37,7 +37,9 @@ endif
plugin_in_files = \
smartcard.gnome-settings-plugin.in
+if SMARTCARD_SUPPORT
plugin_DATA = $(plugin_in_files:.gnome-settings-plugin.in=.gnome-settings-plugin)
+endif
EXTRA_DIST = \
$(plugin_in_files)