- Add (now upstreamed) patch to legacy ESD preference; see
http://bugzilla.gnome.org/show_bug.cgi?id=533198 https://bugzilla.redhat.com/show_bug.cgi?id=430624
This commit is contained in:
parent
d50b9cc718
commit
5f4a086815
51
gnome-settings-daemon-legacy-sound.patch
Normal file
51
gnome-settings-daemon-legacy-sound.patch
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
Index: plugins/sound/gsd-sound-manager.c
|
||||||
|
===================================================================
|
||||||
|
--- plugins/sound/gsd-sound-manager.c (revision 340)
|
||||||
|
+++ plugins/sound/gsd-sound-manager.c (working copy)
|
||||||
|
@@ -296,7 +296,18 @@
|
||||||
|
|
||||||
|
client = gconf_client_get_default ();
|
||||||
|
|
||||||
|
+ /* The "preference" here was just around because ESD introduced tradeoffs and was generally
|
||||||
|
+ poor software. Pulseaudio is better and notably releases the sound device when not in
|
||||||
|
+ use, so should have no impact for legacy applications. The reason we don't actually want
|
||||||
|
+ to even read from the preference is because someone may have set it to false intending
|
||||||
|
+ to disable ESD, but they will then disable Pulseaudio later.
|
||||||
|
+ https://bugzilla.redhat.com/show_bug.cgi?id=430624
|
||||||
|
+ */
|
||||||
|
+#ifdef ENABLE_LEGACY_SOUND_PREF
|
||||||
|
enable_sound = gconf_client_get_bool (client, "/desktop/gnome/sound/enable_esd", NULL);
|
||||||
|
+#else
|
||||||
|
+ enable_sound = TRUE;
|
||||||
|
+#endif
|
||||||
|
event_sounds = gconf_client_get_bool (client, "/desktop/gnome/sound/event_sounds", NULL);
|
||||||
|
/* FIXME this is completely bogus, the entry doesn't exist */
|
||||||
|
event_changed_new = gconf_client_get_int (client, "/desktop/gnome/sound/event_changed", NULL);
|
||||||
|
Index: configure.ac
|
||||||
|
===================================================================
|
||||||
|
--- configure.ac (revision 340)
|
||||||
|
+++ configure.ac (working copy)
|
||||||
|
@@ -317,6 +317,23 @@
|
||||||
|
|
||||||
|
|
||||||
|
# ---------------------------------------------------------------------------
|
||||||
|
+# Enable Legacy Sound Preference
|
||||||
|
+# ---------------------------------------------------------------------------
|
||||||
|
+PKG_CHECK_MODULES(PULSEAUDIO, libpulse, have_pulseaudio=yes, AC_MSG_RESULT([no]))
|
||||||
|
+if test x$have_pulseaudio = xyes; then
|
||||||
|
+ default_enable_legacy_sound_pref=no
|
||||||
|
+else
|
||||||
|
+ default_enable_legacy_sound_pref=yes
|
||||||
|
+fi
|
||||||
|
+AC_ARG_ENABLE(legacy-sound-pref,
|
||||||
|
+ [AC_HELP_STRING([--enable-legacy-sound-pref],
|
||||||
|
+ [check for preference to start ESD])],
|
||||||
|
+ ,enable_legacy_sound_pref=$default_enable_legacy_sound_pref)
|
||||||
|
+if test "x$enable_legacy_sound_pref" = "xyes"; then
|
||||||
|
+ AC_DEFINE(ENABLE_LEGACY_SOUND_PREF,1,[enable preference for ESD startup])
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+# ---------------------------------------------------------------------------
|
||||||
|
# Enable Profiling
|
||||||
|
# ---------------------------------------------------------------------------
|
||||||
|
AC_ARG_ENABLE(profiling,
|
@ -1,6 +1,6 @@
|
|||||||
Name: gnome-settings-daemon
|
Name: gnome-settings-daemon
|
||||||
Version: 2.23.3
|
Version: 2.23.3
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: The daemon sharing settings from GNOME to GTK+/KDE applications
|
Summary: The daemon sharing settings from GNOME to GTK+/KDE applications
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -24,6 +24,7 @@ BuildRequires: libgnome-devel
|
|||||||
BuildRequires: xorg-x11-proto-devel
|
BuildRequires: xorg-x11-proto-devel
|
||||||
BuildRequires: gstreamer-devel
|
BuildRequires: gstreamer-devel
|
||||||
BuildRequires: gstreamer-plugins-base-devel
|
BuildRequires: gstreamer-plugins-base-devel
|
||||||
|
BuildRequires: pulseaudio-libs-devel
|
||||||
BuildRequires: libgnomekbd-devel
|
BuildRequires: libgnomekbd-devel
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: perl(XML::Parser)
|
BuildRequires: perl(XML::Parser)
|
||||||
@ -33,6 +34,7 @@ Patch1: add-randr-12.patch
|
|||||||
Patch2: gnome-settings-daemon-2.21.91-ignore-model-if-evdev.patch
|
Patch2: gnome-settings-daemon-2.21.91-ignore-model-if-evdev.patch
|
||||||
# survive xrandr being absent (such as on Xnest in sabayon)
|
# survive xrandr being absent (such as on Xnest in sabayon)
|
||||||
Patch5: xrandr-missingok.patch
|
Patch5: xrandr-missingok.patch
|
||||||
|
Patch6: gnome-settings-daemon-legacy-sound.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
A daemon to share settings from GNOME to other applications. It also
|
A daemon to share settings from GNOME to other applications. It also
|
||||||
@ -55,6 +57,7 @@ developing applications that use %{name}.
|
|||||||
%patch1 -p1 -b .add-randr-12
|
%patch1 -p1 -b .add-randr-12
|
||||||
%patch2 -p1 -b .ignore-layout-if-using-evdev
|
%patch2 -p1 -b .ignore-layout-if-using-evdev
|
||||||
%patch5 -p1 -b .xrandr-missingok
|
%patch5 -p1 -b .xrandr-missingok
|
||||||
|
%patch6 -p0 -b .legacy-sound
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-static=no --enable-profiling
|
%configure --enable-static=no --enable-profiling
|
||||||
@ -137,6 +140,11 @@ fi
|
|||||||
%{_libdir}/pkgconfig/gnome-settings-daemon.pc
|
%{_libdir}/pkgconfig/gnome-settings-daemon.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 17 2008 Colin Walters <walters@redhat.com> - 2.23.3-2
|
||||||
|
- Add (now upstreamed) patch to legacy ESD preference; see
|
||||||
|
http://bugzilla.gnome.org/show_bug.cgi?id=533198
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=430624
|
||||||
|
|
||||||
* Wed Jun 4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.3-1
|
* Wed Jun 4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.3-1
|
||||||
- Update to 2.23.3
|
- Update to 2.23.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user