Add a patch to make the fallback mounter build correctly
And add the power plugin
This commit is contained in:
parent
d92a4d97b4
commit
4cfa7909e5
28
fallback-mounter.patch
Normal file
28
fallback-mounter.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
diff --git a/plugins/automount/Makefile.am b/plugins/automount/Makefile.am
|
||||||
|
index 209feb1..ace425a 100644
|
||||||
|
--- a/plugins/automount/Makefile.am
|
||||||
|
+++ b/plugins/automount/Makefile.am
|
||||||
|
@@ -17,7 +17,8 @@ gnome_fallback_mount_helper_CFLAGS = \
|
||||||
|
|
||||||
|
gnome_fallback_mount_helper_LDADD = \
|
||||||
|
$(SETTINGS_PLUGIN_LIBS) \
|
||||||
|
- $(X11_LIBS)
|
||||||
|
+ $(X11_LIBS) \
|
||||||
|
+ $(top_builddir)/gnome-settings-daemon/libgsd-profile.la
|
||||||
|
|
||||||
|
autostartdir = $(sysconfdir)/xdg/autostart
|
||||||
|
autostart_in_files = gnome-fallback-mount-helper.desktop.in
|
||||||
|
diff --git a/plugins/automount/gnome-fallback-mount-helper.c b/plugins/automount/gnome-fallback-mount-helper.c
|
||||||
|
index ff5d192..9f7a1fa 100644
|
||||||
|
--- a/plugins/automount/gnome-fallback-mount-helper.c
|
||||||
|
+++ b/plugins/automount/gnome-fallback-mount-helper.c
|
||||||
|
@@ -22,7 +22,9 @@
|
||||||
|
#include "config.h"
|
||||||
|
|
||||||
|
#include <glib.h>
|
||||||
|
+#include <glib/gi18n.h>
|
||||||
|
#include <unistd.h>
|
||||||
|
+#include <gtk/gtk.h>
|
||||||
|
|
||||||
|
#include "gsd-automount-manager.h"
|
||||||
|
|
@ -13,6 +13,8 @@ Source: http://download.gnome.org/sources/%{name}/3.1/%{name}-%{version}
|
|||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=723212
|
# https://bugzilla.redhat.com/show_bug.cgi?id=723212
|
||||||
Patch0: chrony-support.patch
|
Patch0: chrony-support.patch
|
||||||
|
|
||||||
|
Patch1: fallback-mounter.patch
|
||||||
|
|
||||||
Requires(pre): GConf2 >= 2.14
|
Requires(pre): GConf2 >= 2.14
|
||||||
Requires(preun): GConf2 >= 2.14
|
Requires(preun): GConf2 >= 2.14
|
||||||
Requires(post): GConf2 >= 2.14
|
Requires(post): GConf2 >= 2.14
|
||||||
@ -63,6 +65,7 @@ developing applications that use %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .chrony
|
%patch0 -p1 -b .chrony
|
||||||
|
%patch1 -p1 -b .fallback
|
||||||
|
|
||||||
# autoreconf -i -f
|
# autoreconf -i -f
|
||||||
|
|
||||||
@ -113,8 +116,10 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_libdir}/gnome-settings-daemon-3.0/a11y-keyboard.gnome-settings-plugin
|
%{_libdir}/gnome-settings-daemon-3.0/a11y-keyboard.gnome-settings-plugin
|
||||||
%{_libdir}/gnome-settings-daemon-3.0/liba11y-keyboard.so
|
%{_libdir}/gnome-settings-daemon-3.0/liba11y-keyboard.so
|
||||||
|
|
||||||
%{_libdir}/gnome-settings-daemon-3.0/automount.gnome-settings-plugin
|
# The automount plugin is a separate executable used in fallback
|
||||||
%{_libdir}/gnome-settings-daemon-3.0/libautomount.so
|
# mode only
|
||||||
|
%{_libexecdir}/gnome-fallback-mount-helper
|
||||||
|
%{_sysconfdir}/xdg/autostart/gnome-fallback-mount-helper.desktop
|
||||||
|
|
||||||
%{_libdir}/gnome-settings-daemon-3.0/background.gnome-settings-plugin
|
%{_libdir}/gnome-settings-daemon-3.0/background.gnome-settings-plugin
|
||||||
%{_libdir}/gnome-settings-daemon-3.0/libbackground.so
|
%{_libdir}/gnome-settings-daemon-3.0/libbackground.so
|
||||||
@ -151,7 +156,8 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_libdir}/gnome-settings-daemon-3.0/liborientation.so
|
%{_libdir}/gnome-settings-daemon-3.0/liborientation.so
|
||||||
%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.plugins.orientation.gschema.xml
|
%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.plugins.orientation.gschema.xml
|
||||||
|
|
||||||
# no power plugin yet, just a schema
|
%{_libdir}/gnome-settings-daemon-3.0/power.gnome-settings-plugin
|
||||||
|
%{_libdir}/gnome-settings-daemon-3.0/libpower.so
|
||||||
%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.plugins.power.gschema.xml
|
%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.plugins.power.gschema.xml
|
||||||
|
|
||||||
%{_libdir}/gnome-settings-daemon-3.0/print-notifications.gnome-settings-plugin
|
%{_libdir}/gnome-settings-daemon-3.0/print-notifications.gnome-settings-plugin
|
||||||
@ -227,6 +233,10 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_datadir}/gnome-settings-daemon-3.0/input-device-example.sh
|
%{_datadir}/gnome-settings-daemon-3.0/input-device-example.sh
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 26 2011 Cosimo Cecchi <cosimoc@redhat.com> - 3.1.4-2
|
||||||
|
- Add a patch to make the fallback mounter to build correctly
|
||||||
|
- Include the new power plugin
|
||||||
|
|
||||||
* Mon Jul 25 2011 Matthias Clasen <mclasen@redhat.com> - 3.1.4-1
|
* Mon Jul 25 2011 Matthias Clasen <mclasen@redhat.com> - 3.1.4-1
|
||||||
- Update to 3.1.4
|
- Update to 3.1.4
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user