Update to 3.25.1. Meson. BR reshuffle
This commit is contained in:
parent
12005a7e91
commit
31ccb82c77
1
.gitignore
vendored
1
.gitignore
vendored
@ -43,3 +43,4 @@
|
|||||||
/gnome-clocks-3.22.1.tar.xz
|
/gnome-clocks-3.22.1.tar.xz
|
||||||
/gnome-clocks-3.23.90.tar.xz
|
/gnome-clocks-3.23.90.tar.xz
|
||||||
/gnome-clocks-3.24.0.tar.xz
|
/gnome-clocks-3.24.0.tar.xz
|
||||||
|
/gnome-clocks-3.25.1.tar.xz
|
||||||
|
23
gnome-clocks-meson1.patch
Normal file
23
gnome-clocks-meson1.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff --git a/data/meson.build b/data/meson.build
|
||||||
|
index 90dafc2..a7dacb0 100644
|
||||||
|
--- a/data/meson.build
|
||||||
|
+++ b/data/meson.build
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
iconsdir = join_paths(get_option('datadir'), 'icons/hicolor')
|
||||||
|
-foreach size: ['16x16', '22x22', '32x32', '48x48', '256x256', 'scalable']
|
||||||
|
- install_subdir('icons/' + size, install_dir: iconsdir)
|
||||||
|
+foreach size: ['16x16', '22x22', '32x32', '48x48', '256x256', 'symbolic']
|
||||||
|
+ install_subdir('icons/hicolor/' + size, install_dir: iconsdir)
|
||||||
|
endforeach
|
||||||
|
|
||||||
|
install_subdir('images/', install_dir: join_paths(get_option('datadir'), meson.project_name()))
|
||||||
|
diff --git a/help/meson.build b/help/meson.build
|
||||||
|
index f89afbd..31d389f 100644
|
||||||
|
--- a/help/meson.build
|
||||||
|
+++ b/help/meson.build
|
||||||
|
@@ -39,4 +39,5 @@ gnome.yelp(meson.project_name(),
|
||||||
|
sources: help_files,
|
||||||
|
media: help_media,
|
||||||
|
languages: help_linguas,
|
||||||
|
+ symlink_media: true,
|
||||||
|
)
|
@ -1,37 +1,44 @@
|
|||||||
Name: gnome-clocks
|
Name: gnome-clocks
|
||||||
Version: 3.24.0
|
Version: 3.25.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Clock application designed for GNOME 3
|
Summary: Clock application designed for GNOME 3
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://wiki.gnome.org/Apps/Clocks
|
URL: https://wiki.gnome.org/Apps/Clocks
|
||||||
Source0: https://download.gnome.org/sources/gnome-clocks/3.24/%{name}-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/gnome-clocks/3.25/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
BuildRequires: gtk3-devel
|
# these are already upstream
|
||||||
Buildrequires: gobject-introspection-devel
|
Patch0: gnome-clocks-meson1.patch
|
||||||
BuildRequires: libcanberra-devel
|
|
||||||
BuildRequires: libgweather-devel >= 3.13.91
|
BuildRequires: meson
|
||||||
BuildRequires: gnome-desktop3-devel
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: vala
|
|
||||||
BuildRequires: desktop-file-utils glib2-devel itstool
|
|
||||||
BuildRequires: geoclue2-devel
|
|
||||||
BuildRequires: geocode-glib-devel
|
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: gsound-devel
|
BuildRequires: itstool
|
||||||
BuildRequires: libappstream-glib
|
BuildRequires: libappstream-glib
|
||||||
|
BuildRequires: vala
|
||||||
|
|
||||||
|
BuildRequires: pkgconfig(gtk+-3.0) >= 3.20
|
||||||
|
BuildRequires: pkgconfig(gweather-3.0) >= 3.14
|
||||||
|
BuildRequires: pkgconfig(gnome-desktop-3.0) >= 3.8
|
||||||
|
BuildRequires: pkgconfig(glib-2.0) >= 2.44
|
||||||
|
BuildRequires: pkgconfig(gobject-2.0) >= 2.44
|
||||||
|
BuildRequires: pkgconfig(libgeoclue-2.0) >= 2.4
|
||||||
|
BuildRequires: pkgconfig(geocode-glib-1.0) >= 1.0
|
||||||
|
BuildRequires: pkgconfig(gsound) >= 0.98
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Clock application designed for GNOME 3
|
Clock application designed for GNOME 3
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%meson
|
||||||
make V=1 %{?_smp_mflags}
|
%meson_build
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%make_install
|
%meson_install
|
||||||
%find_lang gnome-clocks --with-gnome
|
%find_lang gnome-clocks --with-gnome
|
||||||
|
|
||||||
# Update the screenshot shown in the software center
|
# Update the screenshot shown in the software center
|
||||||
@ -81,6 +88,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 23 2017 Yanko Kaneti <yaneti@declera.com> - 3.25.1-1
|
||||||
|
- Update to 3.25.1. Meson. BR reshuffle
|
||||||
|
|
||||||
* Mon Mar 20 2017 Yanko Kaneti <yaneti@declera.com> - 3.24.0-1
|
* Mon Mar 20 2017 Yanko Kaneti <yaneti@declera.com> - 3.24.0-1
|
||||||
- Update to 3.24.0
|
- Update to 3.24.0
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gnome-clocks-3.24.0.tar.xz) = f29a61ac9634008fa918f9f08c6e24c93816c0077687bd2feff3ef2c62c0db475076de5dbc1e223027627e985c4e4362f0cdf1a47821356c0a9ef9c4cd672de1
|
SHA512 (gnome-clocks-3.25.1.tar.xz) = 93207d91bbec3cfd163e31a62e237ba3c9e92aaf794f1783ec6118fa02d63ab9625bb943245ab6dc5c992f74c11f26a31287e5b1f0b9c8486dac2a0bfdbd606e
|
||||||
|
Loading…
Reference in New Issue
Block a user