auto-import changelog data from gmp-4.1.2-9.src.rpm
Thu Oct 23 2003 Joe Orton <jorton@redhat.com> 4.1.2-9 - build with -Wa,--noexecstack Thu Oct 23 2003 Joe Orton <jorton@redhat.com> 4.1.2-8 - build assembly code with -Wa,--execstack - use parallel make - run tests, and fix C++ therein Thu Oct 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> - enable mpfr #104395 - enable cxx #80195 - add COPYING.LIB - add fixes from gmp web-site - remove some cruft patches for older libtool releases Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> - rebuilt Tue Jun 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> - make configure.in work with newer autoconf Sun Jun 01 2003 Florian La Roche <Florian.LaRoche@redhat.de> - do not set extra_functions for s390x #92001 Thu Feb 13 2003 Elliot Lee <sopwith@redhat.com> 4.1.2-3 - Add ppc64 patch, accompanied by running auto*
This commit is contained in:
parent
99c01d16cf
commit
4e10f76d3c
@ -49,38 +49,8 @@
|
||||
+ s390x-*-*)
|
||||
+ gcc_cflags="-g -O2 $fomit_frame_pointer"
|
||||
+ path="s390x"
|
||||
+ extra_functions="udiv_w_sdiv"
|
||||
+ #extra_functions="udiv_w_sdiv"
|
||||
+ ;;
|
||||
# IBM s/370 and similar
|
||||
[s3[6-9]0*-*-*])
|
||||
gcc_cflags="-g -O2 $fomit_frame_pointer"
|
||||
--- gmp-4.1/mpn/Makeasm.am
|
||||
+++ gmp-4.1/mpn/Makeasm.am
|
||||
@@ -106,4 +106,4 @@
|
||||
$(CCAS) $(COMPILE_FLAGS) tmp-$*.s -o $@
|
||||
$(RM_TMP) tmp-$*.s
|
||||
.asm.lo:
|
||||
- $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/mpn/m4-ccas --m4="$(M4)" $(CCAS) $(COMPILE_FLAGS) `test -f $< || echo '$(srcdir)/'`$<
|
||||
+ $(LIBTOOL) --mode=compile $(top_srcdir)/mpn/m4-ccas --m4="$(M4)" $(CCAS) $(COMPILE_FLAGS) `test -f $< || echo '$(srcdir)/'`$<
|
||||
--- gmp-4.1/mpn/Makefile.in
|
||||
+++ gmp-4.1/mpn/Makefile.in
|
||||
@@ -681,7 +681,7 @@
|
||||
$(CCAS) $(COMPILE_FLAGS) tmp-$*.s -o $@
|
||||
$(RM_TMP) tmp-$*.s
|
||||
.asm.lo:
|
||||
- $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/mpn/m4-ccas --m4="$(M4)" $(CCAS) $(COMPILE_FLAGS) `test -f $< || echo '$(srcdir)/'`$<
|
||||
+ $(LIBTOOL) --mode=compile $(top_srcdir)/mpn/m4-ccas --m4="$(M4)" $(CCAS) $(COMPILE_FLAGS) `test -f $< || echo '$(srcdir)/'`$<
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
.NOEXPORT:
|
||||
--- gmp-4.1.1/longlong.h
|
||||
+++ gmp-4.1.1/longlong.h
|
||||
@@ -687,7 +687,7 @@
|
||||
#endif
|
||||
#endif /* 80x86 */
|
||||
|
||||
-#if defined (__x86_64__) && W_TYPE_SIZE == 64
|
||||
+#if defined (disable__x86_64__) && W_TYPE_SIZE == 64
|
||||
#define add_ssaaaa(sh, sl, ah, al, bh, bl) \
|
||||
__asm__ ("addq %5,%1\n\tadcq %3,%0" \
|
||||
: "=r" ((UDItype)(sh)), "=&r" ((UDItype)(sl)) \
|
||||
|
17
gmp-4.1.2-autoconf.patch
Normal file
17
gmp-4.1.2-autoconf.patch
Normal file
@ -0,0 +1,17 @@
|
||||
--- gmp-4.1.2/configure.in.lr 2003-06-03 09:48:52.000000000 +0200
|
||||
+++ gmp-4.1.2/configure.in 2003-06-03 09:49:39.000000000 +0200
|
||||
@@ -1338,11 +1338,11 @@
|
||||
|
||||
|
||||
# The C++ compiler, if desired.
|
||||
+test_CXXFLAGS=${CXXFLAGS+set}
|
||||
+AC_PROG_CXX
|
||||
+
|
||||
want_cxx=no
|
||||
if test $enable_cxx != no; then
|
||||
- test_CXXFLAGS=${CXXFLAGS+set}
|
||||
- AC_PROG_CXX
|
||||
-
|
||||
echo "CXXFLAGS chosen by autoconf: $CXXFLAGS" >&AC_FD_CC
|
||||
cxxflags_ac_prog_cxx=$CXXFLAGS
|
||||
cxxflags_list=ac_prog_cxx
|
34
gmp-4.1.2-ppc64.patch
Normal file
34
gmp-4.1.2-ppc64.patch
Normal file
@ -0,0 +1,34 @@
|
||||
--- gmp-4.1.2/acinclude.m4.sopwith 2002-09-07 20:02:19.000000000 -0400
|
||||
+++ gmp-4.1.2/acinclude.m4 2003-02-11 10:48:30.000000000 -0500
|
||||
@@ -1003,7 +1003,7 @@
|
||||
${tmp_underscore}underscore_test$gmp_cv_asm_label_suffix
|
||||
EOF
|
||||
case $host in
|
||||
- *-*-aix*)
|
||||
+ *-*-aix*|powerpc64-*)
|
||||
cat >>conftes2.s <<EOF
|
||||
$gmp_cv_asm_globl .${tmp_underscore}underscore_test
|
||||
.${tmp_underscore}underscore_test$gmp_cv_asm_label_suffix
|
||||
--- gmp-4.1.2/configure.in.sopwith 2003-02-11 10:48:30.000000000 -0500
|
||||
+++ gmp-4.1.2/configure.in 2003-02-11 10:51:58.000000000 -0500
|
||||
@@ -669,6 +669,11 @@
|
||||
case $host_cpu in
|
||||
powerpc740 | powerpc750 | powerpc7400)
|
||||
path="powerpc32/750 powerpc32" ;;
|
||||
+ powerpc64)
|
||||
+ gcc_cflags="-g -O2"
|
||||
+ gcc_cflags_asm="-Wa,-mppc64"
|
||||
+ extra_functions=""
|
||||
+ ;;
|
||||
*)
|
||||
path="powerpc32" ;;
|
||||
esac
|
||||
@@ -1943,6 +1948,8 @@
|
||||
GMP_ASM_M68K_ADDRESSING
|
||||
GMP_ASM_M68K_BRANCHES
|
||||
;;
|
||||
+ powerpc64*-*-*)
|
||||
+ ;;
|
||||
powerpc*-*-*)
|
||||
GMP_ASM_POWERPC_R_REGISTERS
|
||||
GMP_INCLUDE_MPN(powerpc32/powerpc-defs.m4)
|
71
gmp.spec
71
gmp.spec
@ -3,13 +3,18 @@
|
||||
Summary: A GNU arbitrary precision library.
|
||||
Name: gmp
|
||||
Version: 4.1.2
|
||||
Release: 2
|
||||
Release: 9
|
||||
URL: http://www.swox.com/gmp/
|
||||
Source: ftp://ftp.gnu.org/pub/gnu/gmp/gmp-%{version}.tar.bz2
|
||||
Patch0: gmp-4.0.1-s390.patch
|
||||
Patch1: gmp-4.1.2-ppc64.patch
|
||||
Patch2: gmp-4.1.2-autoconf.patch
|
||||
Patch3: gmp-fixes.patch
|
||||
Patch4: gmp-4.1.2-cxxtests.patch
|
||||
License: LGPL
|
||||
Group: System Environment/Libraries
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: automake autoconf libtool
|
||||
|
||||
%description
|
||||
The gmp package contains GNU MP, a library for arbitrary precision
|
||||
@ -40,17 +45,35 @@ install the gmp package.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1 -b .cxxtests
|
||||
|
||||
libtoolize --force
|
||||
aclocal -I mpn -I mpfr
|
||||
automake
|
||||
autoconf
|
||||
|
||||
%build
|
||||
%configure --enable-mpbsd
|
||||
make
|
||||
if as --help | grep -q execstack; then
|
||||
# the object files do not require an executable stack
|
||||
export CCAS="gcc -c -Wa,--noexecstack"
|
||||
fi
|
||||
%configure --enable-mpbsd --enable-mpfr --enable-cxx
|
||||
make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
|
||||
%{makeinstall}
|
||||
%{makeinstall} LIBTOOL=/usr/bin/libtool
|
||||
install -m 644 gmp-mparam.h ${RPM_BUILD_ROOT}%{_includedir}
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/lib{gmp,mp}.la
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/lib{gmp,mp,gmpxx}.la
|
||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
/sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir}
|
||||
ln -sf gmpxx.so.3 $RPM_BUILD_ROOT%{_libdir}/libgmpxx.so
|
||||
|
||||
%check
|
||||
make %{?_smp_mflags} check
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
@ -69,22 +92,52 @@ fi
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc COPYING NEWS README
|
||||
%doc COPYING COPYING.LIB NEWS README
|
||||
%{_libdir}/libgmp.so.*
|
||||
%{_libdir}/libmp.so.*
|
||||
%{_libdir}/libgmpxx.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libmp.so
|
||||
%{_libdir}/libgmp.so
|
||||
%{_libdir}/libgmpxx.so
|
||||
%{_libdir}/libmp.a
|
||||
%{_libdir}/libgmp.a
|
||||
%{_includedir}/mp.h
|
||||
%{_includedir}/gmp.h
|
||||
%{_includedir}/gmp-mparam.h
|
||||
%{_libdir}/libgmpxx.a
|
||||
%{_libdir}/libmpfr.a
|
||||
%{_includedir}/*.h
|
||||
%{_infodir}/gmp.info*
|
||||
%{_infodir}/mpfr.info*
|
||||
|
||||
%changelog
|
||||
* Thu Oct 23 2003 Joe Orton <jorton@redhat.com> 4.1.2-9
|
||||
- build with -Wa,--noexecstack
|
||||
|
||||
* Thu Oct 23 2003 Joe Orton <jorton@redhat.com> 4.1.2-8
|
||||
- build assembly code with -Wa,--execstack
|
||||
- use parallel make
|
||||
- run tests, and fix C++ therein
|
||||
|
||||
* Thu Oct 02 2003 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- enable mpfr #104395
|
||||
- enable cxx #80195
|
||||
- add COPYING.LIB
|
||||
- add fixes from gmp web-site
|
||||
- remove some cruft patches for older libtool releases
|
||||
|
||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Tue Jun 03 2003 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- make configure.in work with newer autoconf
|
||||
|
||||
* Sun Jun 01 2003 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- do not set extra_functions for s390x #92001
|
||||
|
||||
* Thu Feb 13 2003 Elliot Lee <sopwith@redhat.com> 4.1.2-3
|
||||
- Add ppc64 patch, accompanied by running auto*
|
||||
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user