auto-import changelog data from gmp-4.1.2-2.src.rpm
Wed Jan 22 2003 Tim Powers <timp@redhat.com> - rebuilt Wed Jan 01 2003 Florian La Roche <Florian.LaRoche@redhat.de> - update to 4.1.2 Tue Dec 03 2002 Florian La Roche <Florian.LaRoche@redhat.de> - update to 4.1.1 - remove un-necessary patches - adjust s390/x86_64 patch Sun Oct 06 2002 Florian La Roche <Florian.LaRoche@redhat.de> - add s390x patch - disable current x86-64 support in longlong.h
This commit is contained in:
parent
a94dc12dda
commit
99c01d16cf
@ -1 +1 @@
|
||||
gmp-4.1.tar.bz2
|
||||
gmp-4.1.2.tar.bz2
|
||||
|
@ -10,3 +10,77 @@
|
||||
|
||||
|
||||
/* Generated by tuneup.c, 2001-09-26, gcc 2.95 */
|
||||
--- ./mpn/s390x/gmp-mparam.h
|
||||
+++ ./mpn/s390x/gmp-mparam.h
|
||||
@@ -0,0 +1,27 @@
|
||||
+/* gmp-mparam.h -- Compiler/machine parameter header file.
|
||||
+
|
||||
+Copyright (C) 1991, 1993, 1994, 1995 Free Software Foundation, Inc.
|
||||
+
|
||||
+This file is part of the GNU MP Library.
|
||||
+
|
||||
+The GNU MP Library is free software; you can redistribute it and/or modify
|
||||
+it under the terms of the GNU Library General Public License as published by
|
||||
+the Free Software Foundation; either version 2 of the License, or (at your
|
||||
+option) any later version.
|
||||
+
|
||||
+The GNU MP Library is distributed in the hope that it will be useful, but
|
||||
+WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
|
||||
+or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Library General Public
|
||||
+License for more details.
|
||||
+
|
||||
+You should have received a copy of the GNU Library General Public License
|
||||
+along with the GNU MP Library; see the file COPYING.LIB. If not, write to
|
||||
+the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
|
||||
+MA 02111-1307, USA. */
|
||||
+
|
||||
+#define BITS_PER_MP_LIMB 64
|
||||
+#define BYTES_PER_MP_LIMB 8
|
||||
+#define BITS_PER_LONGINT 64
|
||||
+#define BITS_PER_INT 32
|
||||
+#define BITS_PER_SHORTINT 16
|
||||
+#define BITS_PER_CHAR 8
|
||||
--- ./configure.in
|
||||
+++ ./configure.in
|
||||
@@ -620,6 +620,11 @@
|
||||
;;
|
||||
|
||||
|
||||
+ s390x-*-*)
|
||||
+ gcc_cflags="-g -O2 $fomit_frame_pointer"
|
||||
+ path="s390x"
|
||||
+ extra_functions="udiv_w_sdiv"
|
||||
+ ;;
|
||||
# IBM s/370 and similar
|
||||
[s3[6-9]0*-*-*])
|
||||
gcc_cflags="-g -O2 $fomit_frame_pointer"
|
||||
--- gmp-4.1/mpn/Makeasm.am
|
||||
+++ gmp-4.1/mpn/Makeasm.am
|
||||
@@ -106,4 +106,4 @@
|
||||
$(CCAS) $(COMPILE_FLAGS) tmp-$*.s -o $@
|
||||
$(RM_TMP) tmp-$*.s
|
||||
.asm.lo:
|
||||
- $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/mpn/m4-ccas --m4="$(M4)" $(CCAS) $(COMPILE_FLAGS) `test -f $< || echo '$(srcdir)/'`$<
|
||||
+ $(LIBTOOL) --mode=compile $(top_srcdir)/mpn/m4-ccas --m4="$(M4)" $(CCAS) $(COMPILE_FLAGS) `test -f $< || echo '$(srcdir)/'`$<
|
||||
--- gmp-4.1/mpn/Makefile.in
|
||||
+++ gmp-4.1/mpn/Makefile.in
|
||||
@@ -681,7 +681,7 @@
|
||||
$(CCAS) $(COMPILE_FLAGS) tmp-$*.s -o $@
|
||||
$(RM_TMP) tmp-$*.s
|
||||
.asm.lo:
|
||||
- $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/mpn/m4-ccas --m4="$(M4)" $(CCAS) $(COMPILE_FLAGS) `test -f $< || echo '$(srcdir)/'`$<
|
||||
+ $(LIBTOOL) --mode=compile $(top_srcdir)/mpn/m4-ccas --m4="$(M4)" $(CCAS) $(COMPILE_FLAGS) `test -f $< || echo '$(srcdir)/'`$<
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
.NOEXPORT:
|
||||
--- gmp-4.1.1/longlong.h
|
||||
+++ gmp-4.1.1/longlong.h
|
||||
@@ -687,7 +687,7 @@
|
||||
#endif
|
||||
#endif /* 80x86 */
|
||||
|
||||
-#if defined (__x86_64__) && W_TYPE_SIZE == 64
|
||||
+#if defined (disable__x86_64__) && W_TYPE_SIZE == 64
|
||||
#define add_ssaaaa(sh, sl, ah, al, bh, bl) \
|
||||
__asm__ ("addq %5,%1\n\tadcq %3,%0" \
|
||||
: "=r" ((UDItype)(sh)), "=&r" ((UDItype)(sl)) \
|
||||
|
33
gmp.spec
33
gmp.spec
@ -2,15 +2,11 @@
|
||||
|
||||
Summary: A GNU arbitrary precision library.
|
||||
Name: gmp
|
||||
Version: 4.1
|
||||
Release: 4
|
||||
Version: 4.1.2
|
||||
Release: 2
|
||||
URL: http://www.swox.com/gmp/
|
||||
Source: ftp://ftp.gnu.org/pub/gnu/gmp/gmp-%{version}.tar.bz2
|
||||
Patch0: gmp-4.0.1-s390.patch
|
||||
Patch1: gmpxx.h.getnum.diff
|
||||
Patch2: mpf_inp_str.c.diff
|
||||
Patch3: powm_ui.c.41.diff
|
||||
Patch4: randraw.c.41.diff
|
||||
License: LGPL
|
||||
Group: System Environment/Libraries
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
@ -44,14 +40,6 @@ install the gmp package.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p0
|
||||
pushd mpf
|
||||
%patch2 -p0
|
||||
popd
|
||||
pushd mpz
|
||||
%patch3 -p0
|
||||
popd
|
||||
%patch4 -p0
|
||||
|
||||
%build
|
||||
%configure --enable-mpbsd
|
||||
@ -61,6 +49,8 @@ make
|
||||
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
|
||||
%{makeinstall}
|
||||
install -m 644 gmp-mparam.h ${RPM_BUILD_ROOT}%{_includedir}
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/lib{gmp,mp}.la
|
||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
@ -95,6 +85,21 @@ fi
|
||||
%{_infodir}/gmp.info*
|
||||
|
||||
%changelog
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Jan 01 2003 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- update to 4.1.2
|
||||
|
||||
* Tue Dec 03 2002 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- update to 4.1.1
|
||||
- remove un-necessary patches
|
||||
- adjust s390/x86_64 patch
|
||||
|
||||
* Sun Oct 06 2002 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- add s390x patch
|
||||
- disable current x86-64 support in longlong.h
|
||||
|
||||
* Mon Jul 8 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.1-4
|
||||
- Add 4 patches, among them one for #67918
|
||||
- Update URL
|
||||
|
Loading…
Reference in New Issue
Block a user