update to 0.3.0
This commit is contained in:
parent
35d3303bf8
commit
dad7521cf7
@ -1 +1 @@
|
|||||||
glog-0.2.tar.gz
|
glog-0.3.0.tar.gz
|
||||||
|
@ -1,60 +0,0 @@
|
|||||||
index 8e41d5e..d4bb7de 100644
|
|
||||||
--- src/googletest.h
|
|
||||||
+++ src/googletest.h
|
|
||||||
@@ -14,6 +14,9 @@
|
|
||||||
#include <string>
|
|
||||||
#include <vector>
|
|
||||||
|
|
||||||
+#include <stdio.h>
|
|
||||||
+#include <stdlib.h>
|
|
||||||
+
|
|
||||||
#include <sys/types.h>
|
|
||||||
#include <sys/stat.h>
|
|
||||||
#include <fcntl.h>
|
|
||||||
index 14c9789..47ba36f 100644
|
|
||||||
--- src/logging_unittest.cc
|
|
||||||
+++ src/logging_unittest.cc
|
|
||||||
@@ -23,6 +23,9 @@
|
|
||||||
#include <string>
|
|
||||||
#include <vector>
|
|
||||||
|
|
||||||
+#include <stdio.h>
|
|
||||||
+#include <stdlib.h>
|
|
||||||
+
|
|
||||||
#include "base/commandlineflags.h"
|
|
||||||
#include "glog/logging.h"
|
|
||||||
#include "glog/raw_logging.h"
|
|
||||||
index e6e3e70..0e1b6cb 100644
|
|
||||||
--- src/symbolize.cc
|
|
||||||
+++ src/symbolize.cc
|
|
||||||
@@ -414,7 +414,7 @@ class LineReader {
|
|
||||||
|
|
||||||
char *FindLineFeed() {
|
|
||||||
return reinterpret_cast<char *>
|
|
||||||
- (memchr(reinterpret_cast<const void *>(bol_), '\n', eod_ - bol_));
|
|
||||||
+ (memchr(reinterpret_cast<void *>(bol_), '\n', eod_ - bol_));
|
|
||||||
}
|
|
||||||
|
|
||||||
bool BufferIsEmpty() {
|
|
||||||
@@ -428,7 +428,7 @@ class LineReader {
|
|
||||||
const int fd_;
|
|
||||||
char * const buf_;
|
|
||||||
const int buf_len_;
|
|
||||||
- const char *bol_;
|
|
||||||
+ char *bol_;
|
|
||||||
char *eol_;
|
|
||||||
const char *eod_; // End of data in "buf_".
|
|
||||||
};
|
|
||||||
index e8cbc0c..f06bcdd 100644
|
|
||||||
--- src/utilities.cc
|
|
||||||
+++ src/utilities.cc
|
|
||||||
@@ -3,6 +3,9 @@
|
|
||||||
|
|
||||||
#include "utilities.h"
|
|
||||||
|
|
||||||
+#include <stdio.h>
|
|
||||||
+#include <stdlib.h>
|
|
||||||
+
|
|
||||||
#include <signal.h>
|
|
||||||
#ifdef HAVE_SYS_TIME_H
|
|
||||||
# include <sys/time.h>
|
|
@ -1,13 +0,0 @@
|
|||||||
Index: src/logging_unittest.cc
|
|
||||||
===================================================================
|
|
||||||
--- src/logging_unittest.cc (revision 37)
|
|
||||||
+++ src/logging_unittest.cc (revision 38)
|
|
||||||
@@ -154,7 +154,7 @@
|
|
||||||
FLAGS_logtostderr = true;
|
|
||||||
|
|
||||||
InitGoogleTest(&argc, argv);
|
|
||||||
-#ifdef HAVE_LIB_GTEST
|
|
||||||
+#ifdef HAVE_LIB_GMOCK
|
|
||||||
InitGoogleMock(&argc, argv);
|
|
||||||
#endif
|
|
||||||
|
|
12
glog.spec
12
glog.spec
@ -1,14 +1,12 @@
|
|||||||
Name: glog
|
Name: glog
|
||||||
Version: 0.2
|
Version: 0.3.0
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A C++ application logging library
|
Summary: A C++ application logging library
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://code.google.com/p/google-glog
|
URL: http://code.google.com/p/google-glog
|
||||||
Source0: http://google-glog.googlecode.com/files/%{name}-%{version}.tar.gz
|
Source0: http://google-glog.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||||
Patch0: glog-r38.patch
|
|
||||||
Patch1: glog-gcc4.4.patch
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
@ -32,8 +30,6 @@ developing applications that use %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p0
|
|
||||||
%patch1 -p0
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoconf
|
autoconf
|
||||||
@ -65,11 +61,15 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc doc/designstyle.css doc/glog.html
|
%doc doc/designstyle.css doc/glog.html
|
||||||
%{_libdir}/libglog.so
|
%{_libdir}/libglog.so
|
||||||
|
%{_libdir}/pkgconfig/libglog.pc
|
||||||
%dir %{_includedir}/glog
|
%dir %{_includedir}/glog
|
||||||
%{_includedir}/glog/*
|
%{_includedir}/glog/*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 03 2009 John A. Khvatov <ivaxer@fedoraproject.org> - 0.3.0-1
|
||||||
|
- update to 0.3.0
|
||||||
|
|
||||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-6
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
@ -2,3 +2,4 @@ glog-0_1_2-6_fc10:HEAD:glog-0.1.2-6.fc10.src.rpm:1229343821
|
|||||||
glog-0_2-2_fc10:HEAD:glog-0.2-2.fc10.src.rpm:1232879474
|
glog-0_2-2_fc10:HEAD:glog-0.2-2.fc10.src.rpm:1232879474
|
||||||
glog-0_2-4_fc10:HEAD:glog-0.2-4.fc10.src.rpm:1235684646
|
glog-0_2-4_fc10:HEAD:glog-0.2-4.fc10.src.rpm:1235684646
|
||||||
glog-0_2-5_fc10:HEAD:glog-0.2-5.fc10.src.rpm:1235691384
|
glog-0_2-5_fc10:HEAD:glog-0.2-5.fc10.src.rpm:1235691384
|
||||||
|
glog-0_3_0-1_fc11:HEAD:glog-0.3.0-1.fc11.src.rpm:1249295950
|
||||||
|
Loading…
Reference in New Issue
Block a user