Added patch for compatibility with gflags >= 2.1.0.
This commit is contained in:
parent
374429bee2
commit
cc1b9fac43
71
glog-0.3.3-gflags-namespace.patch
Normal file
71
glog-0.3.3-gflags-namespace.patch
Normal file
@ -0,0 +1,71 @@
|
||||
diff -Naur glog-0.3.3/src/demangle_unittest.cc glog-0.3.3-patched/src/demangle_unittest.cc
|
||||
--- glog-0.3.3/src/demangle_unittest.cc 2012-01-11 04:14:17.000000000 -0500
|
||||
+++ glog-0.3.3-patched/src/demangle_unittest.cc 2014-04-24 12:13:53.967735046 -0400
|
||||
@@ -41,6 +41,11 @@
|
||||
#include "googletest.h"
|
||||
#include "config.h"
|
||||
|
||||
+#ifdef HAVE_LIB_GFLAGS
|
||||
+#include <gflags/gflags.h>
|
||||
+using namespace gflags;
|
||||
+#endif
|
||||
+
|
||||
GLOG_DEFINE_bool(demangle_filter, false,
|
||||
"Run demangle_unittest in filter mode");
|
||||
|
||||
diff -Naur glog-0.3.3/src/logging_unittest.cc glog-0.3.3-patched/src/logging_unittest.cc
|
||||
--- glog-0.3.3/src/logging_unittest.cc 2013-01-30 23:39:40.000000000 -0500
|
||||
+++ glog-0.3.3-patched/src/logging_unittest.cc 2014-04-24 12:12:11.977883984 -0400
|
||||
@@ -61,6 +61,7 @@
|
||||
|
||||
#ifdef HAVE_LIB_GFLAGS
|
||||
#include <gflags/gflags.h>
|
||||
+using namespace gflags;
|
||||
#endif
|
||||
|
||||
#ifdef HAVE_LIB_GMOCK
|
||||
diff -Naur glog-0.3.3/src/signalhandler_unittest.cc glog-0.3.3-patched/src/signalhandler_unittest.cc
|
||||
--- glog-0.3.3/src/signalhandler_unittest.cc 2012-01-11 04:14:17.000000000 -0500
|
||||
+++ glog-0.3.3-patched/src/signalhandler_unittest.cc 2014-04-24 12:15:14.976822615 -0400
|
||||
@@ -41,6 +41,11 @@
|
||||
#include <string>
|
||||
#include "glog/logging.h"
|
||||
|
||||
+#ifdef HAVE_LIB_GFLAGS
|
||||
+#include <gflags/gflags.h>
|
||||
+using namespace gflags;
|
||||
+#endif
|
||||
+
|
||||
using namespace GOOGLE_NAMESPACE;
|
||||
|
||||
void* DieInThread(void*) {
|
||||
diff -Naur glog-0.3.3/src/symbolize_unittest.cc glog-0.3.3-patched/src/symbolize_unittest.cc
|
||||
--- glog-0.3.3/src/symbolize_unittest.cc 2012-01-11 04:14:17.000000000 -0500
|
||||
+++ glog-0.3.3-patched/src/symbolize_unittest.cc 2014-04-24 12:14:18.077463477 -0400
|
||||
@@ -41,6 +41,11 @@
|
||||
#include "googletest.h"
|
||||
#include "config.h"
|
||||
|
||||
+#ifdef HAVE_LIB_GFLAGS
|
||||
+#include <gflags/gflags.h>
|
||||
+using namespace gflags;
|
||||
+#endif
|
||||
+
|
||||
using namespace std;
|
||||
using namespace GOOGLE_NAMESPACE;
|
||||
|
||||
diff -Naur glog-0.3.3/src/utilities_unittest.cc glog-0.3.3-patched/src/utilities_unittest.cc
|
||||
--- glog-0.3.3/src/utilities_unittest.cc 2012-01-11 04:14:17.000000000 -0500
|
||||
+++ glog-0.3.3-patched/src/utilities_unittest.cc 2014-04-24 12:14:54.963048001 -0400
|
||||
@@ -33,6 +33,11 @@
|
||||
#include "googletest.h"
|
||||
#include "glog/logging.h"
|
||||
|
||||
+#ifdef HAVE_LIB_GFLAGS
|
||||
+#include <gflags/gflags.h>
|
||||
+using namespace gflags;
|
||||
+#endif
|
||||
+
|
||||
using namespace GOOGLE_NAMESPACE;
|
||||
|
||||
TEST(utilities, sync_val_compare_and_swap) {
|
12
glog.spec
12
glog.spec
@ -1,6 +1,6 @@
|
||||
Name: glog
|
||||
Version: 0.3.3
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: A C++ application logging library
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -9,8 +9,10 @@ URL: http://code.google.com/p/google-glog
|
||||
Source0: http://google-glog.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
BuildRequires: autoconf
|
||||
#Requires:
|
||||
Patch0: glog-0.3.3-gflags-namespace.patch
|
||||
|
||||
BuildRequires: autoconf, gflags-devel >= 2.1.0
|
||||
Requires: gflags
|
||||
|
||||
%description
|
||||
Google glog is a library that implements application-level
|
||||
@ -30,6 +32,7 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -p1 -P 0
|
||||
|
||||
%build
|
||||
autoconf
|
||||
@ -68,6 +71,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Apr 24 2014 Dan Fuhry <dfuhry@dattobackup.com> - 0.3.3-4
|
||||
- Added patch for compatibility with gflags >= 2.1.0.
|
||||
|
||||
* Mon Aug 05 2013 John Khvatov <ivaxer@fedoraproject.org> - 0.3.3-3
|
||||
- Removed installed but untracked docs.
|
||||
Fix for https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
|
||||
|
Loading…
Reference in New Issue
Block a user