glog package is retired on c9s for CS-362
This commit is contained in:
parent
8a62c406d5
commit
52482c33b5
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,3 +0,0 @@
|
||||
glog-0.3.0.tar.gz
|
||||
/glog-0.3.3.tar.gz
|
||||
/glog-0.3.5.tar.gz
|
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
||||
glog package is retired on c9s for CS-362
|
@ -1,71 +0,0 @@
|
||||
diff -Naur glog-0.3.3/src/demangle_unittest.cc glog-0.3.3-patched/src/demangle_unittest.cc
|
||||
--- glog-0.3.3/src/demangle_unittest.cc 2012-01-11 04:14:17.000000000 -0500
|
||||
+++ glog-0.3.3-patched/src/demangle_unittest.cc 2014-04-24 12:13:53.967735046 -0400
|
||||
@@ -41,6 +41,11 @@
|
||||
#include "googletest.h"
|
||||
#include "config.h"
|
||||
|
||||
+#ifdef HAVE_LIB_GFLAGS
|
||||
+#include <gflags/gflags.h>
|
||||
+using namespace gflags;
|
||||
+#endif
|
||||
+
|
||||
GLOG_DEFINE_bool(demangle_filter, false,
|
||||
"Run demangle_unittest in filter mode");
|
||||
|
||||
diff -Naur glog-0.3.3/src/logging_unittest.cc glog-0.3.3-patched/src/logging_unittest.cc
|
||||
--- glog-0.3.3/src/logging_unittest.cc 2013-01-30 23:39:40.000000000 -0500
|
||||
+++ glog-0.3.3-patched/src/logging_unittest.cc 2014-04-24 12:12:11.977883984 -0400
|
||||
@@ -61,6 +61,7 @@
|
||||
|
||||
#ifdef HAVE_LIB_GFLAGS
|
||||
#include <gflags/gflags.h>
|
||||
+using namespace gflags;
|
||||
#endif
|
||||
|
||||
#ifdef HAVE_LIB_GMOCK
|
||||
diff -Naur glog-0.3.3/src/signalhandler_unittest.cc glog-0.3.3-patched/src/signalhandler_unittest.cc
|
||||
--- glog-0.3.3/src/signalhandler_unittest.cc 2012-01-11 04:14:17.000000000 -0500
|
||||
+++ glog-0.3.3-patched/src/signalhandler_unittest.cc 2014-04-24 12:15:14.976822615 -0400
|
||||
@@ -41,6 +41,11 @@
|
||||
#include <string>
|
||||
#include "glog/logging.h"
|
||||
|
||||
+#ifdef HAVE_LIB_GFLAGS
|
||||
+#include <gflags/gflags.h>
|
||||
+using namespace gflags;
|
||||
+#endif
|
||||
+
|
||||
using namespace GOOGLE_NAMESPACE;
|
||||
|
||||
void* DieInThread(void*) {
|
||||
diff -Naur glog-0.3.3/src/symbolize_unittest.cc glog-0.3.3-patched/src/symbolize_unittest.cc
|
||||
--- glog-0.3.3/src/symbolize_unittest.cc 2012-01-11 04:14:17.000000000 -0500
|
||||
+++ glog-0.3.3-patched/src/symbolize_unittest.cc 2014-04-24 12:14:18.077463477 -0400
|
||||
@@ -41,6 +41,11 @@
|
||||
#include "googletest.h"
|
||||
#include "config.h"
|
||||
|
||||
+#ifdef HAVE_LIB_GFLAGS
|
||||
+#include <gflags/gflags.h>
|
||||
+using namespace gflags;
|
||||
+#endif
|
||||
+
|
||||
using namespace std;
|
||||
using namespace GOOGLE_NAMESPACE;
|
||||
|
||||
diff -Naur glog-0.3.3/src/utilities_unittest.cc glog-0.3.3-patched/src/utilities_unittest.cc
|
||||
--- glog-0.3.3/src/utilities_unittest.cc 2012-01-11 04:14:17.000000000 -0500
|
||||
+++ glog-0.3.3-patched/src/utilities_unittest.cc 2014-04-24 12:14:54.963048001 -0400
|
||||
@@ -33,6 +33,11 @@
|
||||
#include "googletest.h"
|
||||
#include "glog/logging.h"
|
||||
|
||||
+#ifdef HAVE_LIB_GFLAGS
|
||||
+#include <gflags/gflags.h>
|
||||
+using namespace gflags;
|
||||
+#endif
|
||||
+
|
||||
using namespace GOOGLE_NAMESPACE;
|
||||
|
||||
TEST(utilities, sync_val_compare_and_swap) {
|
185
glog.spec
185
glog.spec
@ -1,185 +0,0 @@
|
||||
Name: glog
|
||||
Version: 0.3.5
|
||||
Release: 14%{?dist}
|
||||
Summary: A C++ application logging library
|
||||
License: BSD
|
||||
URL: https://github.com/google/glog
|
||||
Source0: https://github.com/google/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gcc
|
||||
BuildRequires: autoconf, gflags-devel >= 2.1.0
|
||||
BuildRequires: make
|
||||
Requires: gflags
|
||||
Requires: gflags-devel >= 2.1.0
|
||||
|
||||
%description
|
||||
Google glog is a library that implements application-level
|
||||
logging. This library provides logging APIs based on C++-style
|
||||
streams and various helper macros.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and header files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup
|
||||
|
||||
%build
|
||||
export CXXFLAGS="-std=c++14 $RPM_OPT_FLAGS"
|
||||
autoconf
|
||||
%configure --disable-static
|
||||
%make_build
|
||||
|
||||
%install
|
||||
%make_install
|
||||
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||
rm -rf $RPM_BUILD_ROOT/%{_docdir}/%{name}-%{version}
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%doc ChangeLog COPYING README
|
||||
%{_libdir}/libglog.so.*
|
||||
|
||||
%files devel
|
||||
%doc doc/designstyle.css doc/glog.html
|
||||
%{_libdir}/libglog.so
|
||||
%{_libdir}/pkgconfig/libglog.pc
|
||||
%dir %{_includedir}/glog
|
||||
%{_includedir}/glog/*
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 0.3.5-14
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-12
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Jeff Law <law@redhat.com> - 0.3.5-11
|
||||
- Force C++14 as this code is not C++17 ready
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Wed Oct 10 2018 Filipe Rosset <rosset.filipe@gmail.com> - 0.3.5-6
|
||||
- spec cleanup and modernization
|
||||
|
||||
* Wed Oct 10 2018 Sérgio Basto <sergio@serjux.com> - 0.3.5-5
|
||||
- Rebuit for gflags-2.2.1
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Sat Jul 29 2017 Filipe Rosset <rosset.filipe@gmail.com> - 0.3.5-1
|
||||
- Upgrade to latest 0.3.5 fix FTBFS rhbz #1423617 #1300053 and #1473570
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Jun 19 2017 Filipe Rosset <rosset.filipe@gmail.com> - 0.3.3-14
|
||||
- Spec cleanup
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Mar 25 2016 Björn Esser <fedora@besser82.io> - 0.3.3-12
|
||||
- Rebuilt for /lib64/libglog.so: undefined reference to
|
||||
'gflags::FlagRegisterer::FlagRegisterer'-madness
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.3-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.3.3-9
|
||||
- Rebuilt for GCC 5 C++11 ABI change
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.3-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.3-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu May 01 2014 John Khvatov <ivaxer@fedoraproject.org> - 0.3.3-6
|
||||
- Rebuild against gflags.so.2.1
|
||||
|
||||
* Thu Apr 24 2014 Dan Fuhry <dfuhry@dattobackup.com> - 0.3.3-4
|
||||
- Added patch for compatibility with gflags >= 2.1.0.
|
||||
|
||||
* Mon Aug 05 2013 John Khvatov <ivaxer@fedoraproject.org> - 0.3.3-3
|
||||
- Removed installed but untracked docs.
|
||||
Fix for https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Jul 31 2013 John Khvatov <ivaxer@fedoraproject.org> - 0.3.3-1
|
||||
- update to 0.3.3
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-4
|
||||
- Rebuilt for c++ ABI breakage
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Aug 03 2009 John A. Khvatov <ivaxer@fedoraproject.org> - 0.3.0-1
|
||||
- update to 0.3.0
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Fri Feb 27 2009 John A. Khvatov <ivaxer@fedoraproject.org> 0.2-5
|
||||
- fixes for gcc 4.4
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Sun Jan 25 2009 John A. Khvatov <ivaxer@fedoraproject.org> 0.2-2
|
||||
- update to 0.2
|
||||
|
||||
* Thu Dec 4 2008 John A. Khvatov <ivaxer@fedoraproject.org> 0.1.2-6
|
||||
- fix %%{_includedir}
|
||||
- fixed documentation
|
||||
|
||||
* Wed Dec 3 2008 John A. Khvatov <ivaxer@fedoraproject.org> 0.1.2-5
|
||||
- Added configure regeneration
|
||||
|
||||
* Tue Dec 2 2008 John A. Khvatov <ivaxer@fedoraproject.org> 0.1.2-4
|
||||
- Initial release
|
Loading…
Reference in New Issue
Block a user