Initial import

This commit is contained in:
John A. Khvatov 2008-12-15 12:28:02 +00:00
parent d9668f5051
commit 30f9a1260a
5 changed files with 196 additions and 0 deletions

View File

@ -0,0 +1 @@
glog-0.1.2.tar.gz

113
glog-lpthread.patch Normal file
View File

@ -0,0 +1,113 @@
Index: configure
===================================================================
--- configure (revision 20)
+++ configure (revision 21)
@@ -22818,7 +22818,80 @@
ac_compiler_gnu=$ac_cv_c_compiler_gnu
+# To make libglog depend on libpthread on Linux, we need to add
+# -lpthread in addition to -pthread.
+{ echo "$as_me:$LINENO: checking for pthread_self in -lpthread" >&5
+echo $ECHO_N "checking for pthread_self in -lpthread... $ECHO_C" >&6; }
+if test "${ac_cv_lib_pthread_pthread_self+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ ac_check_lib_save_LIBS=$LIBS
+LIBS="-lpthread $LIBS"
+cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char pthread_self ();
+int
+main ()
+{
+return pthread_self ();
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext conftest$ac_exeext
+if { (ac_try="$ac_link"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+ (eval "$ac_link") 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
+ test -z "$ac_c_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest$ac_exeext &&
+ $as_test_x conftest$ac_exeext; then
+ ac_cv_lib_pthread_pthread_self=yes
+else
+ echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+ ac_cv_lib_pthread_pthread_self=no
+fi
+
+rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
+ conftest$ac_exeext conftest.$ac_ext
+LIBS=$ac_check_lib_save_LIBS
+fi
+{ echo "$as_me:$LINENO: result: $ac_cv_lib_pthread_pthread_self" >&5
+echo "${ECHO_T}$ac_cv_lib_pthread_pthread_self" >&6; }
+if test $ac_cv_lib_pthread_pthread_self = yes; then
+ cat >>confdefs.h <<_ACEOF
+#define HAVE_LIBPTHREAD 1
+_ACEOF
+
+ LIBS="-lpthread $LIBS"
+
+fi
+
+
# Check if there is google-gflags library installed.
{ echo "$as_me:$LINENO: checking for main in -lgflags" >&5
echo $ECHO_N "checking for main in -lgflags... $ECHO_C" >&6; }
Index: src/config.h.in
===================================================================
--- src/config.h.in (revision 20)
+++ src/config.h.in (revision 21)
@@ -15,6 +15,9 @@
/* Define to 1 if you have the <inttypes.h> header file. */
#undef HAVE_INTTYPES_H
+/* Define to 1 if you have the `pthread' library (-lpthread). */
+#undef HAVE_LIBPTHREAD
+
/* Define to 1 if you have the <libunwind.h> header file. */
#undef HAVE_LIBUNWIND_H
Index: configure.ac
===================================================================
--- configure.ac (revision 20)
+++ configure.ac (revision 21)
@@ -83,6 +83,9 @@
# Some of the code in this directory depends on pthreads
ACX_PTHREAD
+# To make libglog depend on libpthread on Linux, we need to add
+# -lpthread in addition to -pthread.
+AC_CHECK_LIB(pthread, pthread_self)
# Check if there is google-gflags library installed.
AC_CHECK_LIB(gflags, main, ac_cv_have_libgflags=1, ac_cv_have_libgflags=0)

80
glog.spec Normal file
View File

@ -0,0 +1,80 @@
Name: glog
Version: 0.1.2
Release: 6%{?dist}
Summary: A C++ application logging library
Group: System Environment/Libraries
License: BSD
URL: http://code.google.com/p/google-glog
Source0: http://google-glog.googlecode.com/files/%{name}-%{version}.tar.gz
Patch0: glog-lpthread.patch
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires: autoconf
#Requires:
%description
Google glog is a library that implements application-level
logging. This library provides logging APIs based on C++-style
streams and various helper macros.
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%prep
%setup -q
%patch0 -p0
%build
autoconf
%configure --disable-static
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc ChangeLog COPYING README
%{_libdir}/libglog.so.*
%files devel
%defattr(-,root,root,-)
%doc doc/designstyle.css doc/glog.html
%{_libdir}/libglog.so
%dir %{_includedir}/glog
%{_includedir}/glog/*
%changelog
* Thu Dec 4 2008 John A. Khvatov <ivaxer@fedoraproject.org> 0.1.2-6
- fix %%{_includedir}
- fixed documentation
* Wed Dec 3 2008 John A. Khvatov <ivaxer@fedoraproject.org> 0.1.2-5
- Added configure regeneration
* Tue Dec 2 2008 John A. Khvatov <ivaxer@fedoraproject.org> 0.1.2-4
- Initial release

1
import.log Normal file
View File

@ -0,0 +1 @@
glog-0_1_2-6_fc10:HEAD:glog-0.1.2-6.fc10.src.rpm:1229343821

View File

@ -0,0 +1 @@
64b44e0a36b25c4afc77a0f6b2b208ed glog-0.1.2.tar.gz