Work around LRA hang on ppc64le (#1673018)
This commit is contained in:
parent
109c797f85
commit
123aebc7d4
17
glibc-rh1673018.patch
Normal file
17
glibc-rh1673018.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
Work around an LRA bug on ppc64le:
|
||||||
|
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1673018
|
||||||
|
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=89225
|
||||||
|
|
||||||
|
diff --git a/sysdeps/ieee754/ldbl-128ibm/Makefile b/sysdeps/ieee754/ldbl-128ibm/Makefile
|
||||||
|
index bdba6cc6b57e763e..54d12559f491d004 100644
|
||||||
|
--- a/sysdeps/ieee754/ldbl-128ibm/Makefile
|
||||||
|
+++ b/sysdeps/ieee754/ldbl-128ibm/Makefile
|
||||||
|
@@ -13,4 +13,7 @@ ifeq ($(subdir),math)
|
||||||
|
tests += test-fmodl-ldbl-128ibm test-remainderl-ldbl-128ibm \
|
||||||
|
test-remquol-ldbl-128ibm test-canonical-ldbl-128ibm \
|
||||||
|
test-totalorderl-ldbl-128ibm
|
||||||
|
+
|
||||||
|
+# Work around #1673018 (GCC PR 89225): LRA hang on ppc64le in GCC 9.0.
|
||||||
|
+CFLAGS-e_sqrtl.c += -fno-stack-protector
|
||||||
|
endif
|
@ -87,7 +87,7 @@
|
|||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: %{glibcversion}
|
Version: %{glibcversion}
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
|
|
||||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||||
# libraries.
|
# libraries.
|
||||||
@ -158,6 +158,7 @@ Patch18: glibc-c-utf8-locale.patch
|
|||||||
Patch23: glibc-python3.patch
|
Patch23: glibc-python3.patch
|
||||||
Patch28: glibc-rh1615608.patch
|
Patch28: glibc-rh1615608.patch
|
||||||
Patch29: glibc-rh1670028.patch
|
Patch29: glibc-rh1670028.patch
|
||||||
|
Patch30: glibc-rh1673018.patch
|
||||||
|
|
||||||
##############################################################################
|
##############################################################################
|
||||||
# Continued list of core "glibc" package information:
|
# Continued list of core "glibc" package information:
|
||||||
@ -1889,6 +1890,9 @@ fi
|
|||||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 7 2019 Florian Weimer <fweimer@redhat.com> - 2.29-4
|
||||||
|
- Work around LRA hang on ppc64le (#1673018)
|
||||||
|
|
||||||
* Wed Feb 06 2019 Florian Weimer <fweimer@redhat.com> - 2.29-3
|
* Wed Feb 06 2019 Florian Weimer <fweimer@redhat.com> - 2.29-3
|
||||||
- Auto-sync with upstream branch release/2.29/master,
|
- Auto-sync with upstream branch release/2.29/master,
|
||||||
commit 2de15ac95713a238dc258eb8977ecdfca811fc19:
|
commit 2de15ac95713a238dc258eb8977ecdfca811fc19:
|
||||||
|
Loading…
Reference in New Issue
Block a user