glibc/glibc-rh1673018.patch
2019-02-07 10:49:48 +01:00

18 lines
678 B
Diff

Work around an LRA bug on ppc64le:
https://bugzilla.redhat.com/show_bug.cgi?id=1673018
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=89225
diff --git a/sysdeps/ieee754/ldbl-128ibm/Makefile b/sysdeps/ieee754/ldbl-128ibm/Makefile
index bdba6cc6b57e763e..54d12559f491d004 100644
--- a/sysdeps/ieee754/ldbl-128ibm/Makefile
+++ b/sysdeps/ieee754/ldbl-128ibm/Makefile
@@ -13,4 +13,7 @@ ifeq ($(subdir),math)
tests += test-fmodl-ldbl-128ibm test-remainderl-ldbl-128ibm \
test-remquol-ldbl-128ibm test-canonical-ldbl-128ibm \
test-totalorderl-ldbl-128ibm
+
+# Work around #1673018 (GCC PR 89225): LRA hang on ppc64le in GCC 9.0.
+CFLAGS-e_sqrtl.c += -fno-stack-protector
endif