update to 2.27.0-rc2
Release notes: https://www.kernel.org/pub/software/scm/git/docs/RelNotes/2.27.0.txt
This commit is contained in:
parent
1a2db2d667
commit
e79e6b9e08
@ -1,48 +0,0 @@
|
||||
From a2df654cfa807d96932d43b6695791a3af90596a Mon Sep 17 00:00:00 2001
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Mon, 18 May 2020 20:06:23 -0400
|
||||
Subject: [PATCH] gitfaq: avoid validation error with older asciidoc
|
||||
|
||||
When building with asciidoc-8.4.5 (as found on CentOS/Red Hat 6), the
|
||||
period in the "[[files-in-.gitignore-are-tracked]]" anchor is not
|
||||
properly parsed as a section:
|
||||
|
||||
WARNING: gitfaq.txt: line 245: missing [[files-in-.gitignore-are-tracked]] section
|
||||
|
||||
The resulting XML file fails to validate with xmlto:
|
||||
|
||||
xmlto: /git/Documentation/gitfaq.xml does not validate (status 3)
|
||||
xmlto: Fix document syntax or use --skip-validation option
|
||||
/git/Documentation/gitfaq.xml:3: element refentry: validity error :
|
||||
Element refentry content does not follow the DTD, expecting
|
||||
(beginpage? , indexterm* , refentryinfo? , refmeta? , (remark | link
|
||||
| olink | ulink)* , refnamediv+ , refsynopsisdiv? , (refsect1+ |
|
||||
refsection+)), got (refmeta refnamediv refsynopsisdiv refsect1
|
||||
refsect1 refsect1 refsect1 variablelist refsect1 refsect1 )
|
||||
Document /git/Documentation/gitfaq.xml does not validate
|
||||
|
||||
Let's avoid breaking users of platforms which ship an old version of
|
||||
asciidoc, since the cost to do so is quite low.
|
||||
|
||||
Reported-by: Son Luong Ngoc <sluongng@gmail.com>
|
||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||
---
|
||||
Documentation/gitfaq.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Documentation/gitfaq.txt b/Documentation/gitfaq.txt
|
||||
index 370d62dae4..9cd7a592ac 100644
|
||||
--- a/Documentation/gitfaq.txt
|
||||
+++ b/Documentation/gitfaq.txt
|
||||
@@ -223,7 +223,7 @@ a file checked into the repository which is a template or set of defaults which
|
||||
can then be copied alongside and modified as appropriate. This second, modified
|
||||
file is usually ignored to prevent accidentally committing it.
|
||||
|
||||
-[[files-in-.gitignore-are-tracked]]
|
||||
+[[files-in-gitignore-are-tracked]]
|
||||
I asked Git to ignore various files, yet they are still tracked::
|
||||
A `gitignore` file ensures that certain file(s) which are not
|
||||
tracked by Git remain untracked. However, sometimes particular
|
||||
--
|
||||
2.26.1
|
||||
|
12
git.spec
12
git.spec
@ -86,11 +86,11 @@
|
||||
%endif
|
||||
|
||||
# Define for release candidates
|
||||
%global rcrev .rc1
|
||||
%global rcrev .rc2
|
||||
|
||||
Name: git
|
||||
Version: 2.27.0
|
||||
Release: 0.1%{?rcrev}%{?dist}
|
||||
Release: 0.2%{?rcrev}%{?dist}
|
||||
Summary: Fast Version Control System
|
||||
License: GPLv2
|
||||
URL: https://git-scm.com/
|
||||
@ -122,11 +122,6 @@ Source99: print-failed-test-output
|
||||
# https://bugzilla.redhat.com/490602
|
||||
Patch0: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||
|
||||
# Fix doc build on EL-6 with old asciidoc
|
||||
# https://lore.kernel.org/git/CAL3xRKdwOASiGys%2B7Uu_OA5kBPrTdAURfEw3UQ%2BrguTXT%2BC6JQ@mail.gmail.com/
|
||||
# https://lore.kernel.org/git/20200519045301.GY24220@pobox.com/
|
||||
Patch1: 0001-gitfaq-avoid-validation-error-with-older-asciidoc.patch
|
||||
|
||||
%if %{with docs}
|
||||
# pod2man is needed to build Git.3pm
|
||||
BuildRequires: %{_bindir}/pod2man
|
||||
@ -1063,6 +1058,9 @@ rmdir --ignore-fail-on-non-empty "$testdir"
|
||||
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
||||
|
||||
%changelog
|
||||
* Tue May 26 2020 Todd Zullinger <tmz@pobox.com> - 2.27.0-0.2.rc2
|
||||
- update to 2.27.0-rc2
|
||||
|
||||
* Thu May 21 2020 Todd Zullinger <tmz@pobox.com> - 2.27.0-0.1.rc1
|
||||
- update to 2.27.0-rc1
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (git-2.27.0.rc1.tar.xz) = 88a0f0895cea0b689c91962cab85d87914aebd43a83eff29aaeca160f45203767b54ab6f5c1c27982005aa7dfb14789efa6d6069833e09a874fac9a322ab9080
|
||||
SHA512 (git-2.27.0.rc1.tar.sign) = 66f19f27e5dd7e1f915af89034986f8ee339fdbf96f62c9858ff00fad5e9e6956078a2205e7cd27efefc071db001597007c8ec9af3d3a4cc5cca0183a47c6b70
|
||||
SHA512 (git-2.27.0.rc2.tar.xz) = 02cb439255c6861ec0fe17705539c97e80c4eab6671797039d65357cce4802fb11575036b96e0054ad6b75c4d730779cb59a2e1fb66261a9f02e75d091d38f4f
|
||||
SHA512 (git-2.27.0.rc2.tar.sign) = 2658ea642ac2962c81881dd68771cf0f65c87cce1a1cc48d337852d5522121532069e01951c72f0a02c908c8b93474be3a1996be56cce68f7b3ba70c90ebd82c
|
||||
|
Loading…
Reference in New Issue
Block a user