update to 2.27.0-rc1
Release notes: https://www.kernel.org/pub/software/scm/git/docs/RelNotes/2.27.0.txt
This commit is contained in:
parent
24de439725
commit
1a2db2d667
48
0001-gitfaq-avoid-validation-error-with-older-asciidoc.patch
Normal file
48
0001-gitfaq-avoid-validation-error-with-older-asciidoc.patch
Normal file
@ -0,0 +1,48 @@
|
||||
From a2df654cfa807d96932d43b6695791a3af90596a Mon Sep 17 00:00:00 2001
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Mon, 18 May 2020 20:06:23 -0400
|
||||
Subject: [PATCH] gitfaq: avoid validation error with older asciidoc
|
||||
|
||||
When building with asciidoc-8.4.5 (as found on CentOS/Red Hat 6), the
|
||||
period in the "[[files-in-.gitignore-are-tracked]]" anchor is not
|
||||
properly parsed as a section:
|
||||
|
||||
WARNING: gitfaq.txt: line 245: missing [[files-in-.gitignore-are-tracked]] section
|
||||
|
||||
The resulting XML file fails to validate with xmlto:
|
||||
|
||||
xmlto: /git/Documentation/gitfaq.xml does not validate (status 3)
|
||||
xmlto: Fix document syntax or use --skip-validation option
|
||||
/git/Documentation/gitfaq.xml:3: element refentry: validity error :
|
||||
Element refentry content does not follow the DTD, expecting
|
||||
(beginpage? , indexterm* , refentryinfo? , refmeta? , (remark | link
|
||||
| olink | ulink)* , refnamediv+ , refsynopsisdiv? , (refsect1+ |
|
||||
refsection+)), got (refmeta refnamediv refsynopsisdiv refsect1
|
||||
refsect1 refsect1 refsect1 variablelist refsect1 refsect1 )
|
||||
Document /git/Documentation/gitfaq.xml does not validate
|
||||
|
||||
Let's avoid breaking users of platforms which ship an old version of
|
||||
asciidoc, since the cost to do so is quite low.
|
||||
|
||||
Reported-by: Son Luong Ngoc <sluongng@gmail.com>
|
||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||
---
|
||||
Documentation/gitfaq.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Documentation/gitfaq.txt b/Documentation/gitfaq.txt
|
||||
index 370d62dae4..9cd7a592ac 100644
|
||||
--- a/Documentation/gitfaq.txt
|
||||
+++ b/Documentation/gitfaq.txt
|
||||
@@ -223,7 +223,7 @@ a file checked into the repository which is a template or set of defaults which
|
||||
can then be copied alongside and modified as appropriate. This second, modified
|
||||
file is usually ignored to prevent accidentally committing it.
|
||||
|
||||
-[[files-in-.gitignore-are-tracked]]
|
||||
+[[files-in-gitignore-are-tracked]]
|
||||
I asked Git to ignore various files, yet they are still tracked::
|
||||
A `gitignore` file ensures that certain file(s) which are not
|
||||
tracked by Git remain untracked. However, sometimes particular
|
||||
--
|
||||
2.26.1
|
||||
|
@ -1,58 +0,0 @@
|
||||
From 68e7090f31b4d4f2c7b9a25240af61149fbebb5c Mon Sep 17 00:00:00 2001
|
||||
From: Alban Gruin <alban.gruin@gmail.com>
|
||||
Date: Mon, 30 Mar 2020 14:42:35 +0200
|
||||
Subject: [PATCH 1/2] sequencer: don't abbreviate a command if it doesn't have
|
||||
a short form
|
||||
|
||||
When the sequencer is requested to abbreviate commands, it will replace
|
||||
those that do not have a short form (eg. `noop') by a comment mark.
|
||||
`noop' serves no purpose, except when fast-forwarding (ie. by running
|
||||
`git rebase'). Removing it will break this command when
|
||||
`rebase.abbreviateCommands' is set to true.
|
||||
|
||||
Teach todo_list_to_strbuf() to check if a command has an actual
|
||||
short form, and to ignore it if not.
|
||||
|
||||
Signed-off-by: Alban Gruin <alban.gruin@gmail.com>
|
||||
Signed-off-by: Junio C Hamano <gitster@pobox.com>
|
||||
---
|
||||
sequencer.c | 9 ++++++---
|
||||
1 file changed, 6 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/sequencer.c b/sequencer.c
|
||||
index e528225e78..c2f97f94ba 100644
|
||||
--- a/sequencer.c
|
||||
+++ b/sequencer.c
|
||||
@@ -1564,7 +1564,7 @@ static const char *command_to_string(const enum todo_command command)
|
||||
|
||||
static char command_to_char(const enum todo_command command)
|
||||
{
|
||||
- if (command < TODO_COMMENT && todo_command_info[command].c)
|
||||
+ if (command < TODO_COMMENT)
|
||||
return todo_command_info[command].c;
|
||||
return comment_line_char;
|
||||
}
|
||||
@@ -4947,6 +4947,8 @@ static void todo_list_to_strbuf(struct repository *r, struct todo_list *todo_lis
|
||||
max = num;
|
||||
|
||||
for (item = todo_list->items, i = 0; i < max; i++, item++) {
|
||||
+ char cmd;
|
||||
+
|
||||
/* if the item is not a command write it and continue */
|
||||
if (item->command >= TODO_COMMENT) {
|
||||
strbuf_addf(buf, "%.*s\n", item->arg_len,
|
||||
@@ -4955,8 +4957,9 @@ static void todo_list_to_strbuf(struct repository *r, struct todo_list *todo_lis
|
||||
}
|
||||
|
||||
/* add command to the buffer */
|
||||
- if (flags & TODO_LIST_ABBREVIATE_CMDS)
|
||||
- strbuf_addch(buf, command_to_char(item->command));
|
||||
+ cmd = command_to_char(item->command);
|
||||
+ if ((flags & TODO_LIST_ABBREVIATE_CMDS) && cmd)
|
||||
+ strbuf_addch(buf, cmd);
|
||||
else
|
||||
strbuf_addstr(buf, command_to_string(item->command));
|
||||
|
||||
--
|
||||
2.26.0
|
||||
|
@ -1,64 +0,0 @@
|
||||
From de9f1d3ef45ec885339d04f9e34293eb2de8605d Mon Sep 17 00:00:00 2001
|
||||
From: Alban Gruin <alban.gruin@gmail.com>
|
||||
Date: Mon, 30 Mar 2020 14:42:36 +0200
|
||||
Subject: [PATCH 2/2] t3432: test `--merge' with `rebase.abbreviateCommands =
|
||||
true', too
|
||||
|
||||
When fast forwarding, `git --merge' should act the same whether
|
||||
`rebase.abbreviateCommands' is set or not, but so far it was not the
|
||||
case. This duplicates the tests ensuring that `--merge' works when fast
|
||||
forwarding to check if it also works with abbreviated commands.
|
||||
|
||||
Signed-off-by: Alban Gruin <alban.gruin@gmail.com>
|
||||
Signed-off-by: Junio C Hamano <gitster@pobox.com>
|
||||
---
|
||||
t/t3432-rebase-fast-forward.sh | 24 +++++++++++++++++++-----
|
||||
1 file changed, 19 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/t/t3432-rebase-fast-forward.sh b/t/t3432-rebase-fast-forward.sh
|
||||
index 6c9d4a1375..6f0452c0ea 100755
|
||||
--- a/t/t3432-rebase-fast-forward.sh
|
||||
+++ b/t/t3432-rebase-fast-forward.sh
|
||||
@@ -28,10 +28,12 @@ test_rebase_same_head () {
|
||||
shift &&
|
||||
cmp_f="$1" &&
|
||||
shift &&
|
||||
- test_rebase_same_head_ $status_n $what_n $cmp_n " --apply" "$*" &&
|
||||
- test_rebase_same_head_ $status_f $what_f $cmp_f " --apply --no-ff" "$*"
|
||||
- test_rebase_same_head_ $status_n $what_n $cmp_n " --merge" "$*" &&
|
||||
- test_rebase_same_head_ $status_f $what_f $cmp_f " --merge --no-ff" "$*"
|
||||
+ test_rebase_same_head_ $status_n $what_n $cmp_n 0 " --apply" "$*" &&
|
||||
+ test_rebase_same_head_ $status_f $what_f $cmp_f 0 " --apply --no-ff" "$*"
|
||||
+ test_rebase_same_head_ $status_n $what_n $cmp_n 0 " --merge" "$*" &&
|
||||
+ test_rebase_same_head_ $status_f $what_f $cmp_f 0 " --merge --no-ff" "$*"
|
||||
+ test_rebase_same_head_ $status_n $what_n $cmp_n 1 " --merge" "$*" &&
|
||||
+ test_rebase_same_head_ $status_f $what_f $cmp_f 1 " --merge --no-ff" "$*"
|
||||
}
|
||||
|
||||
test_rebase_same_head_ () {
|
||||
@@ -41,9 +43,21 @@ test_rebase_same_head_ () {
|
||||
shift &&
|
||||
cmp="$1" &&
|
||||
shift &&
|
||||
+ abbreviate="$1" &&
|
||||
+ shift &&
|
||||
flag="$1"
|
||||
shift &&
|
||||
- test_expect_$status "git rebase$flag $* with $changes is $what with $cmp HEAD" "
|
||||
+ if test $abbreviate -eq 1
|
||||
+ then
|
||||
+ msg="git rebase$flag $* (rebase.abbreviateCommands = true) with $changes is $what with $cmp HEAD"
|
||||
+ else
|
||||
+ msg="git rebase$flag $* with $changes is $what with $cmp HEAD"
|
||||
+ fi &&
|
||||
+ test_expect_$status "$msg" "
|
||||
+ if test $abbreviate -eq 1
|
||||
+ then
|
||||
+ test_config rebase.abbreviateCommands true
|
||||
+ fi &&
|
||||
oldhead=\$(git rev-parse HEAD) &&
|
||||
test_when_finished 'git reset --hard \$oldhead' &&
|
||||
cp .git/logs/HEAD expect &&
|
||||
--
|
||||
2.26.0
|
||||
|
19
git.spec
19
git.spec
@ -86,11 +86,11 @@
|
||||
%endif
|
||||
|
||||
# Define for release candidates
|
||||
#global rcrev .rc0
|
||||
%global rcrev .rc1
|
||||
|
||||
Name: git
|
||||
Version: 2.26.2
|
||||
Release: 2%{?rcrev}%{?dist}
|
||||
Version: 2.27.0
|
||||
Release: 0.1%{?rcrev}%{?dist}
|
||||
Summary: Fast Version Control System
|
||||
License: GPLv2
|
||||
URL: https://git-scm.com/
|
||||
@ -122,12 +122,10 @@ Source99: print-failed-test-output
|
||||
# https://bugzilla.redhat.com/490602
|
||||
Patch0: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||
|
||||
# Fix issue with fast-forward rebases when rebase.abbreviateCommands is set
|
||||
# https://lore.kernel.org/git/9b4bc756764d87c9f34c11e6ec2fc6482f531805.camel@gmail.com/
|
||||
# https://github.com/git/git/commit/68e7090f31
|
||||
Patch1: 0001-sequencer-don-t-abbreviate-a-command-if-it-doesn-t-h.patch
|
||||
# https://github.com/git/git/commit/de9f1d3ef4
|
||||
Patch2: 0002-t3432-test-merge-with-rebase.abbreviateCommands-true.patch
|
||||
# Fix doc build on EL-6 with old asciidoc
|
||||
# https://lore.kernel.org/git/CAL3xRKdwOASiGys%2B7Uu_OA5kBPrTdAURfEw3UQ%2BrguTXT%2BC6JQ@mail.gmail.com/
|
||||
# https://lore.kernel.org/git/20200519045301.GY24220@pobox.com/
|
||||
Patch1: 0001-gitfaq-avoid-validation-error-with-older-asciidoc.patch
|
||||
|
||||
%if %{with docs}
|
||||
# pod2man is needed to build Git.3pm
|
||||
@ -1065,6 +1063,9 @@ rmdir --ignore-fail-on-non-empty "$testdir"
|
||||
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
||||
|
||||
%changelog
|
||||
* Thu May 21 2020 Todd Zullinger <tmz@pobox.com> - 2.27.0-0.1.rc1
|
||||
- update to 2.27.0-rc1
|
||||
|
||||
* Thu May 21 2020 Merlin Mathesius <mmathesi@redhat.com> - 2.26.2-2
|
||||
- Minor conditional fixes for ELN
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (git-2.26.2.tar.xz) = 5d92d07b171c5cd6e89a29c1211c73c1c900cd51c74d690aebfb4a3d0e93b541b09b42b6d6a1a82f5c3d953096771f9a8605c63be139f559f58698c1a0eabcfc
|
||||
SHA512 (git-2.26.2.tar.sign) = c53a607eda0bf83bf3593e8d68b833ef3ee99976434a97def5dcc25f31e79ff3e79f832b61508509d43d3111df106dde80ff6c9f7ada34ae53e7b4da17b06ed7
|
||||
SHA512 (git-2.27.0.rc1.tar.xz) = 88a0f0895cea0b689c91962cab85d87914aebd43a83eff29aaeca160f45203767b54ab6f5c1c27982005aa7dfb14789efa6d6069833e09a874fac9a322ab9080
|
||||
SHA512 (git-2.27.0.rc1.tar.sign) = 66f19f27e5dd7e1f915af89034986f8ee339fdbf96f62c9858ff00fad5e9e6956078a2205e7cd27efefc071db001597007c8ec9af3d3a4cc5cca0183a47c6b70
|
||||
|
Loading…
Reference in New Issue
Block a user