Minor Patch Update
This commit is contained in:
parent
6cca7cda6c
commit
2a0da651a7
@ -1,6 +1,6 @@
|
||||
diff -ur gettext-0.22.4.orig/configure.ac gettext-0.22.4/configure.ac
|
||||
--- gettext-0.22.4.orig/configure.ac 2022-10-09 08:05:42.000000000 +0530
|
||||
+++ gettext-0.22.4/configure.ac 2024-02-09 12:31:57.502525589 +0530
|
||||
+++ gettext-0.22.4/configure.ac 2024-02-13 12:47:32.099238869 +0530
|
||||
@@ -37,7 +37,7 @@
|
||||
|
||||
dnl Checks for library functions.
|
||||
@ -21,34 +21,21 @@ diff -ur gettext-0.22.4.orig/configure.ac gettext-0.22.4/configure.ac
|
||||
|
||||
diff -ur gettext-0.22.4.orig/gettext-tools/libgettextpo/textstyle.in.h gettext-0.22.4/gettext-tools/libgettextpo/textstyle.in.h
|
||||
--- gettext-0.22.4.orig/gettext-tools/libgettextpo/textstyle.in.h 2023-09-19 02:06:31.000000000 +0530
|
||||
+++ gettext-0.22.4/gettext-tools/libgettextpo/textstyle.in.h 2024-02-09 13:14:44.995080091 +0530
|
||||
@@ -255,7 +255,8 @@
|
||||
+++ gettext-0.22.4/gettext-tools/libgettextpo/textstyle.in.h 2024-02-13 13:04:15.238643775 +0530
|
||||
@@ -254,8 +254,9 @@
|
||||
|
||||
static inline file_ostream_t
|
||||
file_ostream_create (FILE *fp)
|
||||
{
|
||||
-{
|
||||
- return fp;
|
||||
+{
|
||||
+ /* Closing the stream we return should not close 'fp'. */
|
||||
+ return fdopen (dup (fileno (fp)), "w");
|
||||
}
|
||||
|
||||
static inline bool
|
||||
@@ -649,8 +650,8 @@
|
||||
|
||||
/* ----------------------- From noop-styled-ostream.h ----------------------- */
|
||||
|
||||
-typedef styled_ostream_t noop_styled_ostream_t;
|
||||
-
|
||||
+typedef ostream_t noop_styled_ostream_t;
|
||||
+
|
||||
#define noop_styled_ostream_write_mem ostream_write_mem
|
||||
#define noop_styled_ostream_flush ostream_flush
|
||||
#define noop_styled_ostream_free ostream_free
|
||||
@@ -673,13 +674,13 @@
|
||||
return true;
|
||||
}
|
||||
|
||||
-static inline noop_styled_ostream_t
|
||||
+static inline ostream_t
|
||||
@@ -676,10 +677,10 @@
|
||||
static inline noop_styled_ostream_t
|
||||
noop_styled_ostream_create (ostream_t destination, bool pass_ownership)
|
||||
{
|
||||
- if (!pass_ownership)
|
||||
@ -64,7 +51,7 @@ diff -ur gettext-0.22.4.orig/gettext-tools/libgettextpo/textstyle.in.h gettext-0
|
||||
static inline bool
|
||||
diff -ur gettext-0.22.4.orig/gettext-tools/Makefile.am gettext-0.22.4/gettext-tools/Makefile.am
|
||||
--- gettext-0.22.4.orig/gettext-tools/Makefile.am 2023-09-19 01:38:31.000000000 +0530
|
||||
+++ gettext-0.22.4/gettext-tools/Makefile.am 2024-02-09 12:32:57.710481641 +0530
|
||||
+++ gettext-0.22.4/gettext-tools/Makefile.am 2024-02-13 12:49:27.145661060 +0530
|
||||
@@ -19,7 +19,7 @@
|
||||
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
|
||||
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
|
||||
@ -76,7 +63,7 @@ diff -ur gettext-0.22.4.orig/gettext-tools/Makefile.am gettext-0.22.4/gettext-to
|
||||
MOSTLYCLEANFILES = core *.stackdump
|
||||
diff -ur gettext-0.22.4.orig/gettext-tools/src/Makefile.am gettext-0.22.4/gettext-tools/src/Makefile.am
|
||||
--- gettext-0.22.4.orig/gettext-tools/src/Makefile.am 2023-11-17 17:14:38.000000000 +0530
|
||||
+++ gettext-0.22.4/gettext-tools/src/Makefile.am 2024-02-09 12:35:40.445065728 +0530
|
||||
+++ gettext-0.22.4/gettext-tools/src/Makefile.am 2024-02-13 13:06:34.194367930 +0530
|
||||
@@ -311,19 +311,9 @@
|
||||
cldr_plurals_CFLAGS = $(AM_CFLAGS) $(INCXML)
|
||||
cldr_plurals_LDADD = libgettextsrc.la $(LDADD)
|
||||
@ -102,7 +89,7 @@ diff -ur gettext-0.22.4.orig/gettext-tools/src/Makefile.am gettext-0.22.4/gettex
|
||||
# Need ../gnulib-lib/libgettextlib.la.
|
||||
diff -ur gettext-0.22.4.orig/Makefile.am gettext-0.22.4/Makefile.am
|
||||
--- gettext-0.22.4.orig/Makefile.am 2023-11-17 17:39:11.000000000 +0530
|
||||
+++ gettext-0.22.4/Makefile.am 2024-02-09 12:29:57.994627891 +0530
|
||||
+++ gettext-0.22.4/Makefile.am 2024-02-13 12:44:18.309841774 +0530
|
||||
@@ -19,7 +19,7 @@
|
||||
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
|
Loading…
Reference in New Issue
Block a user