Update to 0.22.4 release

This commit is contained in:
matiwari 2024-02-09 15:03:46 +05:30
parent 0c9f023142
commit 6cca7cda6c
3 changed files with 86 additions and 81 deletions

View File

@ -1,27 +1,6 @@
diff -ur gettext-0.22.orig/Makefile.am gettext-0.22/Makefile.am
--- gettext-0.22.orig/Makefile.am 2023-06-23 17:44:45.388281215 +0800
+++ gettext-0.22/Makefile.am 2023-06-23 17:43:14.098701787 +0800
@@ -19,7 +19,7 @@
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = gnulib-local gettext-runtime libtextstyle gettext-tools
+SUBDIRS = gnulib-local gettext-runtime gettext-tools
changelog_etc = \
gettext-runtime/ChangeLog.0 \
@@ -87,7 +87,7 @@
cmp -s $(srcdir)/gettext-runtime/m4/xsize.m4 $(srcdir)/gettext-tools/gnulib-m4/xsize.m4
cmp -s $(srcdir)/gettext-runtime/man/help2man $(srcdir)/gettext-tools/man/help2man
cmp -s $(srcdir)/gettext-runtime/man/x-to-1.in $(srcdir)/gettext-tools/man/x-to-1.in
- cmp -s $(srcdir)/libtextstyle/m4/libtextstyle.m4 $(srcdir)/gettext-tools/gnulib-m4/libtextstyle.m4
+# cmp -s $(srcdir)/libtextstyle/m4/libtextstyle.m4 $(srcdir)/gettext-tools/gnulib-m4/libtextstyle.m4
cmp -s $(srcdir)/gettext-tools/examples/hello-java-awt/m4/TestAWT.java $(srcdir)/gettext-tools/examples/hello-java-swing/m4/TestAWT.java
cmp -s $(srcdir)/gettext-tools/examples/hello-java-awt/m4/TestAWT.class $(srcdir)/gettext-tools/examples/hello-java-swing/m4/TestAWT.class
# Verify that all files have appropriate copyright headers.
diff -ur gettext-0.22.orig/configure.ac gettext-0.22/configure.ac
--- gettext-0.22.orig/configure.ac 2020-09-06 18:01:37.000000000 +0800
+++ gettext-0.22/configure.ac 2023-06-23 17:43:14.099701793 +0800
diff -ur gettext-0.22.4.orig/configure.ac gettext-0.22.4/configure.ac
--- gettext-0.22.4.orig/configure.ac 2022-10-09 08:05:42.000000000 +0530
+++ gettext-0.22.4/configure.ac 2024-02-09 12:31:57.502525589 +0530
@@ -37,7 +37,7 @@
dnl Checks for library functions.
@ -40,9 +19,52 @@ diff -ur gettext-0.22.orig/configure.ac gettext-0.22/configure.ac
AC_CONFIG_FILES([Makefile])
diff -ur gettext-0.22.orig/gettext-tools/Makefile.am gettext-0.22/gettext-tools/Makefile.am
--- gettext-0.22.orig/gettext-tools/Makefile.am 2021-06-15 04:22:46.000000000 +0800
+++ gettext-0.22/gettext-tools/Makefile.am 2023-06-23 18:24:08.822906444 +0800
diff -ur gettext-0.22.4.orig/gettext-tools/libgettextpo/textstyle.in.h gettext-0.22.4/gettext-tools/libgettextpo/textstyle.in.h
--- gettext-0.22.4.orig/gettext-tools/libgettextpo/textstyle.in.h 2023-09-19 02:06:31.000000000 +0530
+++ gettext-0.22.4/gettext-tools/libgettextpo/textstyle.in.h 2024-02-09 13:14:44.995080091 +0530
@@ -255,7 +255,8 @@
static inline file_ostream_t
file_ostream_create (FILE *fp)
{
- return fp;
+ /* Closing the stream we return should not close 'fp'. */
+ return fdopen (dup (fileno (fp)), "w");
}
static inline bool
@@ -649,8 +650,8 @@
/* ----------------------- From noop-styled-ostream.h ----------------------- */
-typedef styled_ostream_t noop_styled_ostream_t;
-
+typedef ostream_t noop_styled_ostream_t;
+
#define noop_styled_ostream_write_mem ostream_write_mem
#define noop_styled_ostream_flush ostream_flush
#define noop_styled_ostream_free ostream_free
@@ -673,13 +674,13 @@
return true;
}
-static inline noop_styled_ostream_t
+static inline ostream_t
noop_styled_ostream_create (ostream_t destination, bool pass_ownership)
{
- if (!pass_ownership)
- /* Not supported without the real libtextstyle. */
- abort ();
- return destination;
+ if (pass_ownership)
+ return destination;
+ else
+ return fdopen (dup (fileno (destination)), "w");
}
static inline bool
diff -ur gettext-0.22.4.orig/gettext-tools/Makefile.am gettext-0.22.4/gettext-tools/Makefile.am
--- gettext-0.22.4.orig/gettext-tools/Makefile.am 2023-09-19 01:38:31.000000000 +0530
+++ gettext-0.22.4/gettext-tools/Makefile.am 2024-02-09 12:32:57.710481641 +0530
@@ -19,7 +19,7 @@
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
@ -52,54 +74,10 @@ diff -ur gettext-0.22.orig/gettext-tools/Makefile.am gettext-0.22/gettext-tools/
EXTRA_DIST = misc/DISCLAIM
MOSTLYCLEANFILES = core *.stackdump
diff -ur gettext-0.22.orig/gettext-tools/libgettextpo/textstyle.in.h gettext-0.22/gettext-tools/libgettextpo/textstyle.in.h
--- gettext-0.22.orig/gettext-tools/libgettextpo/textstyle.in.h 2023-05-19 12:20:56.000000000 +0800
+++ gettext-0.22/gettext-tools/libgettextpo/textstyle.in.h 2023-06-23 17:43:14.099701793 +0800
@@ -243,7 +243,8 @@
static inline file_ostream_t
file_ostream_create (FILE *fp)
{
- return fp;
+ /* Closing the stream we return should not close 'fp'. */
+ return fdopen (dup (fileno (fp)), "w");
}
/* --------------------------- From fd-ostream.h --------------------------- */
@@ -443,6 +444,30 @@
return NULL;
}
+/* ----------------------- From noop-styled-ostream.h ----------------------- */
+
+/* noop_styled_ostream_t is a subtype of ostream_t. */
+typedef ostream_t noop_styled_ostream_t;
+
+#define noop_styled_ostream_write_mem ostream_write_mem
+#define noop_styled_ostream_flush ostream_flush
+#define noop_styled_ostream_free ostream_free
+#define noop_styled_ostream_begin_use_class styled_ostream_begin_use_class
+#define noop_styled_ostream_end_use_class styled_ostream_end_use_class
+#define noop_styled_ostream_get_hyperlink_ref styled_ostream_get_hyperlink_ref
+#define noop_styled_ostream_get_hyperlink_id styled_ostream_get_hyperlink_id
+#define noop_styled_ostream_set_hyperlink styled_ostream_set_hyperlink
+#define noop_styled_ostream_flush_to_current_style styled_ostream_flush_to_current_style
+
+static inline ostream_t
+noop_styled_ostream_create (ostream_t destination, bool pass_ownership)
+{
+ if (pass_ownership)
+ return destination;
+ else
+ return fdopen (dup (fileno (destination)), "w");
+}
+
/* ------------------------------ From color.h ------------------------------ */
#define color_test_mode false
diff -ur gettext-0.22.orig/gettext-tools/src/Makefile.am gettext-0.22/gettext-tools/src/Makefile.am
--- gettext-0.22.orig/gettext-tools/src/Makefile.am 2023-06-09 05:03:36.000000000 +0800
+++ gettext-0.22/gettext-tools/src/Makefile.am 2023-06-23 17:43:14.099701793 +0800
@@ -305,19 +305,9 @@
diff -ur gettext-0.22.4.orig/gettext-tools/src/Makefile.am gettext-0.22.4/gettext-tools/src/Makefile.am
--- gettext-0.22.4.orig/gettext-tools/src/Makefile.am 2023-11-17 17:14:38.000000000 +0530
+++ gettext-0.22.4/gettext-tools/src/Makefile.am 2024-02-09 12:35:40.445065728 +0530
@@ -311,19 +311,9 @@
cldr_plurals_CFLAGS = $(AM_CFLAGS) $(INCXML)
cldr_plurals_LDADD = libgettextsrc.la $(LDADD)
@ -122,3 +100,24 @@ diff -ur gettext-0.22.orig/gettext-tools/src/Makefile.am gettext-0.22/gettext-to
# How to build libgettextsrc.la.
# Need ../gnulib-lib/libgettextlib.la.
diff -ur gettext-0.22.4.orig/Makefile.am gettext-0.22.4/Makefile.am
--- gettext-0.22.4.orig/Makefile.am 2023-11-17 17:39:11.000000000 +0530
+++ gettext-0.22.4/Makefile.am 2024-02-09 12:29:57.994627891 +0530
@@ -19,7 +19,7 @@
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = gnulib-local gettext-runtime libtextstyle gettext-tools
+SUBDIRS = gnulib-local gettext-runtime gettext-tools
changelog_etc = \
gettext-runtime/ChangeLog.0 \
@@ -87,7 +87,7 @@
cmp -s $(srcdir)/gettext-runtime/m4/xsize.m4 $(srcdir)/gettext-tools/gnulib-m4/xsize.m4
cmp -s $(srcdir)/gettext-runtime/man/help2man $(srcdir)/gettext-tools/man/help2man
cmp -s $(srcdir)/gettext-runtime/man/x-to-1.in $(srcdir)/gettext-tools/man/x-to-1.in
- cmp -s $(srcdir)/libtextstyle/m4/libtextstyle.m4 $(srcdir)/gettext-tools/gnulib-m4/libtextstyle.m4
+# cmp -s $(srcdir)/libtextstyle/m4/libtextstyle.m4 $(srcdir)/gettext-tools/gnulib-m4/libtextstyle.m4
cmp -s $(srcdir)/gettext-tools/examples/hello-java-awt/m4/TestAWT.java $(srcdir)/gettext-tools/examples/hello-java-swing/m4/TestAWT.java
cmp -s $(srcdir)/gettext-tools/examples/hello-java-awt/m4/TestAWT.class $(srcdir)/gettext-tools/examples/hello-java-swing/m4/TestAWT.class
# Verify that all files have appropriate copyright headers.

View File

@ -3,8 +3,8 @@
Summary: GNU tools and libraries for localized translated messages
Name: gettext
Version: 0.22
Release: 4%{?dist}
Version: 0.22.4
Release: 1%{?dist}
# The following are licensed under LGPLv2+:
# - libintl and its headers
@ -25,8 +25,8 @@ Source: https://ftp.gnu.org/pub/gnu/%{name}/%{name}-%{version}.tar.gz
Source2: msghack.py
Source3: msghack.1
Patch1: %{name}-%{version}-disable-libtextstyle.patch
Patch2: %{name}-0.21.1-covscan.patch
Patch1: gettext-0.22-disable-libtextstyle.patch
Patch2: gettext-0.21.1-covscan.patch
# for bootstrapping
# BuildRequires: autoconf >= 2.62
@ -175,7 +175,9 @@ Substitutes the values of environment variables.
%prep
%autosetup -p1
%setup -q
%patch 1 -p1 -b .orig~
%patch 2 -p1 -b .orig~
# patch 1
automake
@ -411,6 +413,10 @@ make check LIBUNISTRING=-lunistring
%{_mandir}/man1/msghack.1*
%changelog
* Fri Feb 9 2024 Manish Tiwari <matiwari@redhat.com> - 0.22.4-1
- update to 0.22.4 release
- https://savannah.gnu.org/news/?id=10544
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.22-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (gettext-0.22.tar.gz) = e2a58dde1cae3e6b79c03e7ef3d888f7577c1f4cba283b3b0f31123ceea8c33d7c9700e83de57104644de23e5f5c374868caa0e091f9c45edbbe87b98ee51c04
SHA512 (gettext-0.22.4.tar.gz) = ad2fa2f69be996a637e9b51e8941a39e10050060245dcec1fe75c15b68d0ff973043c87b77e4e2830e407e3bdd040b578f8e24fd05bba43adb94eaee34001aa5