- Update to 2.21.9
This commit is contained in:
parent
9fd5ac9acf
commit
347db692a8
@ -1,31 +0,0 @@
|
||||
--- gdm-2.21.9/gui/simple-greeter/gdm-chooser-widget.c (revision 5978)
|
||||
+++ gdm-2.21.9/gui/simple-greeter/gdm-chooser-widget.c (working copy)
|
||||
@@ -82,6 +82,7 @@ struct GdmChooserWidgetPrivate
|
||||
gint number_of_separated_rows;
|
||||
gint number_of_rows_with_status;
|
||||
gint number_of_rows_with_images;
|
||||
+ gint number_of_active_timers;
|
||||
|
||||
guint update_idle_id;
|
||||
guint animation_timeout_id;
|
||||
@@ -2034,6 +2035,7 @@ start_timer (GdmChooserWidget *widget
|
||||
gtk_list_store_set (widget->priv->list_store, &iter,
|
||||
CHOOSER_TIMER_VALUE_COLUMN, 0.0, -1);
|
||||
|
||||
+ widget->priv->number_of_active_timers++;
|
||||
if (widget->priv->timer_animation_timeout_id == 0) {
|
||||
g_assert (g_hash_table_size (widget->priv->rows_with_timers) == 1);
|
||||
|
||||
@@ -2067,6 +2069,12 @@ stop_timer (GdmChooserWidget *widget,
|
||||
0.0, -1);
|
||||
gtk_list_store_set (widget->priv->list_store, &iter,
|
||||
CHOOSER_TIMER_VALUE_COLUMN, 0.0, -1);
|
||||
+
|
||||
+ widget->priv->number_of_active_timers--;
|
||||
+ if (widget->priv->number_of_active_timers == 0) {
|
||||
+ g_source_remove (widget->priv->timer_animation_timeout_id);
|
||||
+ widget->priv->timer_animation_timeout_id = 0;
|
||||
+ }
|
||||
}
|
||||
|
||||
static void
|
@ -1,25 +0,0 @@
|
||||
--- gdm-2.21.9/common/gdm-signal-handler.c~ 2008-02-04 21:20:41.000000000 +0000
|
||||
+++ gdm-2.21.9/common/gdm-signal-handler.c 2008-03-06 15:41:46.000000000 +0000
|
||||
@@ -220,6 +220,7 @@ signal_handler (int signo)
|
||||
{
|
||||
static int in_fatal = 0;
|
||||
int ignore;
|
||||
+ guchar signo_byte = signo;
|
||||
|
||||
/* avoid loops */
|
||||
if (in_fatal > 0) {
|
||||
@@ -244,12 +245,12 @@ signal_handler (int signo)
|
||||
|
||||
g_warning ("Caught signal %d, shutting down abnormally. Generating backtrace...", signo);
|
||||
gdm_signal_handler_backtrace ();
|
||||
- ignore = write (signal_pipes [1], (guchar *)&signo, 1);
|
||||
+ ignore = write (signal_pipes [1], &signo_byte, 1);
|
||||
break;
|
||||
default:
|
||||
--in_fatal;
|
||||
/* FIXME: should probably use int32 here */
|
||||
- ignore = write (signal_pipes [1], (guchar *)&signo, 1);
|
||||
+ ignore = write (signal_pipes [1], &signo_byte, 1);
|
||||
break;
|
||||
}
|
||||
}
|
21
gdm.spec
21
gdm.spec
@ -4,9 +4,6 @@
|
||||
%define gtk2_version 2.6.0
|
||||
%define libglade2_version 2.0.0
|
||||
%define libgnomeui_version 2.2.0
|
||||
%define libgnomecanvas_version 2.0.0
|
||||
%define librsvg2_version 2.0.1
|
||||
%define libxml2_version 2.4.21
|
||||
%define scrollkeeper_version 0.3.4
|
||||
%define pam_version 0.99.8.1-11
|
||||
%define desktop_file_utils_version 0.2.90
|
||||
@ -19,7 +16,7 @@
|
||||
Summary: The GNOME Display Manager
|
||||
Name: gdm
|
||||
Version: 2.21.9
|
||||
Release: 0.2008.03.10.2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv2+
|
||||
Group: User Interface/X
|
||||
@ -35,11 +32,7 @@ Prereq: /usr/sbin/useradd
|
||||
Requires: gtk2 >= 0:%{gtk2_version}
|
||||
Requires: libglade2 >= 0:%{libglade2_version}
|
||||
Requires: libgnomeui >= 0:%{libgnomeui_version}
|
||||
Requires: libgnomecanvas >= 0:%{libgnomecanvas_version}
|
||||
Requires: librsvg2 >= 0:%{librsvg2_version}
|
||||
Requires: libxml2 >= 0:%{libxml2_version}
|
||||
Requires: pam >= 0:%{pam_version}
|
||||
Requires: usermode
|
||||
Requires: /sbin/nologin
|
||||
Requires: system-logos
|
||||
Requires: fedorainfinity-gdm-theme
|
||||
@ -50,6 +43,7 @@ Requires: hal >= %{hal_version}
|
||||
Requires: ConsoleKit >= %{consolekit_version}
|
||||
Requires: PolicyKit-gnome >= %{polkit_version}
|
||||
Requires: gnome-settings-daemon >= 2.21.92
|
||||
Requires: iso-codes
|
||||
# since we use it, and pam spams the log if the module is missing
|
||||
Requires: gnome-keyring-pam
|
||||
Requires(post): scrollkeeper
|
||||
@ -59,17 +53,11 @@ BuildRequires: pango-devel >= 0:%{pango_version}
|
||||
BuildRequires: gtk2-devel >= 0:%{gtk2_version}
|
||||
BuildRequires: libglade2-devel >= 0:%{libglade2_version}
|
||||
BuildRequires: libgnomeui-devel >= 0:%{libgnomeui_version}
|
||||
BuildRequires: libgnomecanvas-devel >= 0:%{libgnomecanvas_version}
|
||||
BuildRequires: librsvg2-devel >= 0:%{librsvg2_version}
|
||||
BuildRequires: libxml2-devel >= 0:%{libxml2_version}
|
||||
BuildRequires: usermode
|
||||
BuildRequires: pam-devel >= 0:%{pam_version}
|
||||
BuildRequires: fontconfig
|
||||
BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
|
||||
BuildRequires: gail-devel >= 0:%{gail_version}
|
||||
BuildRequires: libgsf-devel
|
||||
BuildRequires: libtool automake autoconf
|
||||
BuildRequires: libcroco-devel
|
||||
BuildRequires: libattr-devel
|
||||
BuildRequires: gettext
|
||||
BuildRequires: gnome-doc-utils
|
||||
@ -89,7 +77,6 @@ BuildRequires: gnome-panel-devel
|
||||
|
||||
Requires: audit-libs >= %{libauditver}
|
||||
|
||||
Patch0: gdm-2.21.9-prevent-some-spurious-wakeups.patch
|
||||
Patch99: gdm-2.21.8-fedora-logo.patch
|
||||
|
||||
%package user-switch-applet
|
||||
@ -110,7 +97,6 @@ multiple simulanteous logged in users.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .prevent-some-spurious-wakeups
|
||||
%patch99 -p1 -b .fedora-logo
|
||||
|
||||
%build
|
||||
@ -304,6 +290,9 @@ fi
|
||||
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
||||
|
||||
%changelog
|
||||
* Mon Mar 10 2008 Jon McCann <jmccann@redhat.com> - 1:2.21.9-1
|
||||
- Update to 2.21.9
|
||||
|
||||
* Mon Mar 10 2008 Ray Strode <rstrode@redhat.com> - 1:2.21.9-0.2008.03.10.2
|
||||
- Prevent some spurious wake ups caused by the
|
||||
timed login timer animation
|
||||
|
@ -1,110 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
gdmwhich () {
|
||||
COMMAND="$1"
|
||||
OUTPUT=
|
||||
IFS=:
|
||||
for dir in $PATH
|
||||
do
|
||||
if test -x "$dir/$COMMAND" ; then
|
||||
if test "x$OUTPUT" = "x" ; then
|
||||
OUTPUT="$dir/$COMMAND"
|
||||
fi
|
||||
fi
|
||||
done
|
||||
IFS=$OLD_IFS
|
||||
echo "$OUTPUT"
|
||||
}
|
||||
|
||||
echo
|
||||
echo "GDM Theme Tester"
|
||||
echo
|
||||
echo "Be sure to test all the environments:"
|
||||
echo " console, console-timed, flexi, remote-flexi, xdmcp"
|
||||
echo "Also be sure to test using caps lock"
|
||||
echo
|
||||
|
||||
XNEST=`gdmwhich Xnest`
|
||||
GDMXNEST=`gdmwhich gdmXnest`
|
||||
GDMGREETER="@libexecdir@/gdmgreeter"
|
||||
|
||||
if [ x$XNEST = x ]; then
|
||||
echo "ERROR: Xnest not found"
|
||||
echo ""
|
||||
exit 1
|
||||
fi
|
||||
|
||||
if [ x$GDMXNEST = x ]; then
|
||||
echo "ERROR: gdmXnest not found"
|
||||
echo ""
|
||||
exit 1
|
||||
fi
|
||||
|
||||
if [ x$GDMGREETER = x ]; then
|
||||
echo "ERROR: gdmgreeter not found"
|
||||
echo ""
|
||||
exit 1
|
||||
fi
|
||||
|
||||
USAGE="
|
||||
Usage: $0 <environment> <theme>
|
||||
<environment> is one of: console, console-timed, flexi, remote-flexi, xdmcp
|
||||
<theme> is either the path of the theme or the name of an installed theme
|
||||
|
||||
If you set the environment variable XNESTSIZE to <width>x<height> (e.g. 800x600)
|
||||
you can test the greeter at that resolution
|
||||
"
|
||||
if [ "$#" != 2 ]; then
|
||||
echo "$USAGE"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
GDM_THEME="$2"
|
||||
DOING_GDM_DEVELOPMENT=yes
|
||||
GDM_PARENT_DISPLAY="$DISPLAY"
|
||||
export GDM_THEME DOING_GDM_DEVELOPMENT GDM_PARENT_DISPLAY
|
||||
|
||||
case $1 in
|
||||
console)
|
||||
GDM_IS_LOCAL=yes
|
||||
export GDM_IS_LOCAL
|
||||
;;
|
||||
console-timed)
|
||||
GDM_IS_LOCAL=yes
|
||||
GDM_FAKE_TIMED=yes
|
||||
export GDM_IS_LOCAL GDM_FAKE_TIMED
|
||||
;;
|
||||
flexi)
|
||||
GDM_IS_LOCAL=yes
|
||||
GDM_FLEXI_SERVER=yes
|
||||
export GDM_IS_LOCAL GDM_FLEXI_SERVER
|
||||
;;
|
||||
remote-flexi)
|
||||
GDM_FLEXI_SERVER=yes
|
||||
export GDM_FLEXI_SERVER
|
||||
;;
|
||||
xdmcp)
|
||||
;;
|
||||
*)
|
||||
echo "$USAGE"
|
||||
exit 1
|
||||
;;
|
||||
esac
|
||||
|
||||
if [ "x$XNESTSIZE" = x ] ; then
|
||||
eval `gdmXnest -b`
|
||||
else
|
||||
eval `gdmXnest -b -o "-geometry $XNESTSIZE"`
|
||||
fi
|
||||
export DISPLAY
|
||||
|
||||
if [ "x$GDM_PARENT_DISPLAY" = "x$DISPLAY" ]; then
|
||||
echo "ERROR: Can't start the Xnest server"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
# This may not be necessary
|
||||
sleep 1
|
||||
|
||||
@libexecdir@/gdmgreeter
|
||||
|
Loading…
Reference in New Issue
Block a user