- Prevent some spurious wake ups caused by the timed login timer animation
This commit is contained in:
parent
979d2a989f
commit
9fd5ac9acf
31
gdm-2.21.9-prevent-some-spurious-wakeups.patch
Normal file
31
gdm-2.21.9-prevent-some-spurious-wakeups.patch
Normal file
@ -0,0 +1,31 @@
|
||||
--- gdm-2.21.9/gui/simple-greeter/gdm-chooser-widget.c (revision 5978)
|
||||
+++ gdm-2.21.9/gui/simple-greeter/gdm-chooser-widget.c (working copy)
|
||||
@@ -82,6 +82,7 @@ struct GdmChooserWidgetPrivate
|
||||
gint number_of_separated_rows;
|
||||
gint number_of_rows_with_status;
|
||||
gint number_of_rows_with_images;
|
||||
+ gint number_of_active_timers;
|
||||
|
||||
guint update_idle_id;
|
||||
guint animation_timeout_id;
|
||||
@@ -2034,6 +2035,7 @@ start_timer (GdmChooserWidget *widget
|
||||
gtk_list_store_set (widget->priv->list_store, &iter,
|
||||
CHOOSER_TIMER_VALUE_COLUMN, 0.0, -1);
|
||||
|
||||
+ widget->priv->number_of_active_timers++;
|
||||
if (widget->priv->timer_animation_timeout_id == 0) {
|
||||
g_assert (g_hash_table_size (widget->priv->rows_with_timers) == 1);
|
||||
|
||||
@@ -2067,6 +2069,12 @@ stop_timer (GdmChooserWidget *widget,
|
||||
0.0, -1);
|
||||
gtk_list_store_set (widget->priv->list_store, &iter,
|
||||
CHOOSER_TIMER_VALUE_COLUMN, 0.0, -1);
|
||||
+
|
||||
+ widget->priv->number_of_active_timers--;
|
||||
+ if (widget->priv->number_of_active_timers == 0) {
|
||||
+ g_source_remove (widget->priv->timer_animation_timeout_id);
|
||||
+ widget->priv->timer_animation_timeout_id = 0;
|
||||
+ }
|
||||
}
|
||||
|
||||
static void
|
8
gdm.spec
8
gdm.spec
@ -19,7 +19,7 @@
|
||||
Summary: The GNOME Display Manager
|
||||
Name: gdm
|
||||
Version: 2.21.9
|
||||
Release: 0.2008.03.10.1%{?dist}
|
||||
Release: 0.2008.03.10.2%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv2+
|
||||
Group: User Interface/X
|
||||
@ -89,6 +89,7 @@ BuildRequires: gnome-panel-devel
|
||||
|
||||
Requires: audit-libs >= %{libauditver}
|
||||
|
||||
Patch0: gdm-2.21.9-prevent-some-spurious-wakeups.patch
|
||||
Patch99: gdm-2.21.8-fedora-logo.patch
|
||||
|
||||
%package user-switch-applet
|
||||
@ -109,6 +110,7 @@ multiple simulanteous logged in users.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .prevent-some-spurious-wakeups
|
||||
%patch99 -p1 -b .fedora-logo
|
||||
|
||||
%build
|
||||
@ -302,6 +304,10 @@ fi
|
||||
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
||||
|
||||
%changelog
|
||||
* Mon Mar 10 2008 Ray Strode <rstrode@redhat.com> - 1:2.21.9-0.2008.03.10.2
|
||||
- Prevent some spurious wake ups caused by the
|
||||
timed login timer animation
|
||||
|
||||
* Mon Mar 10 2008 Ray Strode <rstrode@redhat.com> - 1:2.21.9-0.2008.03.10.1
|
||||
- Update to latest snapshot
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user