- Fix patch fuzz 0.
This commit is contained in:
parent
a97b573f83
commit
f340c03820
@ -7,20 +7,19 @@ https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=190810
|
||||
(remote_async_wait): Likewise.
|
||||
|
||||
|
||||
Index: gdb-6.8.50.20081128/gdb/remote.c
|
||||
Index: gdb-6.8.50.20090818/gdb/remote.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20081128.orig/gdb/remote.c 2008-12-09 16:59:51.000000000 +0100
|
||||
+++ gdb-6.8.50.20081128/gdb/remote.c 2008-12-09 17:00:04.000000000 +0100
|
||||
@@ -4329,8 +4329,13 @@ Packet: '%s'\n"),
|
||||
--- gdb-6.8.50.20090818.orig/gdb/remote.c 2009-08-18 21:00:35.000000000 +0200
|
||||
+++ gdb-6.8.50.20090818/gdb/remote.c 2009-08-18 21:04:46.000000000 +0200
|
||||
@@ -4408,8 +4408,13 @@ Packet: '%s'\n"),
|
||||
VEC_safe_push (cached_reg_t, event->regcache, &cached_reg);
|
||||
}
|
||||
|
||||
- if (*p != ';')
|
||||
- error (_("Remote register badly formatted: %s\nhere: %s"),
|
||||
+ /* It may also occur on amd64 which defaults to 32-bit i386
|
||||
+ target. gdbserver(1) is not aware of the `set architecture'
|
||||
+ name itself as it is not using libbfd. */
|
||||
+ if (*p != ';')
|
||||
if (*p != ';')
|
||||
- error (_("Remote register badly formatted: %s\nhere: %s"),
|
||||
+ error (_("Remote register badly formatted: %s\nhere: %s"
|
||||
+ "\nTry to load the executable by `file' first,"
|
||||
+ "\nyou may also check `set/show architecture'."),
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: gdb-6.8.50.20090809/gdb/corelow.c
|
||||
Index: gdb-6.8.50.20090818/gdb/corelow.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090809.orig/gdb/corelow.c 2009-07-31 17:25:21.000000000 +0200
|
||||
+++ gdb-6.8.50.20090809/gdb/corelow.c 2009-08-10 14:56:11.000000000 +0200
|
||||
--- gdb-6.8.50.20090818.orig/gdb/corelow.c 2009-07-31 17:25:21.000000000 +0200
|
||||
+++ gdb-6.8.50.20090818/gdb/corelow.c 2009-08-18 21:07:23.000000000 +0200
|
||||
@@ -45,6 +45,10 @@
|
||||
#include "exceptions.h"
|
||||
#include "solib.h"
|
||||
@ -89,10 +89,10 @@ Index: gdb-6.8.50.20090809/gdb/corelow.c
|
||||
+ NULL, NULL, NULL,
|
||||
+ &setlist, &showlist);
|
||||
}
|
||||
Index: gdb-6.8.50.20090809/gdb/doc/gdb.texinfo
|
||||
Index: gdb-6.8.50.20090818/gdb/doc/gdb.texinfo
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090809.orig/gdb/doc/gdb.texinfo 2009-08-10 00:50:30.000000000 +0200
|
||||
+++ gdb-6.8.50.20090809/gdb/doc/gdb.texinfo 2009-08-10 14:56:11.000000000 +0200
|
||||
--- gdb-6.8.50.20090818.orig/gdb/doc/gdb.texinfo 2009-08-18 21:07:05.000000000 +0200
|
||||
+++ gdb-6.8.50.20090818/gdb/doc/gdb.texinfo 2009-08-18 21:07:23.000000000 +0200
|
||||
@@ -13733,6 +13733,27 @@ information files.
|
||||
|
||||
@end table
|
||||
@ -121,10 +121,10 @@ Index: gdb-6.8.50.20090809/gdb/doc/gdb.texinfo
|
||||
@cindex @code{.gnu_debuglink} sections
|
||||
@cindex debug link sections
|
||||
A debug link is a special section of the executable file named
|
||||
Index: gdb-6.8.50.20090809/gdb/solib-svr4.c
|
||||
Index: gdb-6.8.50.20090818/gdb/solib-svr4.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090809.orig/gdb/solib-svr4.c 2009-08-10 00:50:30.000000000 +0200
|
||||
+++ gdb-6.8.50.20090809/gdb/solib-svr4.c 2009-08-10 14:56:11.000000000 +0200
|
||||
--- gdb-6.8.50.20090818.orig/gdb/solib-svr4.c 2009-08-18 21:07:04.000000000 +0200
|
||||
+++ gdb-6.8.50.20090818/gdb/solib-svr4.c 2009-08-18 21:07:23.000000000 +0200
|
||||
@@ -1101,9 +1101,33 @@ svr4_current_sos (void)
|
||||
safe_strerror (errcode));
|
||||
else
|
||||
@ -162,11 +162,11 @@ Index: gdb-6.8.50.20090809/gdb/solib-svr4.c
|
||||
}
|
||||
xfree (buffer);
|
||||
|
||||
Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
Index: gdb-6.8.50.20090818/gdb/symfile.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090809.orig/gdb/symfile.c 2009-08-10 00:50:30.000000000 +0200
|
||||
+++ gdb-6.8.50.20090809/gdb/symfile.c 2009-08-10 14:58:53.000000000 +0200
|
||||
@@ -55,6 +55,7 @@
|
||||
--- gdb-6.8.50.20090818.orig/gdb/symfile.c 2009-08-18 21:07:05.000000000 +0200
|
||||
+++ gdb-6.8.50.20090818/gdb/symfile.c 2009-08-18 21:08:31.000000000 +0200
|
||||
@@ -56,6 +56,7 @@
|
||||
#include "elf-bfd.h"
|
||||
#include "solib.h"
|
||||
#include "remote.h"
|
||||
@ -174,7 +174,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <fcntl.h>
|
||||
@@ -1195,16 +1196,65 @@ symbol_file_clear (int from_tty)
|
||||
@@ -1193,16 +1194,65 @@ symbol_file_clear (int from_tty)
|
||||
printf_unfiltered (_("No symbol file now.\n"));
|
||||
}
|
||||
|
||||
@ -242,7 +242,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
{
|
||||
struct build_id *retval;
|
||||
|
||||
@@ -1220,6 +1270,348 @@ build_id_bfd_get (bfd *abfd)
|
||||
@@ -1218,6 +1268,348 @@ build_id_bfd_get (bfd *abfd)
|
||||
return retval;
|
||||
}
|
||||
|
||||
@ -591,7 +591,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
/* Return if FILENAME has NT_GNU_BUILD_ID matching the CHECK value. */
|
||||
|
||||
static int
|
||||
@@ -1237,7 +1629,7 @@ build_id_verify (const char *filename, s
|
||||
@@ -1235,7 +1627,7 @@ build_id_verify (const char *filename, s
|
||||
if (abfd == NULL)
|
||||
return 0;
|
||||
|
||||
@ -600,7 +600,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
|
||||
if (found == NULL)
|
||||
warning (_("File \"%s\" has no build-id, file skipped"), filename);
|
||||
@@ -1256,8 +1648,9 @@ build_id_verify (const char *filename, s
|
||||
@@ -1254,8 +1646,9 @@ build_id_verify (const char *filename, s
|
||||
return retval;
|
||||
}
|
||||
|
||||
@ -612,7 +612,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
{
|
||||
char *link, *s, *retval = NULL;
|
||||
gdb_byte *data = build_id->data;
|
||||
@@ -1265,7 +1658,9 @@ build_id_to_debug_filename (struct build
|
||||
@@ -1263,7 +1656,9 @@ build_id_to_debug_filename (struct build
|
||||
|
||||
/* DEBUG_FILE_DIRECTORY/.build-id/ab/cdef */
|
||||
link = xmalloc (strlen (debug_file_directory) + (sizeof "/.build-id/" - 1) + 1
|
||||
@ -623,7 +623,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
s = link + sprintf (link, "%s/.build-id/", debug_file_directory);
|
||||
if (size > 0)
|
||||
{
|
||||
@@ -1276,12 +1671,14 @@ build_id_to_debug_filename (struct build
|
||||
@@ -1274,12 +1669,14 @@ build_id_to_debug_filename (struct build
|
||||
*s++ = '/';
|
||||
while (size-- > 0)
|
||||
s += sprintf (s, "%02x", (unsigned) *data++);
|
||||
@ -640,7 +640,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
|
||||
if (retval != NULL && !build_id_verify (retval, build_id))
|
||||
{
|
||||
@@ -1289,9 +1686,150 @@ build_id_to_debug_filename (struct build
|
||||
@@ -1287,9 +1684,150 @@ build_id_to_debug_filename (struct build
|
||||
retval = NULL;
|
||||
}
|
||||
|
||||
@ -791,7 +791,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
static char *
|
||||
get_debug_link_info (struct objfile *objfile, unsigned long *crc32_out)
|
||||
{
|
||||
@@ -1374,32 +1912,36 @@ static char *
|
||||
@@ -1372,32 +1910,36 @@ static char *
|
||||
find_separate_debug_file (struct objfile *objfile)
|
||||
{
|
||||
asection *sect;
|
||||
@ -836,7 +836,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
}
|
||||
|
||||
basename = get_debug_link_info (objfile, &crc32);
|
||||
@@ -1407,7 +1949,7 @@ find_separate_debug_file (struct objfile
|
||||
@@ -1405,7 +1947,7 @@ find_separate_debug_file (struct objfile
|
||||
if (basename == NULL)
|
||||
/* There's no separate debug info, hence there's no way we could
|
||||
load it => no warning. */
|
||||
@ -845,7 +845,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
|
||||
dir = xstrdup (objfile->name);
|
||||
|
||||
@@ -1429,24 +1971,19 @@ find_separate_debug_file (struct objfile
|
||||
@@ -1427,24 +1969,19 @@ find_separate_debug_file (struct objfile
|
||||
if (canon_name && strlen (canon_name) > i)
|
||||
i = strlen (canon_name);
|
||||
|
||||
@ -877,7 +877,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
|
||||
/* Then try in the subdirectory named DEBUG_SUBDIRECTORY. */
|
||||
strcpy (debugfile, dir);
|
||||
@@ -1455,12 +1992,7 @@ find_separate_debug_file (struct objfile
|
||||
@@ -1453,12 +1990,7 @@ find_separate_debug_file (struct objfile
|
||||
strcat (debugfile, basename);
|
||||
|
||||
if (separate_debug_file_exists (debugfile, crc32, objfile->name))
|
||||
@ -891,7 +891,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
|
||||
/* Then try in the global debugfile directory. */
|
||||
strcpy (debugfile, debug_file_directory);
|
||||
@@ -1469,12 +2001,7 @@ find_separate_debug_file (struct objfile
|
||||
@@ -1467,12 +1999,7 @@ find_separate_debug_file (struct objfile
|
||||
strcat (debugfile, basename);
|
||||
|
||||
if (separate_debug_file_exists (debugfile, crc32, objfile->name))
|
||||
@ -905,7 +905,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
|
||||
/* If the file is in the sysroot, try using its base path in the
|
||||
global debugfile directory. */
|
||||
@@ -1488,21 +2015,18 @@ find_separate_debug_file (struct objfile
|
||||
@@ -1486,20 +2013,18 @@ find_separate_debug_file (struct objfile
|
||||
strcat (debugfile, basename);
|
||||
|
||||
if (separate_debug_file_exists (debugfile, crc32, objfile->name))
|
||||
@ -913,7 +913,6 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
- xfree (canon_name);
|
||||
- xfree (basename);
|
||||
- xfree (dir);
|
||||
- xfree (canon_name);
|
||||
- return xstrdup (debugfile);
|
||||
- }
|
||||
+ goto cleanup_return_debugfile;
|
||||
@ -934,7 +933,7 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
}
|
||||
|
||||
|
||||
@@ -4254,4 +4778,16 @@ Show printing of symbol loading messages
|
||||
@@ -4255,4 +4780,16 @@ Show printing of symbol loading messages
|
||||
NULL,
|
||||
NULL,
|
||||
&setprintlist, &showprintlist);
|
||||
@ -951,10 +950,10 @@ Index: gdb-6.8.50.20090809/gdb/symfile.c
|
||||
+
|
||||
+ observer_attach_executable_changed (debug_print_executable_changed);
|
||||
}
|
||||
Index: gdb-6.8.50.20090809/gdb/symfile.h
|
||||
Index: gdb-6.8.50.20090818/gdb/symfile.h
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090809.orig/gdb/symfile.h 2009-08-10 00:50:30.000000000 +0200
|
||||
+++ gdb-6.8.50.20090809/gdb/symfile.h 2009-08-10 14:56:11.000000000 +0200
|
||||
--- gdb-6.8.50.20090818.orig/gdb/symfile.h 2009-08-18 21:07:04.000000000 +0200
|
||||
+++ gdb-6.8.50.20090818/gdb/symfile.h 2009-08-18 21:07:23.000000000 +0200
|
||||
@@ -388,6 +388,13 @@ extern int symfile_map_offsets_to_segmen
|
||||
struct symfile_segment_data *get_symfile_segment_data (bfd *abfd);
|
||||
void free_symfile_segment_data (struct symfile_segment_data *data);
|
||||
@ -969,10 +968,10 @@ Index: gdb-6.8.50.20090809/gdb/symfile.h
|
||||
/* From dwarf2read.c */
|
||||
|
||||
extern int dwarf2_has_info (struct objfile *);
|
||||
Index: gdb-6.8.50.20090809/gdb/testsuite/lib/gdb.exp
|
||||
Index: gdb-6.8.50.20090818/gdb/testsuite/lib/gdb.exp
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090809.orig/gdb/testsuite/lib/gdb.exp 2009-08-10 00:50:30.000000000 +0200
|
||||
+++ gdb-6.8.50.20090809/gdb/testsuite/lib/gdb.exp 2009-08-10 14:56:11.000000000 +0200
|
||||
--- gdb-6.8.50.20090818.orig/gdb/testsuite/lib/gdb.exp 2009-08-18 21:07:04.000000000 +0200
|
||||
+++ gdb-6.8.50.20090818/gdb/testsuite/lib/gdb.exp 2009-08-18 21:07:23.000000000 +0200
|
||||
@@ -1248,6 +1248,16 @@ proc default_gdb_start { } {
|
||||
warning "Couldn't set the width to 0."
|
||||
}
|
||||
@ -990,10 +989,10 @@ Index: gdb-6.8.50.20090809/gdb/testsuite/lib/gdb.exp
|
||||
return 0;
|
||||
}
|
||||
|
||||
Index: gdb-6.8.50.20090809/gdb/testsuite/lib/mi-support.exp
|
||||
Index: gdb-6.8.50.20090818/gdb/testsuite/lib/mi-support.exp
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090809.orig/gdb/testsuite/lib/mi-support.exp 2009-08-10 00:50:30.000000000 +0200
|
||||
+++ gdb-6.8.50.20090809/gdb/testsuite/lib/mi-support.exp 2009-08-10 14:56:11.000000000 +0200
|
||||
--- gdb-6.8.50.20090818.orig/gdb/testsuite/lib/mi-support.exp 2009-08-18 21:07:04.000000000 +0200
|
||||
+++ gdb-6.8.50.20090818/gdb/testsuite/lib/mi-support.exp 2009-08-18 21:07:23.000000000 +0200
|
||||
@@ -221,6 +221,16 @@ proc default_mi_gdb_start { args } {
|
||||
}
|
||||
}
|
||||
|
5
gdb.spec
5
gdb.spec
@ -14,7 +14,7 @@ Version: 6.8.50.20090818
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 1%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 2%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -821,6 +821,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Aug 18 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090818-2
|
||||
- Fix patch fuzz 0.
|
||||
|
||||
* Tue Aug 18 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090818-1
|
||||
- Upgrade to the FSF GDB gdb-6.8.50 snapshot: 6.8.50.20090818
|
||||
- archer-jankratochvil-fedora12 commit: 5e0d1cc74f119391a2c3ae25ef5749fc28674f06
|
||||
|
Loading…
Reference in New Issue
Block a user