- Upgrade to the FSF GDB gdb-6.8.50 snapshot: 6.8.50.20090818
- archer-jankratochvil-fedora12 commit: 5e0d1cc74f119391a2c3ae25ef5749fc28674f06
This commit is contained in:
parent
2280d5542d
commit
a97b573f83
@ -1 +1 @@
|
||||
gdb-6.8.50.20090811.tar.bz2
|
||||
gdb-6.8.50.20090818.tar.bz2
|
||||
|
@ -11,10 +11,10 @@
|
||||
|
||||
* gdb.texinfo (File Options): Document --readnever.
|
||||
|
||||
Index: gdb-6.8.50.20090802/gdb/doc/gdb.texinfo
|
||||
Index: gdb-6.8.50.20090811/gdb/doc/gdb.texinfo
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090802.orig/gdb/doc/gdb.texinfo 2009-08-03 09:50:57.000000000 +0200
|
||||
+++ gdb-6.8.50.20090802/gdb/doc/gdb.texinfo 2009-08-03 12:29:58.000000000 +0200
|
||||
--- gdb-6.8.50.20090811.orig/gdb/doc/gdb.texinfo 2009-08-13 10:14:15.000000000 +0200
|
||||
+++ gdb-6.8.50.20090811/gdb/doc/gdb.texinfo 2009-08-13 10:14:18.000000000 +0200
|
||||
@@ -991,6 +991,12 @@ Read each symbol file's entire symbol ta
|
||||
the default, which is to read it incrementally as it is needed.
|
||||
This makes startup slower, but makes future operations faster.
|
||||
@ -28,10 +28,10 @@ Index: gdb-6.8.50.20090802/gdb/doc/gdb.texinfo
|
||||
@end table
|
||||
|
||||
@node Mode Options
|
||||
Index: gdb-6.8.50.20090802/gdb/main.c
|
||||
Index: gdb-6.8.50.20090811/gdb/main.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090802.orig/gdb/main.c 2009-08-03 12:29:03.000000000 +0200
|
||||
+++ gdb-6.8.50.20090802/gdb/main.c 2009-08-03 12:29:58.000000000 +0200
|
||||
--- gdb-6.8.50.20090811.orig/gdb/main.c 2009-08-13 10:14:15.000000000 +0200
|
||||
+++ gdb-6.8.50.20090811/gdb/main.c 2009-08-13 10:14:18.000000000 +0200
|
||||
@@ -382,6 +382,7 @@ captured_main (void *data)
|
||||
{"xdb", no_argument, &xdb_commands, 1},
|
||||
{"dbx", no_argument, &dbx_commands, 1},
|
||||
@ -48,11 +48,11 @@ Index: gdb-6.8.50.20090802/gdb/main.c
|
||||
"), stream);
|
||||
fputs_unfiltered (_("\
|
||||
--se=FILE Use FILE as symbol file and executable file.\n\
|
||||
Index: gdb-6.8.50.20090802/gdb/symfile.c
|
||||
Index: gdb-6.8.50.20090811/gdb/symfile.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090802.orig/gdb/symfile.c 2009-08-03 12:28:14.000000000 +0200
|
||||
+++ gdb-6.8.50.20090802/gdb/symfile.c 2009-08-03 12:29:58.000000000 +0200
|
||||
@@ -78,6 +78,7 @@ static void clear_symtab_users_cleanup (
|
||||
--- gdb-6.8.50.20090811.orig/gdb/symfile.c 2009-08-13 10:14:15.000000000 +0200
|
||||
+++ gdb-6.8.50.20090811/gdb/symfile.c 2009-08-13 10:14:18.000000000 +0200
|
||||
@@ -79,6 +79,7 @@ static void clear_symtab_users_cleanup (
|
||||
|
||||
/* Global variables owned by this file */
|
||||
int readnow_symbol_files; /* Read full symbols immediately */
|
||||
@ -60,19 +60,19 @@ Index: gdb-6.8.50.20090802/gdb/symfile.c
|
||||
|
||||
/* External variables and functions referenced. */
|
||||
|
||||
Index: gdb-6.8.50.20090802/gdb/dwarf2read.c
|
||||
Index: gdb-6.8.50.20090811/gdb/dwarf2read.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090802.orig/gdb/dwarf2read.c 2009-08-03 09:50:57.000000000 +0200
|
||||
+++ gdb-6.8.50.20090802/gdb/dwarf2read.c 2009-08-03 12:31:01.000000000 +0200
|
||||
@@ -52,6 +52,7 @@
|
||||
#include "jv-lang.h"
|
||||
--- gdb-6.8.50.20090811.orig/gdb/dwarf2read.c 2009-08-13 10:14:15.000000000 +0200
|
||||
+++ gdb-6.8.50.20090811/gdb/dwarf2read.c 2009-08-13 10:14:29.000000000 +0200
|
||||
@@ -53,6 +53,7 @@
|
||||
#include "typeprint.h"
|
||||
#include "vec.h"
|
||||
#include "block.h"
|
||||
+#include "top.h"
|
||||
|
||||
#include <fcntl.h>
|
||||
#include "gdb_string.h"
|
||||
@@ -1225,7 +1226,8 @@ dwarf2_has_info (struct objfile *objfile
|
||||
@@ -1245,7 +1246,8 @@ dwarf2_has_info (struct objfile *objfile
|
||||
|
||||
bfd_map_over_sections (objfile->obfd, dwarf2_locate_sections, NULL);
|
||||
}
|
||||
@ -82,10 +82,10 @@ Index: gdb-6.8.50.20090802/gdb/dwarf2read.c
|
||||
&& dwarf2_per_objfile->abbrev.asection != NULL);
|
||||
}
|
||||
|
||||
Index: gdb-6.8.50.20090802/gdb/top.h
|
||||
Index: gdb-6.8.50.20090811/gdb/top.h
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090802.orig/gdb/top.h 2009-01-03 06:57:53.000000000 +0100
|
||||
+++ gdb-6.8.50.20090802/gdb/top.h 2009-08-03 12:29:58.000000000 +0200
|
||||
--- gdb-6.8.50.20090811.orig/gdb/top.h 2009-01-03 06:57:53.000000000 +0100
|
||||
+++ gdb-6.8.50.20090811/gdb/top.h 2009-08-13 10:14:18.000000000 +0200
|
||||
@@ -59,6 +59,7 @@ extern void set_prompt (char *);
|
||||
|
||||
/* From random places. */
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,8 +1,8 @@
|
||||
Index: gdb-6.8.50.20090803/gdb/dwarf2read.c
|
||||
Index: gdb-6.8.50.20090811/gdb/dwarf2read.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090803.orig/gdb/dwarf2read.c 2009-08-04 06:32:58.000000000 +0200
|
||||
+++ gdb-6.8.50.20090803/gdb/dwarf2read.c 2009-08-04 06:33:18.000000000 +0200
|
||||
@@ -2459,6 +2459,7 @@ scan_partial_symbols (struct partial_die
|
||||
--- gdb-6.8.50.20090811.orig/gdb/dwarf2read.c 2009-08-13 10:14:45.000000000 +0200
|
||||
+++ gdb-6.8.50.20090811/gdb/dwarf2read.c 2009-08-13 10:22:36.000000000 +0200
|
||||
@@ -2480,6 +2480,7 @@ scan_partial_symbols (struct partial_die
|
||||
add_partial_subprogram (pdi, lowpc, highpc, need_pc, cu);
|
||||
break;
|
||||
case DW_TAG_variable:
|
||||
@ -10,7 +10,7 @@ Index: gdb-6.8.50.20090803/gdb/dwarf2read.c
|
||||
case DW_TAG_typedef:
|
||||
case DW_TAG_union_type:
|
||||
if (!pdi->is_declaration)
|
||||
@@ -2654,6 +2655,7 @@ add_partial_symbol (struct partial_die_i
|
||||
@@ -2675,6 +2676,7 @@ add_partial_symbol (struct partial_die_i
|
||||
}
|
||||
break;
|
||||
case DW_TAG_variable:
|
||||
@ -18,7 +18,15 @@ Index: gdb-6.8.50.20090803/gdb/dwarf2read.c
|
||||
if (pdi->is_external)
|
||||
{
|
||||
/* Global Variable.
|
||||
@@ -4790,7 +4792,8 @@ dwarf2_add_field (struct field_info *fip
|
||||
@@ -2805,6 +2807,7 @@ die_needs_namespace (struct die_info *di
|
||||
return 1;
|
||||
|
||||
case DW_TAG_variable:
|
||||
+ case DW_TAG_constant:
|
||||
{
|
||||
struct attribute *attr;
|
||||
attr = dwarf2_attr (die, DW_AT_specification, cu);
|
||||
@@ -4741,7 +4744,8 @@ dwarf2_add_field (struct field_info *fip
|
||||
fip->non_public_fields = 1;
|
||||
}
|
||||
}
|
||||
@ -28,7 +36,7 @@ Index: gdb-6.8.50.20090803/gdb/dwarf2read.c
|
||||
{
|
||||
/* C++ static member. */
|
||||
|
||||
@@ -5297,7 +5300,8 @@ read_structure_type (struct die_info *di
|
||||
@@ -5233,7 +5237,8 @@ read_structure_type (struct die_info *di
|
||||
while (child_die && child_die->tag)
|
||||
{
|
||||
if (child_die->tag == DW_TAG_member
|
||||
@ -38,7 +46,7 @@ Index: gdb-6.8.50.20090803/gdb/dwarf2read.c
|
||||
{
|
||||
/* NOTE: carlton/2002-11-05: A C++ static data member
|
||||
should be a DW_TAG_member that is a declaration, but
|
||||
@@ -5416,6 +5420,7 @@ process_structure_scope (struct die_info
|
||||
@@ -5352,6 +5357,7 @@ process_structure_scope (struct die_info
|
||||
{
|
||||
if (child_die->tag == DW_TAG_member
|
||||
|| child_die->tag == DW_TAG_variable
|
||||
@ -46,15 +54,15 @@ Index: gdb-6.8.50.20090803/gdb/dwarf2read.c
|
||||
|| child_die->tag == DW_TAG_inheritance)
|
||||
{
|
||||
/* Do nothing. */
|
||||
@@ -6926,6 +6931,7 @@ load_partial_dies (bfd *abfd, gdb_byte *
|
||||
@@ -6980,6 +6986,7 @@ load_partial_dies (bfd *abfd, gdb_byte *
|
||||
&& abbrev->tag != DW_TAG_subprogram
|
||||
&& abbrev->tag != DW_TAG_lexical_block
|
||||
&& abbrev->tag != DW_TAG_variable
|
||||
+ && abbrev->tag != DW_TAG_constant
|
||||
&& abbrev->tag != DW_TAG_namespace
|
||||
&& abbrev->tag != DW_TAG_module
|
||||
&& abbrev->tag != DW_TAG_member)
|
||||
{
|
||||
@@ -7033,6 +7039,7 @@ load_partial_dies (bfd *abfd, gdb_byte *
|
||||
@@ -7088,6 +7095,7 @@ load_partial_dies (bfd *abfd, gdb_byte *
|
||||
if (load_all
|
||||
|| abbrev->tag == DW_TAG_subprogram
|
||||
|| abbrev->tag == DW_TAG_variable
|
||||
@ -62,7 +70,7 @@ Index: gdb-6.8.50.20090803/gdb/dwarf2read.c
|
||||
|| abbrev->tag == DW_TAG_namespace
|
||||
|| part_die->is_declaration)
|
||||
{
|
||||
@@ -8840,6 +8847,11 @@ new_symbol (struct die_info *die, struct
|
||||
@@ -8901,6 +8909,11 @@ new_symbol (struct die_info *die, struct
|
||||
/* Do not add the symbol to any lists. It will be found via
|
||||
BLOCK_FUNCTION from the blockvector. */
|
||||
break;
|
||||
|
2590
gdb-archer.patch
2590
gdb-archer.patch
File diff suppressed because it is too large
Load Diff
18
gdb.spec
18
gdb.spec
@ -10,11 +10,11 @@ Name: gdb%{?_with_debug:-debug}
|
||||
# Set version to contents of gdb/version.in.
|
||||
# NOTE: the FSF gdb versions are numbered N.M for official releases, like 6.3
|
||||
# and, since January 2005, X.Y.Z.date for daily snapshots, like 6.3.50.20050112 # (daily snapshot from mailine), or 6.3.0.20040112 (head of the release branch).
|
||||
Version: 6.8.50.20090811
|
||||
Version: 6.8.50.20090818
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 4%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 1%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -218,8 +218,8 @@ Patch229: gdb-6.3-bz140532-ppc-unwinding-test.patch
|
||||
# Testcase for exec() from threaded program (BZ 202689).
|
||||
Patch231: gdb-6.3-bz202689-exec-from-pthread-test.patch
|
||||
|
||||
# Backported post gdb-6.8.50.20090811 snapshot fixups.
|
||||
#Patch232: gdb-6.8.50.20090811-upstream.patch
|
||||
# Backported post gdb-6.8.50.20090818 snapshot fixups.
|
||||
#Patch232: gdb-6.8.50.20090818-upstream.patch
|
||||
|
||||
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
|
||||
Patch234: gdb-6.6-bz230000-power6-disassembly-test.patch
|
||||
@ -265,11 +265,6 @@ Patch271: gdb-6.5-bz243845-stale-testing-zombie-test.patch
|
||||
Patch274: gdb-6.6-buildid-locate.patch
|
||||
Patch353: gdb-6.6-buildid-locate-rpm.patch
|
||||
|
||||
# Fix hardware watchpoints after inferior forks-off some process.
|
||||
# Threaded `set follow-fork-mode child' still not fixed there, glibc fixes reqd.
|
||||
# `set detach-on-fork off' not fixed there in general - it already assert-fails.
|
||||
Patch280: gdb-6.6-multifork-debugreg.patch
|
||||
|
||||
# Fix displaying of numeric char arrays as strings (BZ 224128).
|
||||
Patch282: gdb-6.7-charsign-test.patch
|
||||
|
||||
@ -521,7 +516,6 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
%patch271 -p1
|
||||
%patch274 -p1
|
||||
%patch353 -p1
|
||||
%patch280 -p1
|
||||
%patch282 -p1
|
||||
%patch284 -p1
|
||||
%patch287 -p1
|
||||
@ -827,6 +821,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Aug 18 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090818-1
|
||||
- Upgrade to the FSF GDB gdb-6.8.50 snapshot: 6.8.50.20090818
|
||||
- archer-jankratochvil-fedora12 commit: 5e0d1cc74f119391a2c3ae25ef5749fc28674f06
|
||||
|
||||
* Wed Aug 12 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090811-4
|
||||
- Fix minor regressions introduced by the rebase from F-11 (6.8.50.20090302).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user