Fix gdb.arch/amd64-entry-value-paramref.exp rebase regression.
This commit is contained in:
parent
f9739f5031
commit
b1807ab4e1
@ -31,35 +31,33 @@ Index: gdb-7.12.50.20170207/gdb/dwarf2loc.c
|
||||
===================================================================
|
||||
--- gdb-7.12.50.20170207.orig/gdb/dwarf2loc.c 2017-02-16 23:31:53.977893289 +0100
|
||||
+++ gdb-7.12.50.20170207/gdb/dwarf2loc.c 2017-02-16 23:37:44.625522081 +0100
|
||||
@@ -2285,6 +2285,12 @@
|
||||
@@ -42,6 +42,7 @@
|
||||
#include <algorithm>
|
||||
#include <vector>
|
||||
#include <unordered_set>
|
||||
+#include <functional>
|
||||
|
||||
extern int dwarf_always_disassemble;
|
||||
|
||||
@@ -2350,6 +2350,18 @@ dwarf2_evaluate_loc_desc_full (struct ty
|
||||
ctx.per_cu = per_cu;
|
||||
ctx.obj_address = 0;
|
||||
|
||||
+struct frame_info *old_frame (deprecated_safe_get_selected_frame ());
|
||||
+TRY
|
||||
+ {
|
||||
+ if (frame != NULL)
|
||||
+ select_frame (frame);
|
||||
+class RestoreCall {
|
||||
+private:
|
||||
+ const std::function<void ()> func;
|
||||
+public:
|
||||
+ RestoreCall(std::function<void ()> func_):func(func_) {}
|
||||
+ ~RestoreCall() { func(); }
|
||||
+} restore_frame([&]() {
|
||||
+ select_frame (old_frame);
|
||||
+});
|
||||
+if (frame != NULL) select_frame (frame);
|
||||
+
|
||||
scoped_value_mark free_values;
|
||||
|
||||
ctx.gdbarch = get_objfile_arch (objfile);
|
||||
@@ -2471,6 +2477,15 @@
|
||||
|
||||
set_value_initialized (retval, ctx.initialized);
|
||||
|
||||
+ }
|
||||
+CATCH (ex, RETURN_MASK_ALL)
|
||||
+ {
|
||||
+ select_frame (old_frame);
|
||||
+ throw_exception (ex);
|
||||
+ }
|
||||
+END_CATCH
|
||||
+select_frame (old_frame);
|
||||
+
|
||||
return retval;
|
||||
}
|
||||
|
||||
Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.fortran/dynamic-other-frame-stub.f90
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
|
7
gdb.spec
7
gdb.spec
@ -26,7 +26,7 @@ Version: 7.12.50.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -1578,8 +1578,11 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Tue Feb 28 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.12.50.20170226-3.fc26
|
||||
- Fix gdb.arch/amd64-entry-value-paramref.exp rebase regression.
|
||||
|
||||
* Tue Feb 28 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.12.50.20170226-2.fc26
|
||||
- [rhel] Fix gdb.python/py-gil-mthread.exp for Python 2 compat. (RH BZ 1427487).
|
||||
- [testsuite] [rhel] Fix py-gil-mthread.exp for Python 2 compat (RH BZ 1427487).
|
||||
|
||||
* Mon Feb 27 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.12.50.20170226-1.fc26
|
||||
- Rebase to pre-7.13 FSF GDB trunk.
|
||||
|
Loading…
Reference in New Issue
Block a user