[rhel] Fix gdb.python/py-gil-mthread.exp for Python 2 compat. (RH BZ 1427487).
This commit is contained in:
parent
af2c2a5422
commit
f9739f5031
@ -1,8 +1,8 @@
|
||||
Index: gdb-7.12.50.20170207/gdb/doc/python.texi
|
||||
Index: gdb-7.12.50.20170226/gdb/doc/python.texi
|
||||
===================================================================
|
||||
--- gdb-7.12.50.20170207.orig/gdb/doc/python.texi 2017-02-26 21:03:56.414161880 +0100
|
||||
+++ gdb-7.12.50.20170207/gdb/doc/python.texi 2017-02-26 21:03:57.448169033 +0100
|
||||
@@ -229,6 +229,14 @@
|
||||
--- gdb-7.12.50.20170226.orig/gdb/doc/python.texi 2017-02-28 16:06:13.508969181 +0100
|
||||
+++ gdb-7.12.50.20170226/gdb/doc/python.texi 2017-02-28 16:06:14.958979480 +0100
|
||||
@@ -230,6 +230,14 @@
|
||||
return value is @code{None}. If @var{to_string} is @code{True}, the
|
||||
@value{GDBN} virtual terminal will be temporarily set to unlimited width
|
||||
and height, and its pagination will be disabled; @pxref{Screen Size}.
|
||||
@ -17,11 +17,11 @@ Index: gdb-7.12.50.20170207/gdb/doc/python.texi
|
||||
@end defun
|
||||
|
||||
@findex gdb.breakpoints
|
||||
Index: gdb-7.12.50.20170207/gdb/python/python-internal.h
|
||||
Index: gdb-7.12.50.20170226/gdb/python/python-internal.h
|
||||
===================================================================
|
||||
--- gdb-7.12.50.20170207.orig/gdb/python/python-internal.h 2017-02-26 21:03:56.415161887 +0100
|
||||
+++ gdb-7.12.50.20170207/gdb/python/python-internal.h 2017-02-26 21:03:57.448169033 +0100
|
||||
@@ -140,6 +140,8 @@
|
||||
--- gdb-7.12.50.20170226.orig/gdb/python/python-internal.h 2017-02-28 16:06:13.510969195 +0100
|
||||
+++ gdb-7.12.50.20170226/gdb/python/python-internal.h 2017-02-28 16:06:14.958979480 +0100
|
||||
@@ -142,6 +142,8 @@
|
||||
#define PyGILState_Release(ARG) ((void)(ARG))
|
||||
#define PyEval_InitThreads()
|
||||
#define PyThreadState_Swap(ARG) ((void)(ARG))
|
||||
@ -30,11 +30,11 @@ Index: gdb-7.12.50.20170207/gdb/python/python-internal.h
|
||||
#define PyEval_ReleaseLock()
|
||||
#endif
|
||||
|
||||
Index: gdb-7.12.50.20170207/gdb/python/python.c
|
||||
Index: gdb-7.12.50.20170226/gdb/python/python.c
|
||||
===================================================================
|
||||
--- gdb-7.12.50.20170207.orig/gdb/python/python.c 2017-02-26 21:03:56.416161894 +0100
|
||||
+++ gdb-7.12.50.20170207/gdb/python/python.c 2017-02-26 21:09:23.252423095 +0100
|
||||
@@ -595,12 +595,16 @@
|
||||
--- gdb-7.12.50.20170226.orig/gdb/python/python.c 2017-02-28 16:06:13.510969195 +0100
|
||||
+++ gdb-7.12.50.20170226/gdb/python/python.c 2017-02-28 16:06:14.959979487 +0100
|
||||
@@ -596,12 +596,16 @@
|
||||
{
|
||||
const char *arg;
|
||||
PyObject *from_tty_obj = NULL, *to_string_obj = NULL;
|
||||
@ -55,7 +55,7 @@ Index: gdb-7.12.50.20170207/gdb/python/python.c
|
||||
return NULL;
|
||||
|
||||
from_tty = 0;
|
||||
@@ -621,6 +625,15 @@
|
||||
@@ -622,6 +626,15 @@
|
||||
to_string = cmp;
|
||||
}
|
||||
|
||||
@ -71,7 +71,7 @@ Index: gdb-7.12.50.20170207/gdb/python/python.c
|
||||
std::string to_string_res;
|
||||
|
||||
TRY
|
||||
@@ -629,6 +642,13 @@
|
||||
@@ -630,6 +643,13 @@
|
||||
std::string copy (arg);
|
||||
struct interp *interp;
|
||||
|
||||
@ -85,7 +85,7 @@ Index: gdb-7.12.50.20170207/gdb/python/python.c
|
||||
scoped_restore save_async = make_scoped_restore (¤t_ui->async, 0);
|
||||
|
||||
scoped_restore save_uiout = make_scoped_restore (¤t_uiout);
|
||||
@@ -643,10 +663,22 @@
|
||||
@@ -644,10 +664,22 @@
|
||||
to_string_res = execute_command_to_string (©[0], from_tty);
|
||||
else
|
||||
execute_command (©[0], from_tty);
|
||||
@ -109,10 +109,10 @@ Index: gdb-7.12.50.20170207/gdb/python/python.c
|
||||
}
|
||||
END_CATCH
|
||||
|
||||
Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.python/py-gil-mthread.c
|
||||
Index: gdb-7.12.50.20170226/gdb/testsuite/gdb.python/py-gil-mthread.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.12.50.20170207/gdb/testsuite/gdb.python/py-gil-mthread.c 2017-02-26 21:03:57.450169047 +0100
|
||||
+++ gdb-7.12.50.20170226/gdb/testsuite/gdb.python/py-gil-mthread.c 2017-02-28 16:06:14.959979487 +0100
|
||||
@@ -0,0 +1,13 @@
|
||||
+#include <stdio.h>
|
||||
+#include <unistd.h>
|
||||
@ -127,10 +127,10 @@ Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.python/py-gil-mthread.c
|
||||
+ printf ("Sleeping %d\n", i);
|
||||
+ }
|
||||
+}
|
||||
Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.python/py-gil-mthread.exp
|
||||
Index: gdb-7.12.50.20170226/gdb/testsuite/gdb.python/py-gil-mthread.exp
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.12.50.20170207/gdb/testsuite/gdb.python/py-gil-mthread.exp 2017-02-26 21:03:57.450169047 +0100
|
||||
+++ gdb-7.12.50.20170226/gdb/testsuite/gdb.python/py-gil-mthread.exp 2017-02-28 16:06:14.959979487 +0100
|
||||
@@ -0,0 +1,69 @@
|
||||
+# Copyright (C) 2014 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -201,10 +201,10 @@ Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.python/py-gil-mthread.exp
|
||||
+ }
|
||||
+ }
|
||||
+}
|
||||
Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.python/py-gil-mthread.py
|
||||
Index: gdb-7.12.50.20170226/gdb/testsuite/gdb.python/py-gil-mthread.py
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.12.50.20170207/gdb/testsuite/gdb.python/py-gil-mthread.py 2017-02-26 21:03:57.450169047 +0100
|
||||
+++ gdb-7.12.50.20170226/gdb/testsuite/gdb.python/py-gil-mthread.py 2017-02-28 16:26:39.565085643 +0100
|
||||
@@ -0,0 +1,28 @@
|
||||
+try:
|
||||
+ import thread
|
||||
@ -219,7 +219,7 @@ Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.python/py-gil-mthread.py
|
||||
+ while count < 10:
|
||||
+ time.sleep(1)
|
||||
+ count += 1
|
||||
+ print ("Hello (", count, ")")
|
||||
+ print ("Hello ( %d )" % count)
|
||||
+
|
||||
+# Create a threads a continue
|
||||
+try:
|
||||
|
5
gdb.spec
5
gdb.spec
@ -26,7 +26,7 @@ Version: 7.12.50.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -1578,6 +1578,9 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Tue Feb 28 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.12.50.20170226-2.fc26
|
||||
- [rhel] Fix gdb.python/py-gil-mthread.exp for Python 2 compat. (RH BZ 1427487).
|
||||
|
||||
* Mon Feb 27 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.12.50.20170226-1.fc26
|
||||
- Rebase to pre-7.13 FSF GDB trunk.
|
||||
- Dropped gdb-6.7-bz426600-DW_TAG_interface_type-test.patch as GCJ is no more.
|
||||
|
Loading…
Reference in New Issue
Block a user